1. Check out our app, Forums for Android! Download and leave feedback here!

Support Navigation + Car Charger + Car Dock = Battery Drain?

Discussion in 'Android Devices' started by chinatti, Jul 18, 2010.

  1. chinatti

    chinatti Member
    Thread Starter
    15

    Jul 14, 2010
    15
    0
    15
    When I have my DroidX plugged into the Car Dock and am using the navigation app it seems to drain the battery, even though it indicates that the battery is charging. Does anyone else see this?

    I've tried both an older Verizon branded Micro-USB car charger (from an old blackberry), and also a new Motorola P513 charger ($6 on amazon). I have not tried the new charger that Verizon is selling for the DroidX (although it may just be the same as the one I had for my BB).

    If I have the phone in the car dock, without the nav app running, it charges. With the nav app running, it still indicates charging, but the battery level drops.

    In any event, I'm wondering if maybe I need a higher current charger? If so, I'm not even sure how to determine which charger will be able to supply enough to charge (or at a minimum, not drain) the battery...

    Anyone have any ideas?

    Thanks in advance...
     

    Advertisement

  2. xx DROiD ERiS xx

    xx DROiD ERiS xx Well-Known Member
    36

    Jan 1, 2010
    180
    6
    36
    Toyota Service Writer
    Jerseyy
    if you havent noticed quite a few people are bringing up the droid x battery status inaccuracy. tomorrows update will likely bring about some positive change in regard to the driod x stock software
     
  3. jdaud

    jdaud Well-Known Member
    73

    Jun 30, 2010
    144
    69
    73
    Ohio
    I also found the same issue. My family took a 2 hour trip and I used the navigation on my new Droid X only to be left with a 40% charge on the battery. (Used Verizon car charger):mad:
     
  4. dlbrando

    dlbrando Well-Known Member
    16

    Jul 16, 2010
    78
    5
    16
    Air Force WSO
    Pensacola
    I saw another thread on this and checked mine out today. It seemed to work just fine, at least the battery indicator showed a charge. Now, I had to fiddle with the plug a little bit to get it to work just right, so is it possible that it could be on the other end of your plug?
     
  5. chinatti

    chinatti Member
    Thread Starter
    15

    Jul 14, 2010
    15
    0
    15
    I doubt it, since the phone shows "charging", and when nav is not running the charging actually seems to happen. Oh well, hopefully the SW update will fix the problem.....
     
  6. chinatti

    chinatti Member
    Thread Starter
    15

    Jul 14, 2010
    15
    0
    15
    Update 604 seems to have fixed this for me. I can now charge the phone while using Nav in the car dock, and the battery capacity percentage actually increases .... Woo-Hoo!
     

Share This Page

Loading...