1. Are you ready for the Galaxy S20? Here is everything we know so far!

Navigation self opening! please help!

Discussion in 'Android Devices' started by Bisho487, Apr 23, 2012.

  1. Bisho487

    Bisho487 Lurker
    Thread Starter

    Good day there, not sure if this is a Desire HD exclusive problem but nevertheless - here I am.

    I am being driven to the point of near insanity by the HTC app "Navigation" It is opening itself every 15-30 seconds, during calls, during apps, during web browsing, during videos - EVERYTHING. It just never stops coming, I have tried many a time to kill it with Task Manager, but it is of little use. No matter what I do or what I try it opens with the message "You need a licence to finish this trip" I don't know what to do, it's preventing my phone from sleeping, so if I take it to work for an 8 hour shift it damn near kills the battery without me using it - It's just permanently in the top left of my screen as an ongoing app with the message "tap to return to navigation". I should mention this has happened before, it lasted 2 days before it decided to fix itself, this time however, I've been waiting a full week.

    Does ANYONE have ANY suggestions? I really don't want to have to boot my phone in HDD mode and delete the .data folder.

    Thank you in advance.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Harry2

    Harry2 Extreme Android User

    Start the Car Panel app, tap Settings and Car kit and uncheck Auto-launch.

    If you updated your DHD to the latest Android version this Car Panel app might not there any more.

    Note, this HTC navigation will be triggered from a coding of a car kits's microUSB plug.
    It's a resistance between pins 4&5.

    Dirt can be a resistance.
    So, you might have a close look at your phone's microUSB socket and clean it with some pressured air.

    Harry
     
  3. lucids

    lucids Well-Known Member

    OMG this just started happening to me too about an hour ago. I've not had it connected to a car kit or anything. It just keeps opening the premium navigation that then wants to enter/buy a licence. If I exit it just starts again. Even if i switch the phone off and pull the battery and restart it still does it on restart.

    There was a maps update yesterday I thought that was just google, could that have triggered this?

    Help its driving me insane!! I don't want to have to reset...:eek::eek:

    Looking in super tools task killer its showing its running locations twice.
    Killing those still the navigation icon top left of the screen.

    How can I stop this?
    AAAAAAAAAAAAAAAAAAAH

    I managed to get into the settings for this while its running and there is no auto launch option. I have the latest android with no car panel. The phone hasn't been connected to anything other than the charger last night.

    Can I uninstall the premium navigation somehow?
     
  4. lucids

    lucids Well-Known Member

    I just rebooted and got an error message:

    Locations:

    "An error was encountered on your SD card"

    Now I know there is nothing wrong with the micro SD card as I took it out previously and backed it up and checked for errors in windows and it was all fine.
    Is there something on the card i can remove/delete to stop this?

    I removed all updates to "maps" before i shut down.

    Edit

    Looking on the SD card this is in a folder called ".data\navigator"
    This is down to the stupid Route 66 software. Will try deleting the folder from the SD card.

    Edit2
    I uninstalled map updates from within manage apps then deleted the UK and Ireland maps (totally about 500Mb) from within this recurring premium Nav app after going to the buy licence section.
    It then went back to the app with the map but verbally told me an error has occured (several times)..tell me about it!

    Now I note that when I did the last major gingerbread update the premium Nav returned to a months trial (that I had never used) but that is gone. So I reckon its something to do with that.

    Now it hasn't come back again after the map removal....
    Gonna restart the phone and try again.

    Got the locations error reported with SD card on boot up
    But so far no premium Nav starting. Going into Locations app doesn't kick it in either.
    Going to update the "maps" I uninstalled before.
    NB Not the the deleted premium app maps but the google "maps" app update from last night.

    Ok after updating Maps from google Play its started again....

    uninstalled map update, so back to factory and still doing it.
    Now to delete the Nav folder from the SD card completely.
     
  5. Harry2

    Harry2 Extreme Android User

    I take it that you had a close look at your phone's microUSB socket and didn't find any dirt ;)

    Also, you might try the little app 'Dock No-Op', free in Play Store.

    Harry
     
    lucids likes this.
  6. lucids

    lucids Well-Known Member

    its clean as far as i can see but gave it a blast of dust air to be safe...

    I removed the navigator folder from the .data folder on the SD and got the Location: Error with SD card on reboot.

    It then asked me to download 36Mb of files. I said "NO"

    Google Navigation seems working ok

    I then re downloaded the 36Mb it asked for and it re installed locations.

    Seems ok so far but I did notic that when i plugged it in the car charger which i know to be a USB as opposed to AC it reported as AC. And just before I went out when plugging into laptop I didn't have the option to change the connection type any more.

    But now thats back again. So maybe an issue with the micro USB or the locations app.

    I also now took a risk and started the location app (reinstalled) and went to the premium nav and got the buy licence screen, cancelled and the app shut down. It hasn't come back so think it's ok. (fingers crossed)

    Now i notice though that there is a slight hairline crack in the volume button.. now where can i source one of those sigh.
     
  7. lucids

    lucids Well-Known Member

    Sigh...its back again. Unlocked phone and there it was waiting the Nav app prompting for a licence. Plugged in USB to PC and no prompt for USB drive or charge screen so maybe I have a USB fault.
     
  8. porridgemummy

    porridgemummy Lurker

    Hi there,
    I have had this problem for a few weeks now and tried everything, even put back to factory settings and annoyingly lost all my paid for apps!!! AAARRRGGHHH the most annoying pop up thing ever.
    Anyway, I think I have just solved it very simply and keeping fingers crossed it won't come back.

    I swapped the charging cable with my husband who has the same phone and it isn't doing it any more. His cable is an official htc one with the sticker on..mine didn't have an htc sticker and was much shorter in length. It also seemed that the wires were a bit loose on it. So I would recommend that if you can order a new cable and try that before putting back to factory settings and losing stuff.

    Not had the problem for half an hour now and was popping up every few seconds before.
    good luck.x
     
  9. lucids

    lucids Well-Known Member

    I tried 3 USB leads including HTC ones, still no connection choice on attachment (though selected in settings)
    The problem is most likely with the USB pins on the DHD itself as mentioned earlier on the topic. It can be fine for ages then suddenly begin again with this stupid Route 66 software.

    Can't use HTC sync as it will only go in charge mode but using My Phone Explorer for back up. Come Monday I will be contacting HTC for a warranty repair of the USB connection.
     
  10. plakapong

    plakapong Lurker

    I have been having the same problems for a while now, car panel starting up randomly and when usb charger is inserted, no connection to htc sync, unable to use hdd mode, loudspeaker turning on randomly during calls. Tried all the fixes suggested and in the other thread about the car panel problem still no joy. I took the phone back to the shop today and they suggested I reload the latest ROM, Im not convinced this is the answer and they didn't believe me when I told them it was a fault with the usb connection and even demostrated it by inserting the mini usb end into the phone and wiggling it and hey presto, the car panel came up again...grrrr!!

    Any help gratefully received.

    cheers
     
  11. lucids

    lucids Well-Known Member

    Exactly the same as me, speaker coming on also as you said.

    mine is the latest gingerbread. Now if one factory resets i wonder whether it will return to the factory ROM, the one with the car panel. Then in its settings there is a tick box for auto launch, that's on by default. I checked on a brand new desire s yesterday before updating. Thus if one resets it might be worth unticking that box, then updating to new ROM with sense 3.

    If it still occurs then its definitely the USB pins shorting. Have a look on restart for a message that comes up from Locations saying there is a problem reading your SD card. I get that sometimes as well.
     
  12. plakapong

    plakapong Lurker

    Hi Lucids, I've tried the factory reset and that didn't fix the problem. I am now downloading 2.3 from HTC developer website using the HTC carrier EU version as I bought mine in Thailand and it had the India version, this version does not have the Dock option in settings so I was screwed there. I'll let you know if it's successful or if I brick the phone :eek:
     
  13. lucids

    lucids Well-Known Member

    So is your phone rooted ?
    Mine is unrooted with uk stock ROM. not tied to any provider as was SIM free so no custom firmware.

    I'm going to get a backup phone prob desire s, and transfer to that before resetting and testing. I'm pretty certain though mines the usb as it often kicks in when i insert a cable.

    Fortunately ADB is still working so my phone explorer back ups still working.

    I did a successful test of it and transferred messages and calendar from its back up of DHD to Desire S. The contacts i would do separately via the exported vcf and gmail.

    I'll report back after the reset to check whether it sorts it or not, now need to look at my warranty status.
     
  14. Mark67

    Mark67 Lurker

    Mine started playing up last week. Every time I put the phone on charge, the navigation popped up. Soon after, it just seemed to be on a loop cycle. Tried all the usual resets and deletions, but nothing worked.

    Finally sorted it by cleaning the USB socket with a (VERY) soft toothbrush. I gently placed the bristles in the socket and swept them back towards myself so not to push any dirt across the contact pins. Its been two days now and the problem is yet to return.

    It is worth noting though that my blackberry and Nokia leads would give all the usual options when used to link my phone to my laptop, but now, only my HTC lead offers the full suite of options.
     
  15. lucids

    lucids Well-Known Member

    Shortly after when i last posted mine suddenly returned to normal until a couple of weeks ago when it started again for about a week then just stopped once again. Madness!! The phone is unusable when in that state.
     
  16. baskr1

    baskr1 Lurker

  17. Xiggy

    Xiggy Lurker

    I called UK HTC tech support today after trying all the above fixes without success.

    I was told to do the following:

    Menu>Settings>Applications>Manage Applications>All (tab at top)>Navigation (not Navigation Launcher).

    There should then be an option to clear data. Select this option (I think it asks you to confirm) and then soft reset the phone by taking the battery out and turning back on.

    I tried the above 2 hours ago and so far so good.

    The tech support person also suggested turning off automatic updates to make certain the problem doesn't come back

    Menu>Settings>About Phone>Software Updates - uncheck scheduled check box.

    Hope this helps
     
  18. Smarty Party

    Smarty Party Lurker

    Hi all,

    I solved it!!

    I had this exact same problems for weeks. Locations kept opening AND speaker always on. It was driving me mad. I tried all the other things suggested on the forums. Cleared out data folder. Took out battery. installed some map switching app. Fail. Fail. Fail.Eventually I discovered it was simply caused by a dirty USB/charging slot. If some dirt is touching a certain two pins the phone thinks you have plugg ed in a car charger and triggers Sat Nav/speaker. The solution is to just carfully scrape out the slot using a pin. Mine LOOKED clean but in fact had about 2mm of compacted grime/pocket fluff which was shorting out the connections.

    Haven't had any problems since. Phone back to normal.

    YAY!
     
    pinkgirl1981, CDPlant and D-U-R-X like this.
  19. pinkgirl1981

    pinkgirl1981 Lurker

    I would never have believed a tiny speak of dust would cause such an annoyance with a phone! But out of sheer frustration I stuck a pin in the USB charging point and dug out a piece of fluff! Hooray! Normal service resumed once more. And I don't have to restore, reset, or get a new phone. :D
     
  20. shad0man

    shad0man Lurker

    Solved!!! Had this problem for a while now but for months I've had an issue with the charger falling out all the time - loose connection. I even asked Vodafone if they would fix it under warranty and they said they wouldn't. I have a long drive tomorrow and was worrying that the battery wouldn't last for navigation, as well as having the annoying premium navigation issue that kept popping up - which was why I came here. At last I found the solution after many months! Got a needle, cleaned out a ton of fluff! The chargers stay in! Was so close to spending
     
  21. shad0man

    shad0man Lurker

    P.S. Please be careful if trying this yourself - I actually just bent a pin inside and it wouldn't charge. Luckily I managed to move it back into place and it works ok now. Be gentle with removing any fluff!
     
  22. antonyd

    antonyd Lurker

    This was annoying me for 3 weeks, tried all the software solutions then came across your post! Thank you!!!!

     
  23. Harry2

    Harry2 Extreme Android User

    I'm afraid no one starts reading threads at their beginning :D

    Harry
     

HTC Desire HD Forum

The HTC Desire HD release date was October 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 768GB RAM, Snapdragon S2 processor, and 1230mAh battery.

October 2010
Release Date
0
Reviews
Loading...
Similar Threads - Navigation self opening
  1. David Devoy
    Replies:
    12
    Views:
    2,550
  2. Derek John Castle
    Replies:
    0
    Views:
    930
  3. thedavegray
    Replies:
    6
    Views:
    1,476
  4. melbourn5
    Replies:
    3
    Views:
    3,750
  5. BenyBen
    Replies:
    2
    Views:
    915
  6. App Update
    Replies:
    0
    Views:
    907
  7. App Update
    Replies:
    0
    Views:
    799
  8. frappydan
    Replies:
    0
    Views:
    3,503
  9. Jakub74
    Replies:
    0
    Views:
    2,040
  10. ThomasGLu
    Replies:
    0
    Views:
    2,159

Share This Page

Loading...