1. Download our Official Android App: Forums for Android!

Support Need fix for no data connection on Optimus M

Discussion in 'Android Devices' started by Tekzel, Oct 15, 2011.

  1. Tekzel

    Tekzel Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Feb 5, 2011

    Feb 5, 2011
    3
    0
    5
    Ok, the back story is I had my Optimus M rooted and, like a dumbass, I removed LG Home, not thinking about the consequences, to save space. Well, after I switched to T-Mobile and a Sensation (awesome phone, by the way) I did a factory reset on my Optimus and of course it wiped everything, and tried to load LG Home, but it was gone. It seemed to be basically bricked.

    I searched around and found out how to use LGNPST to write a new stock ROM back to it, 2.2.1 (Unfortunately, Gingerbreak didn't seem to work). Now, though, there seems to be a problem with the PRL file, it doesn't recognize the MetroPCS network any more. I can't call 611, as I should be able to even on a phone with no service. It should still be able to see the network (the notification bar indicator shows an x and no bars), and the other day the time and date were wrong and there wasn't a way to fix it since it seems to set it manually, and it wasn't getting the info from the network.

    I've been using it as an alarm clock and an MP3 player for when I don't want to risk my good phone. I'd like to fix this issue if possible. I've tried using both LGNPST and the Qualcomm app (qst 2.7 or something like that) to try to write a new PRL file to it, but they both act like they are doing it but as soon as they start the phone reboots and while they indicate it was successful, nothing has changed.

    Any suggestions will be welcomed, thanks in advance. Sorry for the book. haha.
     

    Advertisement

  2. Tekzel

    Tekzel Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Feb 5, 2011

    Feb 5, 2011
    3
    0
    5
    Ok, nevermind. I decided to find a 2.2 image and write it instead so I could root, after I wrote it, rooted, etc, I tried upgrade the PRL (3024) and it worked, it sees the network again. Guess something was wonky with the last image.
     
Tags:

Share This Page

Loading...