1. Are you ready for the Galaxy S20? Here is everything we know so far!

NEED HELP FAST on google account and apps

Discussion in 'Android Help' started by Heak TayLong, Jan 31, 2016.

  1. Heak TayLong

    Heak TayLong Lurker
    Thread Starter

    Hello, everyone here! I have been using Samsung Galaxy Grand for 2 years... I haven't experienced this problem until today. Today, as I attempted to open to YouTube, it didn't open and said 'There is a problem to network service. Please try again." also my Play Store and Google+, it said no connection as well. I have switched from Mobile Data to WiFi and other way around and they still said 'no connection'. I think there is a problem about Google Apps and account. My mobile data and wifi worked perfectly fine... My Google chrome and Gmail worked, but the other 3 I mentioned earlier didn't. Then I remove my account from my device and add it back again. As it was logging in, it said "Can't established a reliable connection to a server." It even said "This could a temporary problem, or your Android device may not be provisioned for data service." I've searched Google for solutions, but nothing has been solved. I have cleared the cache, data on Google Play Service, Play Store, Youtube, Google+. I have even rebooted, toggled airplane mode.. and I've also done the syncing on my account, and it said "Sync is experiencing a problem. It will be shortly." NOTHING STILL HASN'T BEEN SOLVED. My phone IS ROOTED. I don't want to do the factory reset...
    Can you help solving this problem, please? I would appreciate that. Thanks in advanced, and sorry for my English.

    One more thing, I can sign my account in on Google Chrome, but I can't do that on Google+ or setting...

    Is it because of my Google Account or mu Google App or because of my network connection?
     


    #1 Heak TayLong, Jan 31, 2016
    Last edited: Jan 31, 2016

    1. Download the Forums for Android™ app!


      Download

       
  2. Parayilhussain

    Parayilhussain Android Enthusiast

     LOGIN REGISTER
    xda-developers Android Development and Hacking Android General [SOLUTION:] Can't Establish a reliable connection to the server/Playstore No Connect by QYOBZ

    NEW TO XDA? START HERE.
    FIND YOUR DEVICE
    OR START EXPLORING
    Apps and Games by XDA Members
    Show Off Your Homescreen
    Guide: Getting Started on XDA
    TOTAL MEMBERS 6,938,318
    ONLINE NOW 39,729
    FORUMS
    Android General
    Android Q&A, Help & Troubleshooting
    Android Software and Hacking General [Developers Only]
    Android Software Development
    Miscellaneous Android Development
    [More]

    MOST THANKED
    ALL-TIME
    4 (quote) SHOULD i expect you to click the THANKS button... :p …QYOBZ OP2013-Sep-10 9:36
    4Thanks Alot man !!! Thanks Alot man !!! it works here are the …ahmer472013-Feb-20 8:53
    2Solution another simple method for this is download lucky …shivamgarg2014-Aug-31 7:55
    2Success...Almost!!! (quote) I have a Samsung Galaxy Ace …mariostatm2014-Feb-17 16:39
    2 i find this works 1/ download adaway ... 2/ then download …pweibj672013-Dec-28 19:10

    ANALYSIS & OPINION

    CF-Auto-Root Updated with Support for Over 300 devices!
    December 27, 2015

    Jide Remix Ultra Tablet Review: Multi-window Done Right
    December 26, 2015

    Elephone Launch P9000 Available From $99.99
    December 26, 2015

    What Was the WORST Android Thing That Happened in 2015?
    December 25, 2015

    Tronsmart Titan Quick Charger Review and International Giveaway! – XDA TV
    December 25, 2015More XDA News

    TOP FORUM DISCUSSIONS
    Detailed Guide to Install Sony’s Android 6.0 Concept Software on Xperia Z3 Compact
    December 27, 2015
    Guide to Repartitioning Xperia S to Flash Unofficial AOSP Build
    December 27, 2015
    Beta of SuperSU Updated to Version 2.65
    December 26, 2015
    Easily Redial Busy Numbers with Busy Redial
    December 25, 2015
    Root Beta Android 6.0 Firmware on Samsung Galaxy S6
    December 24, 2015
    Enable EIS (Electronic Image Stabilization) on Nexus 5X by Editing Build.prop
    December 23, 2015
    Sony Xperia S Receives AOSP Port of Marshmallow
    December 23, 2015More Forum Links

    Tweet Like +1
    [SOLUTION:] Can't Establish a reliable connection to the server/Playstore No Connect
    147 posts
    Thanks: 309

    By QYOBZ, Senior Member on 21st January 2013, 10:03 AM
    Reply Subscribe Email
    12311Last


     CREDITS GOES TO: to crazzzzy (and many other users) (pandawill) for posting this solution.

    WARNING: YOU MAY LOSE ALL YOUR DATA BY DOING THIS.

    Issues:
    - Account sync OFF permanently with the message: "Sync is currently experiencing problems".
    - Signing in Google Apps fails showing message: "Can't establish a reliable connection to the server"

    Possible Cause:
    - system file named 'hosts' (/etc/hosts) points to a Google server that changed IP, thus blocking access to Apps.

    Possible Solution:
    edit 'hosts' file (/etc/hosts) deleting or commenting (adding a # at the beginning) the old line

    Please do it at your own risk.

    How to do it:

    METHOD 1

    1.- ROOT your device (of course)

    2.- Editing the file
    You will need a proper editor
    Download and Install Total Commander and open it
    OR DOWNLOAD BELOW

    3.- Browse with Total Commander to root/etc
    (hint: on the right side of the screen there's a shortcut to system folder.. look for etc/ and you will find it)
    Tap mount R/W
    Long tap on "hosts" > edit file > Totalcmd-Editor

    Open etc/hosts and edit the file. Just put # before 74.125.93.113 android.clients.google.com.

    4.- SAVED

    Edited file should look like this:

    127.0.0.1 localhost
    #74.125.93.113 android.clients.google.com

    remember: based on my own observation it should be look like this:

    127.0.0.1(just one space)localhost
    #74.125.93.113(just one space)android.clients.google.com

    5.- Turn OFF your device.
    6.(Not Necessary, Go to Next Step. But if the problem persist do Factory Reset..) Got it on Recovery Mode, Factory Data Reset, wipe data.
    7. Reboot your device.
    8. Once the phone reboots, input your google account information when the phone asks for it.
    9.- Sync to your account and contacts

    METHOD 2:

    1. Make sure you have a ROOT ACCESS on your Device.
    2. Install Root Explorer, Run App, Grant SU Access.
    3. Browse root / etc... at the top of your screen you will see mount R/O and mount R/W...
    4.Tap mount R/W
    5.Look for host file, long press it and open with text editor.
    6. just Add # (pound sign) on the first number.
    like this:

    #74.125.93.113(just one space)android.clients.google.com

    SAVE IT and Reboot.
    Now you can connect to Google Play very well.

    UPDATE: 08/22/13

    If above method fail to connect you properly or have some issue on wireless connection, revert the host file to its original state
    and install this app on playstore:
    https://play.google.com/store/apps/d...eb.hosts&hl=en

    run app and choose your prefer edit.

    Another Way Playstore not working after Installing/Uninstalling Freedom App?

    - Go to Root Explorer and Mount R/W then delete Hosts file under system/etc/
    - Reboot
    - Shutdown & Boot to Recovery
    - Wipe Cache/Dalvik Cache
    - Reboot
    - Presto! back to normal.

    Edit:
    Removed Attached Files you may download it on Google Playstore. 

    Total Commander: https://play.google.com/store/apps/d...TotalCommander

    Root Explorer: https://play.google.com/store/apps/d...e.rootexplorer

    Note: You may use your favorite File Manager as long as it can browse up to the root of your Phone..

    Download Other File Managers:
    Root Browser: http://forum.xda-developers.com/show....php?t=1338582 (Credits to the Devs)
    ES Explorer: http://forum.xda-developers.com/show....php?t=2210417 (Credits to the Devs)

    Note: If ABOVE method doesn't work for you... reflash rom would be your final choice!

    JUST A SIMPLE CLICK ON THANKS BUTTON... WILL GLADLY APPRECIATED!
    ACTIONS SPEAK LOUDER THAN WORDS SO YOU MAY CLICK THANKS BUTTON RATHER THAN THANK ME ON REPLY...
    Last edited by QYOBZ; 12th May 2014 at 09:34 AM. Reason: attached file
    The Following 265 Users Say Thank You to QYOBZ For This Useful Post: [ View ]


    saif858
    23rd January 2013, 02:21 AM |#2
    Junior MemberThanks: 2

    I read your solution but when i saw my host file there was a different ip address

    127.201.26.224 android.clients.google.com
    mtalk.google.com

    i comment both of them and did what you said but it didn't work the first time
    2nd time i did that and it worked


    Thanks
    Last edited by saif858; 23rd January 2013 at 03:17 AM.
    The Following 2 Users Say Thank You to saif858 For This Useful Post: [ View ]
    dfusaro
    23rd January 2013, 07:00 PM |#3
    Junior MemberThanks: 0

    THAKS A LOT DUDE !!!!!!! I't works 
    MANOJ5329
    30th January 2013, 11:28 AM |#4
    MemberThanks: 2

     Same Error
    Even i have 127.122.124.92 android.clients.google.com mtalk.google.com ip, so did u change this ip to 74. or did u add the new ip below the local host portion???

    ---------- Post added at 03:58 PM ---------- Previous post was at 03:43 PM ----------

    Ok Thanks a lot it really worked now, now this might help for some one if u have the same error as i got. No 74.125.93.113 ip present below local host (127.122.124.92 android.clients.google.com mtalk.google.com ip present ). so just copy this (#74.125.93.113 android.clients.google.com) below 127.0.0.1 localhost , and that worked for me....
    therafman
    3rd February 2013, 10:34 PM |#5
    Junior MemberThanks: 0

     Thank You!
    Thank you for the info, it worked on my Chines tablet as it stopped working all of a sudden.
    I had a feeling that it was something like this, just had no clue how to go about it... and why the hell are they using hard-coded IP addresses anyway???

    BTW, just fixing the HOST file and rebooting fixed it for me.
    benjieb
    3rd February 2013, 11:43 PM |#6
    Senior MemberThanks: 13

    THANKS! Browsed all over the net to find a solution to this issue!

    Tried many things and was about to decide to sell my GNex and upgrade to nexus 4!

    Thanks to this thread and you all I am a happy GNex user again.

    Still wonder what happened that changed this file or fckd my system...
    The Following User Says Thank You to benjieb For This Useful Post: [ View ]
    benjieb
    4th February 2013, 05:44 PM |#7
    Senior MemberThanks: 13

    Uhhh, didn't work so well. I have access to my google account again (play, gmail, youtube...)

    but when I try to update an app or download a new one, I get an error: RPC:S-5:AEC-0


    Can anyone help ?


    thanks
    yonymun
    5th February 2013, 08:53 PM |#8
    Junior MemberThanks: 0

    Thanks problem solved
    Hi I was frustrated for some time over this issue, following your instructions (ES file explorer and editor) solved the problem.
    Only corrected the file without factory reset than added one of my accounts.
    Thanks again.
    ahmer47
    20th February 2013, 02:53 PM |#9
    Junior MemberThanks: 4

     Thanks Alot man !!!
    Thanks Alot man !!! it works

    here are the steps ( your device must me rooted ) :

    1. download total commandar.apk from google
    2. Install it in your android mobile
    3. open the total commandar from ur android mobile and goto File System root
    4. search for the folder etc and open that folder
    5. now search for the file name ' hosts ' and click on it .
    6. select edit file and add ---> " # " <--- before 2nd line like this " #74.125.93.113 android.clients.google.com "
    7. and save it
    8. Reboot your device
    9. turn on ur wifi and ADD GOOGLE ACCOUNT !!! Enjoy
    The Following 4 Users Say Thank You to ahmer47 For This Useful Post: [ View ]
    a4403
    22nd February 2013, 03:49 AM |#10
    Junior MemberThanks: 2

    Thanks It worked in my GNote II...It happened to me many times when i flash a new ROM and these is the first time a solution works
    The Following User Says Thank You to a4403 For This Useful Post: [ View ]
    praveenyashwanth
    27th February 2013, 03:02 PM |#11
    Junior MemberThanks: 0

    Quote:
    Originally Posted by a4403
    Thanks It worked in my GNote II...It happened to me many times when i flash a new ROM and these is the first time a solution works

    thanks a million man.
    it works wonder ...............
    Read More

    Reply Subscribe to ThreadPage 1 of 3612311Last
    Tags
    can't establish, google play, playstore, server error, sync

     Guest Quick Reply (no urls or BBcode)
    Message:
    
     
    Previous Thread Next Thread

    Top Threads in Android General by ThreadRank
    [Meizu]-[FLyme Os] Install rom international for All devices 8th August 2015 Miscellaneous Android Development
    [APP][5.0+] NetGuard - No-root firewall [0.63 BETA 20151226] 25th October 2015 Android Apps and Games
    Infocus m810/m812 custom recovery, unlock, roms (only m810), tweaks. 31st October 2015 Android General
    Infocus M810/M810t thread, a $160 Oneplus One....two??? 15th September 2015 Android General
    Vivo Xshot (Info, Downgrade, Root, TWRP, ROMs....) 11th June 2015 Android General
    Asus AFT flash tool Free (Solution –Struck on boot logo / Asus screen / Droid boot 26th July 2015 Android General
    ZTE V5 Pro on sale on the 24th 22nd September 2015 Android General
    Letv Le 1s LeTV X500 first released and Antutu test score exposed 28th October 2015 Android General
    xda-developers Android Development and Hacking Android General [SOLUTION:] Can't Establish a reliable connection to the server/Playstore No Connect by QYOBZ

    XDA Developers was founded by developers, for developers. It is now a valuable resource for people who want to make the most of their mobile devices, from customizing the look and feel to adding new functionality.
    Are you a developer?

    Sitemap

    More info
    Contact
    Rules
    Android Guides
    Suggest Content
    Privacy Policy
    XDA App
    Root Any Device

    Copyright © xda-developers. Hosted by Leaseweb

    We're Social

     
  3. svim

    svim Extreme Android User

    Try booting into 'Safe Mode' and see if you're still having a problem with your online connectivity. If it is OK in Safe Mode than can you think of anything you might have installed since yesterday before you started to have problems?
    Another thing to try is clear the system cache partition. It won't affect your data or your apps but it sometimes clears up odd things going on that aren't related to individual app problems.

    http://cellphoneforums.net/samsung-...-master-reset-clear-cache-boot-safe-mode.html
     
  4. Heak TayLong

    Heak TayLong Lurker
    Thread Starter

    Thanks guy... I solved it now... It's because of an app I downloaded...
     
Loading...

Share This Page

Loading...