1. Are you ready for the Galaxy S20? Here is everything we know so far!

Need Help - GSM Only mode doesn't work

Discussion in 'Android Devices' started by prakashp, Sep 6, 2011.

  1. prakashp

    prakashp Newbie
    Thread Starter

    On my Micromax A70, when I set network mode to "GSM Only", I am not able to receive calls or dial-out. It constantly gives "Network Busy" message.

    It works when I set it to "GSM/WCDMA Preferred", but gives same "Network Busy" message intermittently. Because of this problem I am missing some of my important calls.

    The same SIM card works perfect with my Nokia phone in both GSM and UMTS mode without any glitch.

    Any help to resolve this would be highly appreciated.

    Thanks in advance.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Ankit.a70

    Ankit.a70 Lurker

    I am having the same problem with my handset. Most of the time it shows the message "Network Busy" during outgoing calls. I always use GSM ONLY network mode in my device.
    Any help would be appreciated.
     
  3. theperfectpunk

    theperfectpunk Well-Known Member

    Have U Tried Soft Reset?
     
  4. prakashp

    prakashp Newbie
    Thread Starter

    You been reboot? Yes tried many times.
     
  5. sunil90

    sunil90 Android Enthusiast

    maybe your sim card does not support gsm only ?.. im using reliance smart and mine works perfectly
     
  6. mdimran247

    mdimran247 Newbie

    I am using Vodafone and network goes down often. I have to restart my mobile to get network. Any solutions? Anybody else having the same problem?
     
  7. cool.gautam

    cool.gautam Android Enthusiast


    When done GSM only.....wait for aboit 10 mins u'll get network :)
     
  8. mdimran247

    mdimran247 Newbie

    It has been already set to GSM only. Still I'm getting problem. It goes off for hours until I restart my mobile
     
  9. akshaybz

    akshaybz Android Enthusiast

    I think he meant that it happens when YOU ARE AT "GSM ONLY"...
    Change to something else...
    to rhe GSM/WCDMA automatic one..

    Clear it gautam.
     
  10. mdimran247

    mdimran247 Newbie

    Hi Akshaybz/Gautam,
    I had tried that but after sometime it is going our of network. I had to restart to get back. Anyone here having the same problem? Please suggest....
     
  11. droidolution

    droidolution Newbie

    select gsm as preferred, go to gsm/umts options and select 'use 2g network only'. then go to 'network operators', search network and select ur carrier. wait for some time (10 mins may be :p). if the network still dont gets connected, just reboot. everything should be fine. I had the same issue after the 3g activation and this saved my 2g back.
     
  12. ams04

    ams04 Well-Known Member

    I am having same problem but in both gsm and wcdma(my no. says busy and nothing says for outgoing calls it just disconnects):thinking::thinking:...
    i never mentioned it because i thought that it might be a problem of BSNL:rolleyes:
     
  13. mdimran247

    mdimran247 Newbie

    I am still facing these network related problems. Worried if this is the problem of our phone!!!!!
     
  14. ninadchaudhari

    ninadchaudhari What's up !

    Yup i think you must go to a bit more native solution so
    on dialer : *#*#4636#*#*

    After a moment, a screen will appear called "Testing"
    Select the drop-down that says "Phone Information".
    From there, scroll down to where it should say "WCDMA preferred" or WCDMA only , and change it to "EDGE only" OR SIMILAR ! . Use the back key to get out. It should stay selected even through a reboot.
     
  15. ninadchaudhari

    ninadchaudhari What's up !

    also it seems the prob. of your operator in this case....
     
  16. mdimran247

    mdimran247 Newbie

    Thanks for the reply Ninad,
    I cant find the Edge option u specified. It was selected to GSM only by default.
     
  17. ninadchaudhari

    ninadchaudhari What's up !

Loading...

Share This Page

Loading...