1. Are you ready for the Galaxy S20? Here is everything we know so far!

Need help rooting 2.1

Discussion in 'Android Devices' started by autarkh, Jun 2, 2010.

  1. autarkh

    autarkh Lurker
    Thread Starter


    I did a search but did not find anything directly applicable to my situation. My apologies if I missed it.

    My Droid is currently running Android 2.1 update 1.

    I had previously rooted under Android 2.0.1, but I inadvertently installed the Verizon automatic system update, which took away root privileges. (Incidentally, is there a way to disable automatic updates? Before my slip-up, I had been canceling the dialog box for over a week.)

    I tried the method described in this post and it seemed to work, but I can't execute "su" from the terminal emulator console. I have the superuser permissions ninja under apps, but I also had it after the forced Verizon update. I suspect this is a vestige of the previous rooting.

    I would be immensely grateful if someone could direct me to instructions on how to EITHER: A) download everything necessary to revert to 2.0.1, use the root exploit, and then upgrade to a rooted version of 2.1, OR B) root my current installation of 2.1.

    Also, if you could recommend a good ROM with wireless tethering, that'd be icing on the cake.

    Thanks in advance.

  2. OMJ

    OMJ Bazinga

    The thread that you linked to. In the second post is directions for reverting to 2.0.1 Sounds like that would be the best solution for you
    autarkh likes this.
  3. autarkh

    autarkh Lurker
    Thread Starter


    I'll post again if I have problems.
  4. autarkh

    autarkh Lurker
    Thread Starter

    OK. So I found this...

    ... which I think will solve my problem.

    The only issue I'm having is getting adb working via USB.

    After installing the usb driver and RSDLite, I downloaded the Android SDK. Then I booted the Droid into sprecovery and mounted /system. But I still can't get it to connect to the phone. I'm certain I'm doing something stupid. Is there a guide on the initial adb setup, just to make sure I haven't missed something?

    Once I get to the shell, I'm pretty sure I can figure this out.
  5. Fabolous

    Fabolous Superuser

    Did you add the /tools directory to your system path?

    That would be something along the lines of: My Computer, properties, advanced settings, environment variables, then add where you put the tools folder to 'PATH'

    That way, you can use the command adb, no matter where you open your command prompt.
  6. autarkh

    autarkh Lurker
    Thread Starter

    No, I don't have it in the path.

    I was executing adb from the folder where it is installed (ie. C:\android-sdk-windows\tools)

    The problem isn't running adb, but getting it to connect to the phone.
  7. autarkh

    autarkh Lurker
    Thread Starter

    Specifically, when I try "adb usb" or "adb devices" it says either:

    A) "*deamon not running. starting it now*", after which it hangs
    B) the same thing, followed by "ADB server didn't ACK; *failed to start daemon*; error: cannot connect to daemon"
  8. Timaphillips

    Timaphillips Android Enthusiast

    I'm sure i'll get attacked for this, but is there an "easy" way like DMUpdater was to root 2.1 on a fresh previously unrooted phone?
  9. Papadroid

    Papadroid Android Expert

    Are you using Win 7? If so did you download the motorola drivers? The drivers from the adb did not work for me. Link provided below for drivers:

    USB and PC Charging Drivers - Motorola USA
  10. autarkh

    autarkh Lurker
    Thread Starter

    XP. I'm using the Motorola drivers. I rebooted again, now I can at least start the daemon (both "adb usb" and "adb device" work), but I can't do "adb shell" or "adb push"
  11. iamschoi

    iamschoi Lurker

    i had the same problem, and i want to go back to 2.0.1 but when i run rsd to run sbk file it FAILS saying "chipset 33 not detected" and "failed flashing process. phone [0000]: unable to retrieve initialization values from INI file."

    did u have this problem too and if so how did you get past it? please help...

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page