1. Are you ready for the Galaxy S20? Here is everything we know so far!

Need Help Someone

Discussion in 'Android Devices' started by gamergirl1208, Dec 5, 2013.

  1. gamergirl1208

    gamergirl1208 Lurker
    Thread Starter

    I've had the amazon app store on my galaxy s3 for a while now and for the last 6 or so months it won't let me download any apps it says the app is downloading but then when the screen pops up and askes me to install it I hit install and it won't do anything. Yes I have unkown apps allowed to download on my phone. Anyone else having this problem? If so what can I do to fix this problem I love the amazon app store
     



    1. Download the Forums for Android™ app!


      Download

       
  2. heat57

    heat57 Android Enthusiast

    Go to the Application manager in system settings, scroll to the Amazon app and clear cache and data. Then reboot and open the app again and enter your account details and so on. See if that helps to solve the problem.
     
  3. gamergirl1208

    gamergirl1208 Lurker
    Thread Starter

    Just tried doing that and nope apps still won't download
     
  4. aml1025

    aml1025 Android Enthusiast

    Have you tried uninstalling and reinstalling the app entirely to see if that helps?
     

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...