1. Are you ready for the Galaxy S20? Here is everything we know so far!

Need Help With Eclipse

Discussion in 'Android Development' started by Rene505, Jan 6, 2014.

  1. Rene505

    Rene505 Lurker
    Thread Starter

    Hello Everyone,

    I am new to Eclipse and appreciate any help with this. I recently installed eclipse and am trying to test out a basic android live wallpaper, everything seems fine but when I click run to see how it would appear on my emulator the emulator starts up but my app does not open on it. I also tried to hook up my real android device via usb, the eclipse doesn't even see my real device in the 'run as'. I did follow the instructions on how to hook up a real device but still no use.

    I would really appreciate any help on getting my emulator and real device to start showing my apps. I know it is something dumb that I must have missed.

    Thank you so much in advance.

    Regards,
    Rene
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    Welcome to AF Rene.:)

    I moved this to the Application Development forum to get some better eyes on it.
     
  3. venom2124

    venom2124 Newbie

    Have you looked at the logcat to see if it is kicking out any errors. Have you tried to run on an actual device. On occassion the emulators will be glitchy and cause more headaches. I've seen emulator run apps do weird things and then the same app runs like a top on an actual phone.
     
  4. Rene505

    Rene505 Lurker
    Thread Starter

    Sorry I am too new, I would appreciate if you tell me the steps to find and utilize the logcat.
    Yes, as I mentioned I did connect a real device and tried to run on it but it is not showing in eclipse.
     
  5. Rene505

    Rene505 Lurker
    Thread Starter

    Hi again. It appears that I had an issue with my ADB, when I restarted it now my real device connected via usb is working normally, but I still get errors when trying to start up the emulator. I would appreciate any assistance on this. Thanks
     
  6. houserjr

    houserjr Lurker

    window/prefrence/DDMS/abd timeout settings increase this number. The AVD virtual device is a resource hog and takes a long time to start up so it may be timing out. Also consider starting the AVD first then run the code
     
  7. ProjectLiquid

    ProjectLiquid Member

    Are there any errors in the console or code? And are you trying to run the program on the emulator or your phone?
     
Loading...

Share This Page

Loading...