Root Need some help, rooting, brick, firmware - issues all around.


Well-Known Member
So basically my computer cannot recognize my phone via USB. I have tried downloading all the drivers, everything.

My problems all started when I bricked my phone, and was forced to do a factory reset. When that happened it put version F of the firmware on my phone. I have followed all the instructions to put version C on my phone - but it won't work.

I have tried rooting it normally, it wont work. It says daemon not started, starting daemon on port bla bla bla, then it hangs. However it hangs forever, since all I'm getting is a charge, and it doesn't recognize the phone as files. I used to be able to just plug my phone in and see the files.

Additionally, when I plug in my USB it doesn't give me the option to select if I want to charge, camera mode, whatever, even though I have the option selected to ask me, and I have debug on.

I don't know what to do. I've already lost a ton of my stuff, and had to factory reset multiple times. And I'm getting really aggravated.


Well-Known Member
Thread starter
Sorry, I thought I posted an update but I didn't.

Basically the phone is stuck with firmware F, but that's no big deal. I've got it rooted, and I just have to fix my boot buddy script.

To make a long story short the problem was the cable I was using was tricking the phone into thinking my laptop was a wall charger.

So right now don't really need any help with the issues I mentioned. It's unbricked as of now, and I can access files on my laptop, and it's rooted.