1. Check out our companion app, Forums for Android! Download from Google Play

Root Need to get Stock Phone back!

Discussion in 'Android Devices' started by HammerB, Oct 21, 2010.

  1. HammerB

    HammerB Member
    Thread Starter
    5

    Oct 3, 2010
    5
    0
    5
    Toronto, ON
    I have the Vibrant i9000M on Bell Mobility. I was trying to get Froyo using the regedit method. After changing the tags as the forums discussed, Kies gave me an update. After I completed the update I realized all it did was give me an update to international 2.1

    Now, the Bell apps are gone and all I see at the top is signal bars, it use to tell me if i was on 3G, etc but that doesn't show anymore. I've tried the factory restore but all it does is delete everything with the same international setting.

    Here's the specs I see now:
    Model Number : GT-I9000
    Firmware version : 2.1-update1
    Baseband version : I9000XXJM1
    Kernal Version : 2.6.29 root@SE-S603 #2
    Build Number : ECLAIR.XWJM2

    How do I get the Bell Mobility I9000M stock back?!?!

    Let me know if I left anything out. Thanks in advance!

    **EDIT** My data is not working!
     

    Advertisement

  2. HammerB

    HammerB Member
    Thread Starter
    5

    Oct 3, 2010
    5
    0
    5
    Toronto, ON
    So I got the JH2 firmware back! But i still have no data.

    in Settings > About phone > Status, under Mobile network state it says Disconnected.

    Is there anyway of restoring the data functionality ? I know it's not the sim card because I tried it on another phone and data was available.

    Any help would be greatly appreciated.

    Thanks
     
  3. djquick

    djquick Well-Known Member
    38

    May 13, 2010
    228
    23
    38
    DJ/Remixer/Producer, IT Specialist
    Maricopa, AZ
    do a factory format
     
  4. HammerB

    HammerB Member
    Thread Starter
    5

    Oct 3, 2010
    5
    0
    5
    Toronto, ON
    djquick, I tried a factory format it didn't work.

    I did a little more research and found the problem, here's the solution if anyone finds themselves without data service on their Bell device

    Make sure APN settings (Settings > Wireless and network > Mobile networks > Access Point Names) are as follows:

    Name: Bell Internet
    APN: pda.bell.ca
    Proxy: web.wireless.bell.ca
    Port: 80
    MMSC: http://mms.bell.ca/mms/wapenc
    MMS proxy: web.wireless.bell.ca
    MMS port: 80
    MCC: 302
    MNC: 610
    APN type: Internet + mms
    Authentication Type: none


    Proof that research goes a long way lol... Glad my device is back on track :D
     
  5. bootsie

    bootsie Well-Known Member
    38

    Jun 2, 2010
    166
    17
    38
    Seems odd that you would have to manually set that
     
  6. shaahinjjj

    shaahinjjj Well-Known Member
    36

    Aug 12, 2010
    103
    7
    36
    I had to do this same thing because i was using this phone under Rogers, which is normal. But having to go through this while using a phone from Bell under Bell's network is strange.
     

Share This Page

Loading...