1. Are you ready for the Galaxy S20? Here is everything we know so far!

Netflix on CM7?

Discussion in 'Android Devices' started by breadnatty08, May 13, 2011.

  1. breadnatty08

    breadnatty08 pain rustique
    Thread Starter

    Has anyone successfully been able to stream Netflix on their Nook using the .apk that was released? I got it working on my Droid (which isn't supposed to be supported), but not my Nook. Certainly would be better on the larger screen....:(
    Hopefully xda will have something up their sleeves soon.
     

    Advertisement

  2. Valkerie

    Valkerie Android Enthusiast

    I got it to work. Threes a good thread on xda about it. You have to modify your build.prop to get netflix to work.
     
  3. Legobricke

    Legobricke Well-Known Member

    Make sure you backup your build.prop file before editing just in case you need to switch back.


    -Remount /system as RW using Root Explorer
    -Backup the /system/build.prop to /system/build.prop.bak
    -Edit the file /system/build.prop with a text editor
    -Replace each of the below line with

    ro.product.model=Nexus S
    ro.product.manufacturer=samsung

    -Make sure there are no extra spaces at the ends of lines as that can cause problems
    -Save the file
    -Hard Reboot

    That should do it.... Worked perfectly for me.

    You can read the thread over at xda here

    Lego
     
    breadnatty08 likes this.
  4. breadnatty08

    breadnatty08 pain rustique
    Thread Starter

    Quick question, how does one backup their build.prop file? Is a full Nandroid backup sufficient? I've never had to mess with this on my Droid before, so this will be the first time.

    Edit: nevermind, found the quick copy/paste method over at XDA! I need to spend more time over there...
     
  5. webyrd

    webyrd Newbie

    I got Netflix working on NC running CM7 without editing build.prop by sideloading the netflix-devicecheck-disabled.apk from:
    forum.xda-developers.com/showthread.php?t=1076150

    FYI to all that need RW file permisions, the File Expert app is free, it also lets you mount R/W. I have not used Root Explorer, because I have not found anything I needed to do that File Expert can't do.
    edit, file expert no longer supports root for free, using ES File Explorer now
     
    honyock and LuvArabians like this.
  6. gooberman

    gooberman Newbie

    That was the only way I could get it to work.

    I love using netflix on the nook!
     
  7. vilamonster

    vilamonster Newbie

    I cannot get it to work using either of the modified apk files. It displays the movie, but goes too fast. Movie and sound seems to be going at twice the normal frame rate.

    Any suggestions?
     
  8. kingofmay

    kingofmay Newbie

    What about xfinity?
     
  9. kingofmay

    kingofmay Newbie

    What do I do with this .apk file?? Where do I put it?
     
  10. Valkerie

    Valkerie Android Enthusiast

    .apk file - stick it on your SD card and install as you would any other app. In Android, app installation files are called .apk, kind of, but not quite like .exe files in Windows.
     
  11. I_B_Jammin

    I_B_Jammin Lurker

    Sorry for the ignorance (Its a Noob thing) how do you install the app or .apk file from the sd card exactly? Also, is there a reason I cannot find the Netflix app in Market? I'm using CM7 from an sd card, everytime I connect to Market and Search for the Netflix app it nowhere to be found. Thanks!
     
  12. gooberman

    gooberman Newbie

    I'm fighting the same issue myself
     
  13. colchiro

    colchiro Extreme Android User

  14. I_B_Jammin

    I_B_Jammin Lurker

    I now have Netflix running but have the dread "chipmonk" sydrome. I have tried in vain to edit my build.prop file using a multitude of file management apps but none will let me save the changes! I even resorted to using a build.pro file (Found here:Netflix on Nook Color | Too Smart Guys )to overwrite my existing one here but I apparently don't have permission to that either! This is really getting frustrating! What am I missing?:(
     
  15. TheAmazingDave

    TheAmazingDave Android Expert

    I had no trouble editing my build.prop to work with Netflix, I just had to change the known identifiers to an HTC Vision, then rebooted. No more double-speed playback.

    I used RootExplorer to edit, you must enable read/write permissions to edit the file.
     
  16. colchiro

    colchiro Extreme Android User

    Before you do anything, go into Rom Explorer and make a recovery backup. See my Phiremod or CM7 rom installs on how to do that... first step. :D

    Get Root Explorer and scroll down to system, and tap it to open it. Then at the top, tap the [ r/o ] button. It'll change to [ r/w ] (or read/write privilege). Then long-press on your build.prop file, choose edit and carefully edit it. When done, tap the menu button, choose save and exit and tap the top button to change back to [ r/o ] and reboot.
     
    tube517 and I_B_Jammin like this.
  17. droid_freak

    droid_freak Well-Known Member

    Works perfect on my New Nook w/ CM7.0.3 Stable
     
  18. droid_freak

    droid_freak Well-Known Member

    If you download the new apk in the XDA thread above, Netflix works like a champ, no buildprop changes needed.
     
    tube517 likes this.
  19. tube517

    tube517 Android Expert

    Just rooted my NC and flashed CM7 and Netflix works great. I have a new toy :D
     
  20. flu13

    flu13 Android Enthusiast

Loading...

Share This Page

Loading...