1. Are you ready for the Galaxy S20? Here is everything we know so far!

Netflix won't work! HELP!!!!!

Discussion in 'Android Apps & Games' started by tabletnewb, Oct 22, 2014.

  1. tabletnewb

    tabletnewb Lurker
    Thread Starter

    Hello I am new to android tablets so forgive me if this has been covered but I am desperate. I cannot get Netflix to work on my tablet here is what I have:
    Tablet: Ainol Novo 7 Fire (Flame)
    OS: 4.2.2
    What I have tried so far: Installing the latest version of Netflix. I am able to log on and see my home screen but when I try to play a video it says "Loading" and never loads
    I have also tried uninstalling the latest version of Netflix and installed Netflix 1.8.1 apk. That did not work either. I can also see my home screen but when I try to load a video it starts to load then the Netflix splash screen comes up and then goes back to my home screen.
    I believe my tablet is rooted although I will admit I don't really know what that means?

    Can anyone help me get Netflix to work? Thank you very much!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Mikestony

    Mikestony ~30% Carbon Black ±
    VIP Member

    Hello and welcome tabletnewb:)
    I saw your duplicate thread in your device forum and removed that as I think the issue may be with the app itself;)

    Anyway, I don't use Netflix, but I can try to help:)
    Are you trying to log in when other devices on your account are accessing it too?
    Are you on wifi or 3g/4g when you are trying to watch?
    https://help.netflix.com/en/node/306

    Are you able to access it just fine via a computer?
     
    funkylogik and mikedt like this.
  3. mikedt

    mikedt 你好

    Doesn't Netflix only support certain popular makes and models of Android devices, like Samsung Tab, with it being locked down with DRM. Ainol Novo is a Chinese tablet.
     
    Mikestony likes this.
  4. tabletnewb

    tabletnewb Lurker
    Thread Starter

    Thanks for your input guys! I suppose DRM could be a reason but I just thought Android was Android? The tablet was legally purchased and my account is valid and in good standing...don't see why my hardware should make a difference?

    To answer your questions Mike:
    I only use Netflix on one device at a time and I am trying to log in via wifi and I have no problem accessing it on my laptop, my roku, and my Apple TV. Could it have to do with Flash not being supported by Android 4.2.2?


     
  5. Mikestony

    Mikestony ~30% Carbon Black ±
    VIP Member

    I don't think it's a Flash issue.
    Whilst be-bopping around the internet for your issue, it seems like a few folks have the same issue you do.
    I didn't see any type of sure-fire fixes for it yet though:(
     
    funkylogik likes this.
  6. tabletnewb

    tabletnewb Lurker
    Thread Starter

    Thanks Mike,
    I did found the same thing when I was googling the issue...was hoping maybe someone here had a thought. Oh...thanks anyway! :-/
     
  7. Mikestony

    Mikestony ~30% Carbon Black ±
    VIP Member

    Well, don't give hope yet... I did see some roms that had the Netflix issue fixed, and you did mention you were rooted?
    I'd have to find those again ;)
    So maybe that's an option?
     
    funkylogik likes this.
  8. tabletnewb

    tabletnewb Lurker
    Thread Starter

    Yes I think I am rooted. Again though I know that seems to mean you can make changes to the OS however I have no idea how to do any of those things and do not know what a ROM is :thinking: The reason I think I may be rooted already is that I see apps called: CifsManager, Root Explorer, and SuperSU which in my research said they all needed a rooted device to operate, also in an a review I read about the tablet it mentions it comes rooted out of the box. Regardless any ideas you may have of course are greatly appreciated! Thank you again!
     
  9. aaditysony

    aaditysony Lurker

    All this sounds too much techie n tweaking well i am already facing the same issue in my tablet. it is manufactured by micromax. i tried almost everything and give up by not thinking to install such unsupported apps.

    Poor me.
     
  10. funkylogik

    funkylogik share the love peeps ;)

    Sorry if this is a dumb question but does your tab connect to the Internet without any issues?
     
  11. mikedt

    mikedt 你好

    I'm sure Netflix only supports certain approved devices, same with Sky and HBO. Mainly because of the DRM, and so no rooted devices at all. Micromax are an Indian manufacturer, who mainly sell in India, Pakistan and Bangladesh, don't think there is any Netflix there.
     
  12. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Netflix doesn't care about rooted devices so long as the hardware DRM support is there. It's far more forgiving (read: rational) than Sky in that regard.

    And that's probably the issue here - it's likely missing.
     
    mikedt likes this.
Loading...

Share This Page

Loading...