1. Download our Official Android App: Forums for Android!

Support Network disabled. Poor connection.

Discussion in 'Android Devices' started by twinturbonet, Jul 24, 2012.

  1. twinturbonet

    twinturbonet Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jul 24, 2012

    Jul 24, 2012
    5
    0
    5
    Hello, I'm receiving this error "Network Disabled, poor connection" when trying to connect to my Belkin router. The signal shows strong, but doesn't connect. I had some DNS issues with my router about a week ago, but the router fixed itself after I left it unplugged for a day. As of right now, my computer is back on the router and I have internet.

    Any ideas? :thinking:

    I have a Galaxy S3, Android 4.0.4 (ICS).

    I've tried resetting the router, resetting the phone, changing the channel on the wireless router, messed around with the security settings, and nothing. I'm obviously not a PC guru, but I can usually hold my own.

    Thanks for the help!
     

    Advertisement

  2. twinturbonet

    twinturbonet Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jul 24, 2012

    Jul 24, 2012
    5
    0
    5
  3. jmadeline

    jmadeline Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 15, 2012

    Aug 15, 2012
    1
    0
    5
    I have the same problem! I've done pretty much everything that you did, but nothing seems to work for me to connect to my home wifi. I've been doing some reading, and others seems to be having this problem as well - yet, there is still no definite answer.

    However, I was able to connect to my neighbors unsecured network and the network at my school with flying colors.

    I think it probably just has to do something with the router. In my case, my router is quite old (Microsoft Wireless Base Station Router)... so that probably has do something with it.
     
  4. Rolo42

    Rolo42 Android Enthusiast
    Rank:
    None
    Points:
    103
    Posts:
    712
    Joined:
    Mar 23, 2012

    Mar 23, 2012
    712
    118
    103
    Male
    Retired Electronics, Computer, Network Engineer
    Greensboro, NC
    Need more info than "it doesn't work".

    What is the router's configuration? (screenshots may save time)

    Additionally, ensure your router's firmware is up to date.
     
  5. itm

    itm Member
    Rank:
    None
    Points:
    15
    Posts:
    74
    Joined:
    Aug 7, 2010

    Aug 7, 2010
    74
    0
    15
  6. rjbohm

    rjbohm Lurker
    Rank:
    None
    Points:
    25
    Posts:
    3
    Joined:
    Oct 11, 2012

    Oct 11, 2012
    3
    0
    25
    My ASUS tf101 also stopped the wifi connection 10 days after receiving device. No problem setting it up then it just quit connecting.
    I am getting the error "Avoided faulty network connection"
    HELP
     
  7. vijays3

    vijays3 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Oct 24, 2012

    Oct 24, 2012
    9
    1
    16
    solved !!! solved !!! solved !!!

    1. Go to your router settings.
    2. In wireless, go to "network mode"
    3. In network mode, there were 6 modes given:
    802.11 B/G/N mixed mode
    802.11 B/G mixed mode
    802.11 G/N mixed mode
    802.11 B only
    802.11 G only
    802.11 N only
    4. Select " 802.11 B only"
    5. Save and exit.

    Earlier, my router was in mixed mode (B/G/N) and there was error in connecting. The wi-fi singal was of pull power, but it was showing "poor connection, network disabled". After changing the network mode to "B" only, my Galaxy S3 connected seamlessly as before.

    i dont know the reason, why my s3 was working initially when router was in mixed mode, why it stopped suddenly? now i am happy...atlast working... - Try this step and if working., spread the news and help others - Regards..Vijay
     
  8. vijays3

    vijays3 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Oct 24, 2012

    Oct 24, 2012
    9
    1
    16
    solved !!! solved !!! solved !!!

    1. Go to your router settings.
    2. In wireless, go to "network mode"
    3. In network mode, there were 6 modes given:
    802.11 B/G/N mixed mode
    802.11 B/G mixed mode
    802.11 G/N mixed mode
    802.11 B only
    802.11 G only
    802.11 N only
    4. Select " 802.11 B only"
    5. Save and exit.

    Earlier, my router was in mixed mode (B/G/N) and there was error in connecting. The wi-fi singal was of pull power, but it was showing "poor connection, network disabled". After changing the network mode to "B" only, my Galaxy S3 connected seamlessly as before.

    i dont know the reason, why my s3 was working initially when router was in mixed mode, why it stopped suddenly? now i am happy...atlast working... - Try this step and if working., spread the news and help others - Regards..Vijay
     
  9. vijays3

    vijays3 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Oct 24, 2012

    Oct 24, 2012
    9
    1
    16
    solved !!! solved !!! solved !!!

    1. Go to your router settings.
    2. In wireless, go to "network mode"
    3. In network mode, there were 6 modes given:
    802.11 B/G/N mixed mode
    802.11 B/G mixed mode
    802.11 G/N mixed mode
    802.11 B only
    802.11 G only
    802.11 N only
    4. Select " 802.11 B only"
    5. Save and exit.

    Earlier, my router was in mixed mode (B/G/N) and there was error in connecting. The wi-fi singal was of pull power, but it was showing "poor connection, network disabled". After changing the network mode to "B" only, my Galaxy S3 connected seamlessly as before.

    i dont know the reason, why my s3 was working initially when router was in mixed mode, why it stopped suddenly? now i am happy...atlast working... - Try this step and if working., spread the news and help others - Regards..Vijay
     
  10. hokkers999

    hokkers999 Newbie
    Rank:
    None
    Points:
    35
    Posts:
    11
    Joined:
    Oct 24, 2012

    Oct 24, 2012
    11
    0
    35
    UK
    I know you know this already but you do remember that "b" is only 11mbits...bit limiting when "n" goes up to 300 meg. Guess it depends on your internet connection, but if like it mine it is 100meg...then even "g" isn't enough.
     
  11. Mhamadkob

    Mhamadkob Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 29, 2012

    Oct 29, 2012
    1
    0
    5
    In my wireless settings i only can find two options mixed or disabled
    Any solution..?.
     
  12. Wisheezy

    Wisheezy Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    165
    Joined:
    Sep 1, 2012

    Sep 1, 2012
    165
    7
    56
    United Kingdom

    G/N are faster than B so restricting your router to B isn't the best solution..your other devices may not even connect to it anymore.

    There's a few obvious reasons this happens that i've found out myself.

    It says this error when you are connected to the Wi-Fi but haven't actually put your wi-fi password in

    the signal is generally poor

    thats all I got from my experience.
     
  13. vijays3

    vijays3 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Oct 24, 2012

    Oct 24, 2012
    9
    1
    16

    - I am not an expert, but usually find way to fix things. I changed the mode to "B"only and s3 connected immeidately without any problems. Once connected, I changed the setting again to "B / G / N - mixed mode" and still "S3" connects to the network without the error.

    - This could be some bug (or) some security settings...but believe me this works.

    - I see many posts that many people are suffering from this problem. Try this and if it works, spread the news and help others. - Regards...Vijay
     
  14. vijays3

    vijays3 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Oct 24, 2012

    Oct 24, 2012
    9
    1
    16
    I am not an expert, but usually find way to fix things. I changed the mode to "B"only and s3 connected immeidately without any problems. Once connected, I changed the setting again to "B / G / N - mixed mode" and still "S3" connects to the network without the error.

    - This could be some bug (or) some security settings...but believe me this works.

    - I see many posts that many people are suffering from this problem. Try this and if it works, spread the news and help others. - Regards...Vijay
     
  15. vijays3

    vijays3 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Oct 24, 2012

    Oct 24, 2012
    9
    1
    16
    I am not an expert, but usually find way to fix things. I changed the mode to "B"only and s3 connected immeidately without any problems. Once connected, I changed the setting again to "B / G / N - mixed mode" and still "S3" connects to the network without the error.

    - This could be some bug (or) some security settings...but believe me this works.

    - I see many posts that many people are suffering from this problem. Try this and if it works, spread the news and help others. - Regards...Vijay
     
  16. vijays3

    vijays3 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Oct 24, 2012

    Oct 24, 2012
    9
    1
    16

    I am not an expert, but usually find way to fix things. I changed the mode to "B"only and s3 connected immeidately without any problems. Once connected, I changed the setting again to "B / G / N - mixed mode" and still "S3" connects to the network without the error.

    - This could be some bug (or) some security settings...but believe me this works.

    - I see many posts that many people are suffering from this problem. Try this and if it works, spread the news and help others. - Regards...Vijay
     
  17. loueenk

    loueenk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 1, 2013

    Sep 1, 2013
    2
    0
    5
    I had this same problem and this is what solved it:

    1. Go to settings.
    2. Click on WiFi
    3. Click menu (bottom left on phone) and click Advanced.
    4. Make sure the "Check for Internet Service" is unchecked
    5. After I unchecked this I had no more problems connecting to my WiFi.

    I think it got checked when I did a Samsung phone update the night before.
    :D
     
  18. loueenk

    loueenk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 1, 2013

    Sep 1, 2013
    2
    0
    5
    [​IMG] Network disabled, poor connection
    I had this same problem and this is what solved it:

    1. Go to settings.
    2. Click on WiFi
    3. Click menu (bottom left on phone) and click Advanced.
    4. Make sure the "Check for Internet Service" is unchecked
    5. After I unchecked this I had no more problems connecting to my WiFi.

    I think it got checked when I did a Samsung phone update the night before.
    :D
     

Share This Page

Loading...