1. Are you ready for the Galaxy S20? Here is everything we know so far!

Network Location Issue

Discussion in 'Android Devices' started by dcam1075, Nov 27, 2009.

  1. dcam1075

    dcam1075 Member
    Thread Starter

    So, with the stock Touchwiz software you can not access the normal Android Settings menu for Location and by default the "Network Location" function is dissabled. I installed Open Home (which is a must for this phone imho) and now I can access the classic settings menu. I enabled Network Location then launched Google Maps. After a second or two it centered on a road in Bellevue, WA that is not too far from T-Mo headquarters, problem is I am on the East Coast of the US. I pulled the battery and reboot the phone. Upon reboot I opened Google Maps again and it quickly found my approx location correctly but then within a second or two it switched back to this phantom location in Washington state. Has anyone else experiences this? If so is this a glitch with my phone or a known issue witht he TouchWiz/Android OS? I really need this functionality in order for the phone to be useful for me. Anyone know of a fix for this?
    Thanks a ton!

    1. Download the Forums for Android™ app!


  2. kchop

    kchop Lurker

    I have the same issue....also using Open Home. My weather widget/flip clock thing keeps resetting to Bellevue, and I can't figure out how to fix it. Same for google maps
  3. dcam1075

    dcam1075 Member
    Thread Starter

    Ah Ha! I think I have it figured out. I went to "Manage Applications" and found a program called "Network Location". I selected delete data and then went back to google maps. It found my true location and has not yet defaulted back to that phantom Washington location. I have not traveled anywhere yet though to see if it will update when I move. Give this a try and let me know if it works for you too
  4. kchop

    kchop Lurker

    well done!!! I've tried it too, and so far so good!
  5. integra891

    integra891 Newbie

    I reset that program data and Im still ending up in bellevue washington. I also did a factory reset and im still having the same problem.
  6. dcam1075

    dcam1075 Member
    Thread Starter

    So far I it has worked for me after clearing the data in the manage application section. Make sure you are doing clear data and not just clear cache. I will continue to test it today as I will be moving around but so far so good. Fingers crossed.
  7. dcam1075

    dcam1075 Member
    Thread Starter

    Yup, mine just reverted back too. It was good for a numbers of hours and kept updating even as I moved from place to place but then eventually it defaulted back to Bellevue. I guess I will just have to periodically dump the data until a fix is determined.
  8. RL777

    RL777 Lurker

    To enable network location in behold 2.
    Install Sherpa. There is a sub-menu in Sherpa that let you choose " Network Location " or " GPS Location ".
    *:)*To access the Sherpa's sub-menu. First, you must disable the GPS on your phone, then when Sherpa launches and asks to determine your location, it will ask you to enable GPS. Select ENABLE GPS. There you will have your sub-menu. Be sure to choose the " Network Location " and leave the GPS blank. It's that easy. ( Google map will show a blue dot with light blue radius indicating approximate location ).

    In situations where if you need to turn on the phone's GPS, the Network Location will get turn off automatically.
    To reactivate Network Location, just repeat *:)*.
  9. dcam1075

    dcam1075 Member
    Thread Starter

    We are not having trouble turning on Network Location, that can be done through Open Home. The problem we are having is the Network Location will work for a bit then default back to a phantom location near Bellvue, WA. It will stay locked onto this location until you purge the data from the Network Location utility in the Application Manager. Have you been using Network Location with Google Maps on and Behold II without having this problem?? That would be useful information.
  10. RL777

    RL777 Lurker

    I have experience phantom location only once but didn't last long. So didn't pay attention to what that location was. My accuracy rate is over 95%. Perhaps something to do with the carrier's network locator availability?? Mine is southern CA.
  11. dcam1075

    dcam1075 Member
    Thread Starter

    If you have time, disable GPS on your phone, open Google Maps and select "My Location" a couple of times from a couple of different places if possible. Ideally if you can drive around with Netowork Location only on and Google Maps running that would be best! If you get a phantom location let us know where it is showing. We are trying to figure out if this affects all phones or just a batch of them. Thanks!
  12. behold_this

    behold_this Android Expert

    my behold 2 has never shown the bellvue location, or any other "phantom" location. the location is always close to where i am, within the light blue circle. i have network location turned on (through the system settings menu accessed with aHome). i do also have gps on. it works great! first gets a quick fix using tower triangulation, and then the accurate fix (gps) a few sec. to 1 min later depending on where i am. google maps is now very fast on start up (network fix) as well as very accurate (gps fix).
  13. dcam1075

    dcam1075 Member
    Thread Starter

    Excellent, Thanks for the feedback!
  14. briankh

    briankh Newbie

    Press and hold Talk button -- Say "Open Location" -- press Security and Location

    That will take you to the default Android menu so you can have the network set your location.
  15. culo77

    culo77 Well-Known Member

    some crazy reason i was trying to use Reality browser 3.0 and it located me in bellevue WA. google maps was doing the samething.

    turned on gps and gps couldnt find me, opened security and location and turned network off didnt work and turned it on again didnt work.

    i powered off the phone and it worked??????????
  16. yatimameiji

    yatimameiji Android Enthusiast

    Maybe something is wrong with your network settings. Maybe call TMobile and ask if its possible to push out those settings. If I remember they used a proxy back in the day with tzones, so network wise the phone would think its elsewhere. Try running speedtest as that will show you where you are. My phone before this one was a sony ericsson K850. Lovely camera, but anyways I figured out how to tether it and was messing around when I tried speedtest. I dont remember where it thought I was, but I know it wasnt my town(where my pc would show up as).
  17. kat93

    kat93 Lurker

    Greetings! My apologies for jumping in without any introduction; I was doing a search for this problem I'm having and found this thread. It looks like this thread died a few weeks ago... I am wondering if this issue has been resolved at all? I am having a very similar problem:

    I'm using a G1, and the Network Location shows me in San Jose, CA, apparently on Pierce Ave. I am actually in Berkeley, CA. My husband, who also has a G1 and got his at the same time, has the exact same situation. I tried clearing the data as suggested above, and got pretty much the same result: briefly the correct location but then it went right back to San Jose. I've also tried all sorts of variants of turning the GPS on/off, the Network Location on/off, turning the phone off and taking the battery out, etc. The only thing I haven't done is a factory reset, which is a big PITA and probably wouldn't solve it anyway.

    Now, here's the thing: we've had these phones since last May, and we NEVER had this problem up until a couple of weeks ago. This problem apparently coincided with a new cell tower going up nearby. All of a sudden, we got a great signal (it used to be a bit spotty) but our phones now think we're in San Jose. So I'm guessing that the problem might be not with the phones, but with the network. I've thought about contacting T-Mobile about this, but am cynical about the prospect of their employees suggesting anything useful other than a factory reset :rolleyes:

    Any ideas or solutions?

    Thanks all!

    - Kat
  18. dan0zone

    dan0zone Well-Known Member

    This would help us a lil bit ,...,., what version of android is your G1 running ?? ( 1.5 ,, 1.6 ) ????_____,go to settings>about phone>firmwhere version let us know please......
  19. kat93

    kat93 Lurker

    Oh, 1.6, just the standard Donut, no tricks. The problem started occurring long after the Donut update though (like I said, it really seemed to coincide with the new cell tower going up nearby!)
  20. dan0zone

    dan0zone Well-Known Member

    So samsung was right , it is a T-Mobile's issue .For some reason the towers are returning cached locations instead of true locations .
  21. kat93

    kat93 Lurker

    That doesn't quite make sense either... unless I'm completely mis-understanding how this works (which is possible), this isn't a cached location. I've never actually been there since I've had this phone, so why would the location be in my cache? I'm guessing that for some reason, it's picking up a cell site down there instead of the one nearby... but how to get t-mobile to correct this...?
  22. dan0zone

    dan0zone Well-Known Member

    NO .. not in that sense. nothing to do with your G1 just T-Mobile's towers

    when you use the debug tool in the sdk > and you run google maps , ddms shows >> CID= unknow >> returning data from cached location .... and in maps you would see random location ...
    then it says CID=d0a*** >> returning location with accuracy=true and i would see my location
    FYI ..CID ..Cell ID= tower

Samsung Behold 2 Forum

Features and specs are not yet known.

Release Date

Share This Page