1. Check out our companion app, Forums for Android! Download from Google Play

Network Operator Lock

Discussion in 'Android Lounge' started by clivejo, Jul 20, 2010.

  1. clivejo

    clivejo New Member
    Thread Starter
    5

    Jul 20, 2010
    2
    0
    5
    Hi,

    Got my brand new Android phone yesterday but there seems to be one major problem!

    I live between two countries each with multiple operators. So I have manually searched for my operator and 'locked it'. However, the network coverage is very bad and when I lose signal (very regular), Android pops up a screen wanting me to connect to another network, which I don't want do due to massive costs incurred by roaming. I would rather it silently wait until my home operator is within range and connect to it, but it doesn't want to do this! Also, it will keep asking (aprox every minute) to select a new network, which is extremely frustrating!

    Anyone any ideas on how to fix this annoying behaviour?
     

    Advertisement

  2. Demache

    Demache Well-Known Member
    183

    Apr 18, 2010
    3,011
    341
    183
    Sioux Falls, SD
    I'm assuming you have a GSM phone right? So I can't give you very precise directions since I'm in North America with Verizon which is CDMA. But I'll give it a go.

    On my phone, under Settings > Wireless & network settings > Mobile Networks there is an option to select the roaming mode between "Automatic" and "Home Only". I always have it set to Automatic since I won't get roaming fees as long as I'm in the country. But I'm assuming Home Only allows me to only connect to Verizon's network, and ignores the rest. Also, make sure you disable data roaming if you haven't already. That's the REALLY expensive one.

    I'm assuming you've already done this, but here:

    http://androidforums.com/support/4758-gsm-network-roaming-disable.html

    Also, why are you afraid of roaming onto another network? I'm not sure of the specifics for your provider, but you shouldn't get any fees as long as you don't send any text messages and don't answer calls and make sure data roaming is disabled. That's how it worked back when I had a GSM phone when I was roaming.
     
  3. clivejo

    clivejo New Member
    Thread Starter
    5

    Jul 20, 2010
    2
    0
    5
    I don't seem to have that option in my settings.

    I live on the border between Northern Ireland and the Republic of Ireland. Both have the O2 network (O2 IRE & O2 UK). If I accidentally let my phone go onto the wrong network I will be charged a lot! So I don't let it. My previous Nokia let me pick the network and as long as it was set to Manual and my home network, its worked fine. When I was out of range it just said Network Unavailable and I couldnt use voice or data.

    I thought I had the same with the Android based phone, but it will pester me every minute to select another network. This is very annoying and completely interrupts what you are doing at the time.

    Plus, when I do travel into range of my home network, it doesn't seem to re-register, until I do it myself.
     

Share This Page

Loading...