1. Download our Official Android App: Forums for Android!

Root New Captivate owner; My venture into ROMS... Possible newb help inside: Cognition

Discussion in 'Android Devices' started by Dante04SRT, Feb 13, 2011.

  1. Dante04SRT

    Dante04SRT Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    138
    Joined:
    Feb 13, 2011

    Feb 13, 2011
    138
    14
    38
    I got my Captivate about 9 days ago. After returning the first one due to a HORRIBLE shutoff issue, I gave the new one a test for a few days. After it seemed to be fine, I decided to see what all this ROM fuss was about.

    I'm not new to computer/technology by any means, but for whatever reason, I've fought new tech gadgets like Ipods, IPhones, SmartPhones, etc for a while now. Since my contract was up for renewal, I decided to get the Captivate based on the reviews I've read. I've spend the last week reading everything I could find about Android and the Captivate. I'm by no means an expert on the stuff, but I figured I would share my experience to give others who may be new to ROMs some 'help' through the eyes of someone new to the stuff as well.

    Anyway, after doing some preliminary research, I came upon this forum as well as xDA. I also happened upon a fairly well-detailed video trilogy of someone doing a walk through from a stock Captivate to Cognition...

    http://www.youtube.com/watch?v=MsafJ-9uRqk&feature=related

    I watched all 3 videos last night and got the courage to try it this morning... Let's put it this way, it took me from 10:30am to almost 4pm from start to finish. Here's what I learned.....

    Following this video step by step, I rooted the phone (Using one-click root), although I couldn't initially get the "One click" part to work. Instead, I copied the .zip file over renamed it. I then was able to reboot in recovery mode by doing the Vol+/Vol- + Power sequence. It worked fine to allow me to Root.

    After that I, again, followed the video and backed up my apps/data using Titanium Backup. Everything went fine. It wasn't until I had to use the ODIN3 Downloader that I ran into my first major snag. I got ODIN to recognize my phone, but it kept getting stuck at the "file analysis" stage. After 2-3 tries, my phone soft-bricked. I got the "Phone--Triangle--Computer" icon and it wouldn't reboot, or seemingly do anything. It WOULD however allow me to get into the "Downloading..." page with the Droid/Shovel. After a few more attempts with the ODIN flash (Using Start button), the Downloading page stopped working. I was originally holding the Vol+/Vol- buttons and then plugging in the USB cable to get into it. For whatever reason, that functionality stopped; it would just go to USB charging...

    The way I got around this was simply to take the battery out, plug in the USB cable (with ODIN already open on my computer), hold Vol+/Vol- and THEN slide the battery back in - After 3-4 tries, it finally went back to the "Downloading..." screen.

    Once I could get back to that screen, I tried ODIN again to reflash the stock ROM to my phone (as directed in the YouTube video). Still I kept getting the same hangup at the "file analysis" step. I did some quick Google searches and found that it may have been my Windows 7 that was causing the problem. I loaded everything on my WindowsXP machine and it took off the first time, no issues. I was FINALLY able to reflash my phone using ODIN. The phone rebooted and it was a great relief to see the phone come back to life!

    Next, the video said to do a "Master Clear". There again, I had troubles. Sometimes it would start and then stall out, and I'd try again and it would just sit there, and never start. It would up taking me about 5-7 tries until it finally completed the "Master Clear" command.

    Next came to Root the phone again. I had major trouble here for some dumb reason. The OneClick Root still wasn't working, so I copied the .zip file again and tried the 3 button trick to get back into recovery mode. The big shocker was now that I had reflashed to the stock rom (a version lower than my phone had out of the box), I NO LONGER HAD THE 3 BUTTON STUFF!!! I tried like 30+ times to get into recovery mode using EVERY possible way that I could find online and nothing worked. I kept seeing posts all over where people were returning their phones because they couldn't get into recovery mode!

    Figuring that I was going to have to use OCRoot to get into recovery mode, I went back to my WindowsXP computer and tried to use the OCRoot on it but it told me I had to install Dot Net Framework, which ate up like a gig of HD space.

    After installing DotNet, and REINSTALLING the Captivate drivers (http://androidforums.com/captivate-.../123644-captivate-usb-drivers-links-here.html), I was finally able to use OneClickRoot and get into the damn recovery mode. My 64bit Windows7 really seemed to have problems running some things, whereas XP did most everything MUCH better.

    From there, everything went pretty much like the video showed. I installed Cognition v3.04. The only thing that didn't go like video showed was using Titanium Backup to RESTORE the files. After copying all of my saved files/folders back, I had to reboot the phone before Ti-Ba would see them for restoration.

    That's pretty much it for getting the ROM installed - To be honest, it was a real pain because of the problems I ran into, but never having touched (or researched for that matter)an Android device prior to 2 weeks ago, I'd say it went as well as could be expected.

    I hope this information can help someone else who is/was in my shoes.

    I'll post my first impressions of Cognition in another thread.

    -Dan+e
     

    Advertisement

  2. shoman94

    shoman94 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    23
    Joined:
    Dec 5, 2010

    Dec 5, 2010
    23
    3
    16
    Completed mine in less than an hour and used a windows 7 laptop without issue... I flashed mine from the sd card. Rooted using the app from the xda developers section then loaded clockworks and installed the rom on the sd card...went smooth.
     
  3. Rootmepls

    Rootmepls Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    264
    Joined:
    Jan 22, 2011

    Jan 22, 2011
    264
    29
    43
    NorCal
    Getting the right drivers were my biggest hurdle. The ones right off the Samsung site didn't seem to work but the mediafire downloads off of xda worked. Fancy that.
     

Share This Page

Loading...