1. Download our Official Android App: Forums for Android!

Support New Droid Charge and SIM card Problem

Discussion in 'Android Devices' started by Hermosa1, Sep 15, 2011.

  1. Hermosa1

    Hermosa1 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    1
    0
    5
    Just bought a new droid charge.
    Everything was supposed to be set up. Charged for 5 hours.

    Then got a Warning:
    A SIM card is needed to operate this phone. Please turn off your phone and then remove the battery before inserting your SIM card.

    I did this.

    Now the phone won't charge and I am getting the same warning.

    What am I doing wrong.

    Thanks for any help.
     

    Advertisement

  2. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,110
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,110
    24,088
    3,118
    Scotland
    Moved to the Charge forum :)

    Sounds obvious, but is the SIM inserted properly?
     
  3. ufia

    ufia Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Sep 19, 2011

    Sep 19, 2011
    3
    0
    5
    Found this post searching the web to see if anyone else had this problem. I went through 3 phones and 5 sim cards this weekend. Each time the same thing happened. The phone would activate, but within 3 minutes, the sim card would no longer be present. The salesman at Radio Shack spoke with someone at Verizon, and they said it looks like they are having a problem with newly activated Charge phones. I called Verizon the next morning, and they said they see no such problem. Back to the store I went, and when it occured again after activation, they gave me a bionic to use temporarily until they figure out the problem.

    I'd be fine for keeping the Bionic, but this is for my wife, and she wants the Charge.
     
  4. Bozz5384

    Bozz5384 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    222
    Joined:
    Jun 19, 2011

    Jun 19, 2011
    222
    11
    38
    I've heard of lots of problems in the past 3-4 months of SIM card problems in the Charge, no idea why that is. Strange.

    Gotta love it when the minions at Verizon tell there is no problem when you have read all over the internet that others are having the same problem.
     
  5. radioshackdude

    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Sep 26, 2011

    Sep 26, 2011
    3
    0
    5
    Get a new simm card... Call verizon have the new card activated. Put the new sim card into any 4g lte phone other than your Charge...let it activate...once its activated..pull it and put it into your Charge and your good to go. I had same issue..went through 3 cards...now im good..good luck
     

Share This Page

Loading...