1. Are you ready for the Galaxy S20? Here is everything we know so far!

New EASY!! root method for l9

Discussion in 'Android Devices' started by capfl2k5, Jun 26, 2013.

  1. capfl2k5

    capfl2k5 Newbie
    Thread Starter



    JrossiX likes this.

    1. Download the Forums for Android™ app!


      Download

       
  2. blizard

    blizard Newbie

    I love u for reposting an jcase for figuring it out
     
  3. jlede

    jlede Android Expert

    Which l9 models does this work for
     
  4. animusfl

    animusfl Member

    This works in lots of LG phones, seems like it might require JB. Definitely requires system/xbin/spritebud. Just an app to run, if it works, you have root. If not, it does nothing. So it doesn't hurt to try. :thumbup:

    Sent from my LG-P769 using Tapatalk 2
     
  5. zx6guy

    zx6guy Lurker

    Does not work on ICS.
     
  6. kielni

    kielni Lurker

    I rooted my L9 in December when it was 10e, and lost root when it updated to 10g. I didn't bother to do anything because AdAway was still working, but now I want to get root again so I can use the SD card. I have Android 4.1.2, software version 20d, and verified that I do have spritebud.

    I tried this but got "There is no SU binary installed and SuperSU cannot install it" when I ran SuperSU. adb says /system/xbin/su does exist but maybe that's not the right location? I can update, but can't uninstall SuperSU. It seems like the previous root setup is confusing it somehow?

    Any suggestions before I try wiping it and starting fresh?
     
  7. animusfl

    animusfl Member

    A simple reboot should allow you to install supersu or superuser. If not check your file permissions, should be rw-r-r

    Sent from my LG-P769 using Tapatalk 2
     
  8. omgbossis21

    omgbossis21 Android Enthusiast

    Offline flashing for root with the bin is easy. Using the root prep file that's downloaded from the top xda root guide (Lula method or something) will restore your superuser as it was. Thats the l9root. Bat file which can be run before or after the offline flash if you go with that method.
     
  9. kielni

    kielni Lurker

    Thanks for your reply; still no root for me. I tried a few more times, then did a hard reset and tried again. That didn't get rid of the su binary, and getting root didn't work, so I restored my backup.

    Here's what I tried after restoring my backup:
    - verified I have spritebud and su already:

    adb shell ls -l /system/xbin/su
    -rwxr-xr-x root shell 91992 2013-01-24 15:13 su

    adb shell ls -l /system/xbin/spritebud
    -rwxr-xr-x root shell 31116 2013-05-03 08:34 spritebud

    - uninstalled SuperUser (from my previous root in Dec)
    - disabled SuperSU, deleted data and cache (can't uninstall; this takes it back to 0.96)
    - restored LGPwn, restarted
    - enabled SuperSU, updated, and opened
    SuperSU: "There is no SU binary installed and SuperSU cannot install it." A strange thing is that when the app opens, it appears to have a different (old?) logo - a yellow diamond with a red #, instead of the blue bot/red cape
    - installed Superuser; it opened fine and tab showed "No apps in list"
    - tried Titanium Backup: "Sorry, I could not acquire root privileges."
    - tried Root Checker Basic: "Sorry! This device does not have proper root access."

    Oh well, I'll try again after the next update...
     
  10. JustZaphod

    JustZaphod Newbie

    Worked like a charm for me.. Im using the Tmobile P769-20d running JB..
    Ive been trying unsuccessfully to unlock the damn bootloader.. for months now.. lol
    Couldnt get Superuser to work.. even though im sure I could of, but SuperSU worked just as well.. The guys at my local Tmobile store said the L9 is unrootable, now i can tell them to suck it! lol
     
  11. bdmahoney

    bdmahoney Lurker

    After trying just about every other rooting method posted online this one finally worked. YOU ROCK!!!!!!!!!!
     
  12. JrossiX

    JrossiX Member

    i rooted my tmob l9 ics 3 days ago with this method...had been trying for almost two months ....couldnt get that damn lelus method to work or root with restore binay...anyways.....thank u MR. JCASE!!!!
     
  13. Thor28x

    Thor28x Lurker

    Would this work with the MetroPCS LG Optimus L (LGMS769) :thinking: Thanx.
     
  14. skinlab

    skinlab Well-Known Member

    Unfortunately, it doesn't work. .
     
    Thor28x likes this.
  15. ecarlson

    ecarlson Well-Known Member

    Worked on my T-Mobile LG Optimus L9 P769 with the latest 20f Android version.

    I had to go to the first post in the original thread that is referenced in the first post of the thread that is references in the first post in this thread (2 threads back) to get the apk file, but other than that, I installed the apk, ran it, did the restore, let it reboot, installed supersu, and it was done.

    I also uninstalled the apk afterwards and deleted its restore file.

    I tested root access with EsFile Explorer.

    FYI: Not that it is directly relevant, but in case anyone is interested, I did a factory reset a few hours before I rooted it.
     
  16. ebrown761

    ebrown761 Newbie

    correct me if I'm wrong but this does not unlock the bootloader? meaning after this is done i cant install a recovery and flash a rom?
     
  17. skinlab

    skinlab Well-Known Member

    It only roots the phone. There is a CWM on XDA for locked bootloader..
     
  18. Chris3849

    Chris3849 Lurker

    Anybody have a workaround for the apps only being stored on the internal memory of the metro pcs LG l9 Optimus p76910e? Please advise. Thank you.
     
  19. ecarlson

    ecarlson Well-Known Member

    My solution is to root the phone and use Link2SD to move the apps to a second partition on my MicroSD card. I used a 1.GB partition on my 32.GB card. You can use a larger second partition if you plan to install lots of large apps, but I have 72 apps (though very few games) and still have a lot of room left on the second partition. I didn't move all the apps, just many of the larger non-critical ones. I didn't move anything that I wanted to still work in an emergency if something happened to the MicroSD card.
     

LG Optimus L9 Forum

The LG Optimus L9 release date was November 2012. Features and Specs include a 4.7" inch screen, 5MP camera, 1GB RAM, TI OMAP 4430 processor, and 2150mAh battery.

November 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...