1. Check out our app, Forums for Android! Download and leave feedback here!

Root New Maps 4.3 "update unsuccessful" BB .2.1

Discussion in 'Android Devices' started by tjreishus, Jun 22, 2010.

  1. tjreishus

    tjreishus Well-Known Member
    Thread Starter
    88

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    Cant get it to install. Any ideas?
     

    Advertisement

  2. nstallion

    nstallion Well-Known Member
    143

    Nov 13, 2009
    1,152
    136
    143
    San Diego, CA
    Uninstall maps, reinstall.
     
  3. tjreishus

    tjreishus Well-Known Member
    Thread Starter
    88

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    So I went into "manage applications". Maps isn't even listed in there. So I went into root explorer and found it under system, app, and found the APK. I deleted it so that I don't have maps on the phone anymore. I still can't install the new Maps 4.3. So now not only do I not have 4.3, I no longer have ANY map version.

    Any other suggestions? I backed up before doing this, so I can get it back.
     
  4. nstallion

    nstallion Well-Known Member
    143

    Nov 13, 2009
    1,152
    136
    143
    San Diego, CA
    Try putting the .apk back in /system/app/ and then setting permissions to rw-r--r-- then reboot the phone.
     
  5. tjreishus

    tjreishus Well-Known Member
    Thread Starter
    88

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    Are you talking about the permissions in root explorer?

    Restoring back to when I had 4.2, I'll let you know what happens.
     
  6. nstallion

    nstallion Well-Known Member
    143

    Nov 13, 2009
    1,152
    136
    143
    San Diego, CA
    Yeah set the permissions either with root explorer or the terminal.
     
  7. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Forget restoring. Here is the Maps.apk from FRF57:

    Maps.zip
     
    vry5 likes this.
  8. tjreishus

    tjreishus Well-Known Member
    Thread Starter
    88

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    Very cool, and thanks for the APK. I will keep it on my SD card. Unfortunately, I already started the restore.

    Is this the 4.3 APK or the 4.2?
     
  9. tjreishus

    tjreishus Well-Known Member
    Thread Starter
    88

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    Alright, so I went into root explorer, system, app, long pressed Maps.apk, permissions, and selected everything. All permissions are selected, but it still would not install the new version.
     
  10. nstallion

    nstallion Well-Known Member
    143

    Nov 13, 2009
    1,152
    136
    143
    San Diego, CA
    System apps are supposed to be set to:

    User: read, write
    Group: read
    Other: read

    OR

    rw-r--r--

    (same thing)

    Set the permissions that way, restart the phone and see if that helps.
     
  11. tjreishus

    tjreishus Well-Known Member
    Thread Starter
    88

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    Went back and set it to rw-r--r-- Still no luck for me.

    Thanks for trying to help though.

    And yes, I did restart the phone
     
  12. ska.t73

    ska.t73 Well-Known Member
    163

    Mar 11, 2010
    1,659
    305
    163
    Phoenix, AZ
    getting the same issue here on JRummy's Kangerade... I seems to be an issue with Froyo and updating the Maps App... you could try the instructions that people were posting when the Froyo ROMs first came out.

    It involved moving the Maps.apk from the /system/apps folder to the sd card (make sure the Maps.apk is no longer in the /system/apps folder as this was causing issues for some)... Then reboot, and install the Maps.apk from your SD card... Go into Menu/Settings/Manage Apps/All Apps and clear data and cache then uninstall Maps, you should be able to DL it now from the market...
     
  13. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Actually, if it is in the default location as it came with the ROM, then you go to Settings --> Applications --> Manage Applications --> All --> find maps, uninstall it.

    Then you should be able to install it from the market.

    Since it is at 4.3 in the market, I am going to try this exact method myself right now.
     
  14. Branndon

    Branndon Well-Known Member
    43

    Nov 10, 2009
    481
    30
    43
    Website Developer
    Orange County, CA
    Did that work?
     
  15. nstallion

    nstallion Well-Known Member
    143

    Nov 13, 2009
    1,152
    136
    143
    San Diego, CA
    Hmph. I just realized I also have the same problem. Well, a similar problem. The market tells me the package isn't signed properly when I download it. Gonna mess around with it for a bit to see if I can figure it out.
     
  16. tjreishus

    tjreishus Well-Known Member
    Thread Starter
    88

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    Followed the instructions exactly, but it still didn't work for me. I moved the apk to my sd card, deleted the apk from system/apps folder and rebooted. Installed apk from sd card. Went into manage applications, all and uninstalled maps. Went back to the market and got the same "install unsuccessful".

    I thought we had it there.
     
  17. nstallion

    nstallion Well-Known Member
    143

    Nov 13, 2009
    1,152
    136
    143
    San Diego, CA
    I'm starting to think there is either just something wrong with 4.3 or it's having issues with our Froyo ROMs.
     
  18. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Haha, uninstalling from settings does not work. Gonna have to use root explorer and copy the apk to another location and then see if I can uninstall it.
     
  19. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Same thing - have to restore 4.2 back to my /system/app directory.
     
  20. nstallion

    nstallion Well-Known Member
    143

    Nov 13, 2009
    1,152
    136
    143
    San Diego, CA
    I gave up. I think there's something wrong with the 4.3 update apk

    EDIT: I don't see anything in the Nexus 1 forums so either they don't have any problems with it or no one has noticed yet.
     
  21. cruud

    cruud Well-Known Member
    38

    Feb 8, 2010
    159
    10
    38
    Worked fine for me. Froyo BB .2.1
     
  22. Groid

    Groid Well-Known Member
    53

    Dec 1, 2009
    358
    88
    53
    I was having a maps issue also. I downloaded johnlgalt's maps.zip from post #7 in this thread, unzipped and copied Maps.apk to the sdcard. Then I used these commands in Terminal Emulator:

    su
    sysrw
    mv /system/app/Maps.apk /system/app/Maps.apk.bak
    busybox cp /sdcard/Maps.apk /system/app/
    sync
    reboot

    Make sure you capitalize Maps, it matters. After the reboot, I went to the market and chose downloads and the 4.3 update for Maps was there. It installed just fine. My only problem with the new Maps 4.3 is that after every reboot or shutdown, it is like I'm going into maps for the first time and I have to choose the location button from Labs again. Anyone else experience this?
     
  23. subsynth

    subsynth Active Member
    16

    May 20, 2010
    25
    2
    16
    Thanks for supplying the APK. I'm back up on 4.2. I'll hold off on this update for a while.
     
  24. tjreishus

    tjreishus Well-Known Member
    Thread Starter
    88

    Nov 8, 2009
    746
    94
    88
    Airline Pilot
    So, for those of you who have it working, when someone has time can you go through it a bit to let us know if the differences are worth working on getting it on our phones.

    Thanks in advance
     
  25. OMJ

    OMJ Bazinga
    213

    Nov 27, 2009
    3,290
    825
    213
    Finance
    Pennsylvania
    It updated fine for me but I am on cm 5.0.8 not a froyo rom. I can pull the 4.3 apk if you guys want to mess around with that to try and get it working
     

Share This Page

Loading...