1. Are you ready for the Galaxy S20? Here is everything we know so far!

New Milestone-Droid - not opening after first charging.

Discussion in 'Android Devices' started by emilianm, Dec 16, 2009.

  1. emilianm

    emilianm Newbie
    Thread Starter

    New Milestone-Droid - not opening after first charging.

    So I bought my Milestone today, after I played a while with it I plugged the charger and after a while a white light appeared near plug (I don't know if is normal or not ) and now I can not open the mobile any more.
    I even pulled out the battery..but the same result.

    Any idea ?

    Thanks!
     

    Advertisement

  2. eclipsed4utoo

    eclipsed4utoo Android Enthusiast

    the white light coming from the plug port is normal.
     
  3. krichek

    krichek Android Enthusiast

    Plug it back in, the white light near the connector indicates the battery is charging. My guess is the battery isn't charged enough to power the device on. If you are really curious, plug it in and then turn it on as the Droid at least, will work while plugged in even without the battery.
     
  4. BucYouUp68

    BucYouUp68 Android Enthusiast

    Depending on how dead the battery is, If the battery is completely dead, the device will not turn on. Let it charge for about 10 minutes or so. it should then turn on.
     
  5. emilianm

    emilianm Newbie
    Thread Starter

    That is the problem I can not turn it on even when is plug !
     
  6. krichek

    krichek Android Enthusiast


    That is not the case with the Droid. It will power up while plugged in with the battery completely removed. If it is not powering up while plugged in, first make sure you are holding down the power button until you see the Motorola logo, takes about 5 seconds or so. If it still doesn't turn on there is obviously a problem so I would return it.
     
  7. emilianm

    emilianm Newbie
    Thread Starter

    Unfortunately I still have the same problem and I am already discussing with the support from Expansys from Europe.


    I have to mention that I am using the fixed plug and I waited more than 7 hours and phone is not charged. I don
     
  8. n0km

    n0km Lurker

    just for the record... I had the same problem today charging the battery by using usb port. Then I tried using 220/110v -> usb adapter and it worked fine
     
  9. emilianm

    emilianm Newbie
    Thread Starter

    two weeks ago I changed the phone and now is OK :p
     
Loading...

Share This Page

Loading...