1. Check out our companion app, Forums for Android! Download from Google Play

Root New ota

Discussion in 'Android Devices' started by tuzzio, Sep 24, 2011.

  1. tuzzio

    tuzzio New Member
    Thread Starter

    Aug 7, 2011
    Anyone installed it yet? What exactly updated? It installed itself while my phone was in my pocket, however didn't work because of root. my phone just shows the android and has a !. If I unroot and install this, will it effect root?


  2. AndyBones

    AndyBones Well-Known Member

    Jul 5, 2011
    u couldn't google it?
  3. vne147

    vne147 New Member

    Oct 27, 2010
  4. Claribob

    Claribob New Member

    Aug 19, 2011
    Stock DINC2 ROM (rooted): I woke up to this weird glow about a week ago. My phone was all lit up with a white triangle and a yellow exclamation point inside with the little android guy beneath it. Wouldn't turn off. Completely inop. I pulled/re-inserted the battery, powered up into recovery, and restored to a backup I made a month ago. Soon after, I got notification of an OTA update which I deferred until 10/3 at 6P. I read everything I could find on the topic, here and other forums. It didn't take long to find out what others have suggested to do i.e., 1. freeze com.smithmicro.DM, and 2. rename otacerts.zip. What took some time was figuring out how to do those things, especially since I use Ubuntu 10.10 on all my PCs. I found bits and pieces here and there. Thanks to the folks who posted the how-tos.

    First, the easy part. I froze com.smithmicro.DM by opening my freebee Titanium Backup app and tapping the Pro upgrade. After paying for it, all I had do was tap the file and then tap freeze.

    Now the hard part, renaming otacerts.zip I read that I had to get the Android SDK on my miniDell9. I got rev.13 here:

    Android SDK | Android Developers

    Downloaded/extracted the tgz. In one of the text files, I read I needed adb (as in adb shell). I didn't find it. In the tools folder I opened (ran in terminal) the text executable file, android. I high-lighted Installed packages and saw only the Android SDK tools, revision 13. On a WAG, I clicked 'update all' bottom left of screen. It took a long, long time, but eventually it all came down. The download added a folder called platform-tools. In there was the adb executable !! In terminal I navigated there: cd Downloads/android-sdk-linux_x86/platform-tools. Connected my DINC2 to the USB port on the miniDell9, made sure USB debug was on in settings, my phone was on and unlocked. Then typed: sudo ./adb shell in a terminal window on my miniDell. A window popped up on my phone and in so many words, asked me did I want to allow the connection. I ok'd and checked the box to remember. Ahh, there was the user prompt: $ from my phone ! Typing su got me superuser access, #. I navigated to: cd system/etc/security then did an ls. And there was the otacerts.zip file. Well, you might think that a simple command like this: mv otacerts.zip otacerts.zip.bak (like folks have recommended) would rename it. Nope ! It said "failed on otacerts.zip - Read-only file system". It took a while, but I found this on a forum somewhere. There may be other ways to mount in rw, but this worked. At the user prompt: ($), do this:

    mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system
    cd /system/etc/security
    mv otacerts.zip otacerts.zip.bak
    mount -o ro,remount -t yaffs2 /dev/block/mtdblock3 /system


    This worked well. (Note: I didn't type sync nor did I reboot immediately - probably later, though. Not sure what these last two commands do or if they're absolutely necessary)

    Well, yesterday my phones appointment with the OTA update came and went. Nothing happened. Good ! A few min. ago, I moved just the adb executable to my /home folder on my miniDell to make it easier to navigate to it. Maybe if someone knows of a way to get just the adb exec w/o having to download the Android SDK it would be a heck of lot easier.

  5. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut?
    VIP Member

    Feb 24, 2010
    Couldn't you just rename it (otacerts) in rootexplorer or whatever file browser you use?

Share This Page