1. Check out our companion app, Forums for Android! Download from Google Play

Root New rooted Droid user STRUGGLING with mod installations...

Discussion in 'Android Devices' started by physicsperspective, Apr 16, 2010.

  1. physicsperspective

    physicsperspective New Member
    Thread Starter

    Apr 14, 2010
    Last week I finally bit the bullet and rooted my phone. It was a bit of work since I had already updated to 2.1 but I was able to follow along with this very helpful video: YouTube - Motorola Droid - How to ROOT 2.1 firmware! and was rooted without a hitch. Looking at other videos, it appeared the next step was to use ROM Manager Premium to simplify the Rom installation process. I chose to give Ultimate Droid 9.8 a try and it was a breeze installing Chevy's 1.2Ghz LV Kernel, an improved launcher (simply by selecting these options before the Rom download). I selected "clear data" and "backup" and the phone installed the rom, rebooted, all my apps reinstalled, and everything seemed great. I overclocked to 1Ghz, got wifi tethering, and drastically improve my alarm clock with Bedside and LEDs Hack. Everything was perfect until I saw all this chatter about how Ultimate Droid wasn't providing attribution to the CyanogenMod folks and so I thought, "well perhaps I should check that out...". I did a backup by following the Nandroid Backup instructions here: YouTube - Motorola DROID - How to Create a Nandroid Backup - Part 1 and went ahead with CyanogenMod in the same manner that I used for Ultimate Droid 9.8. However this time I wasn't given the option to select a kernel or a launcher. When the phone restarted and re-synced I was missing tons of previously installed apps and some of the core programs (like market) weren't there. Additionally, I couldn't overclock now and the wifi tethering app was gone. Thinking that this mod was just a really stripped down mod and not knowing how to get the apps I needed/wanted, I decided to go back to Ultimate Droid and give the new version 10.0 a try. Similar experience this time (no rom download options) but even fewer apps reloaded (no phone icon this time!). Fed up I tried to go back to 9.8 but encountered the same problems there. I tried to restore the Nandroid backup with Rom Manager but no luck (the phone just reboots). I'm at a loss for what to do next. I'm not too concerned with any data on the phone (everything is either on my HD or in the cloud) but I really want to know what I'm doing wrong. Ideally, I'd be able to install a rom and have an option for all the base programs I want installed (I don't use the corporate calendar for example), the Kernel I want to use, the theme and launcher of my choice, AND have all my applications re-install. If this is too much to hope for, I would still like to have all the base apps installed and learn how to do a kernel, rom, theme, update independent of the rom update. I have the following questions to the forum:

    1) What am I doing wrong?
    2) Assuming these mods are just stripped down, how do I do updates to kernel, theme, and launcher independent of the mod?
    3) Can I hope to re-create my initial 9.8 experience by reverting to stock rooted 2.1 and then using Rom Manager to do a new "fresh" mod install?

    Many thanks to anybody who can help me make some progress. I've been crawling thru various forums on Phandroid, Droid Forums, and here but I run into to many acronyms and tech speak to understand what they are talking about (I think it's a challenge catching up to the Android community that has been tinkering since the G1). I'll never go back to an unrooted phone so here's hoping that someone can help me out. Thanks!


  2. SteveC

    SteveC Well-Known Member

    Jan 10, 2010
    irrigation management
    Klamath Falls, OR
    Well, when I went to CM 5057 from UD 10 I had no particular problem. However, you really need Titanium Backup. That will back up all of your apps and restore them too automatically with the donate version, or manually with the free version. Always have a ROM backup before you do anything.

    When I installed CM, there was a check the google apps box. Sounds like that got past you unchecked. Reflash (or redownload the ROM) and be sure that is checked.

    Just below the place where you tap the ROM you want under Cyanogen, there are two sections for kernels. One for Bekit, one for P3Droid. With the ROM installed, just go in and select one and install it. Then go to Set CPU and set your profiles etc.

    You may have to manually reinstall the apps if you didn't back them up. They will show in the Market, but without backup, you will have to go one at a time and re install.

    Again I really recommend Titanium Backup. It has saved me more than once.

    Seems like WIFi tether was there on my download, but if not just get on the phone, google android wifi tether. That will take you to a google site wher you are just a couple of clicks and a couple of minutes from the tether download and install.
    WIFI tether can be downloaded here
  3. johnlgalt

    johnlgalt Antidisestablishmentarian

    Oct 28, 2009
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Actually, coming from UD9.8 TiBu is going to fark on you if you try to do an all in one apps + system restore. It just will, trust me - completely different bases for UD9.8 and the current CM series.

    physicsperspective, the issue here is that you most likely did *not* wipe cache and data before restoring - this is going to be a must as those are two very different ROMs.

    Also, ROM manager gives you the option to make the Nandroid backup yourself when you are getting ready to install another ROM - it asks you to select (default is not selected) the wipe 8and* the backup.

    Be sure that with UD9.8 you are signed in to your Google account and have allowed the phone to save a backup of the data to your account - then run RM, pick the new ROM you want, select *both* wipe and backup, when the download is done, then let it reboot, make the backup, and then restore the new ROM.

    After that is all complete, reboot the phone, and then log in to your account, Check what you want synced, and then on the next two pages leave all three (2 on the first and 1 on the second) checked, and then leave the phone alone for a few minutes - and it will eventually populate your phone with all your previous apps on its own.

    Finally, if you're computer savvy, then you can *try* to use TiBu but I would recommend doing 1) data only, and 2) one app at a time, and then rebooting.

    The different bases used from UD9.8 and the current CM will make restoring most data associated with system as well as (possibly) other data associated with market apps useless as a worst case scenario, as you've been finding out....
  4. Jeffruby

    Jeffruby Well-Known Member

    Oct 30, 2009
    Here is your problem, I had same issue. Cm rom does not have google files. Go to cm site, where you would dl the cm rom. Below that ull see the google file. Dl to your cpu, then put out in your root, restart phone in safe mode, run that file, boom ure set. This part in instructions was missing for me. Gl

Share This Page