1. Download our Official Android App: Forums for Android!

Support New to Android - Microsoft Exchange Encyption Issue

Discussion in 'Android Devices' started by mattyb05, Sep 7, 2011.

  1. mattyb05

    mattyb05 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 7, 2011

    Sep 7, 2011
    2
    0
    5
    Hi guys,

    New to android (coming across from iphone) and have just got myself a Samsung Galaxy S2.

    However the IT guy at my work is having issues setting up my work email on Microsoft Exchange ActiveSync.

    Apparently after trying to set up it is coming back saying incorrect username/password - even though the details are in fact correct.

    The IT guy has said apparently there is an issue with SGS 2 / android version 2.3.3 and the encryption on Microsoft Exchange.

    He said the encryption settings on android is not what the exchange is wanting to see and that to bypass this issue you need to turn off the exchange encryption (which apparently he doesnt want to do due to security) ???

    Can anyone shed any light on this or a workaround ?
     

    Advertisement

  2. elric999uk

    elric999uk Newbie
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Feb 22, 2011

    Feb 22, 2011
    26
    2
    16
    Male
    IT manager
    UK
    what version of exchange are you using? i'm using android 2.3.3 on exchange 2003 and no issues with connecting, just use the stock HTC email app, are you trying to connect to the server itself, if you have OWA set up on your system use the webmail address and not the server name
     
  3. Osmood

    Osmood Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 11, 2011

    Sep 11, 2011
    2
    0
    5
    We're using Exchange 2007, with OWA setup and correct SSL certificate for access. Iphones (the other staff phone) work ok for Activesync to the exchange server.
    Imap/Pop access is disabled in Exchange so we need activesync, with SSL, to work. Also not going to disable SSL for security reasons on the server.
    I've heard that some versions of Android email client have issues with SSL certificate verification from other forums.
    Mattyb05 has email V3.0.0.1 on Android 2.3.3. Email is setup to the public address of the mail server, the one that is registered in the SSL certificate and setup for activesync access from the internet.

    Any help would be appreciated...

    Osmood - the IT guy.
     
  4. Osmood

    Osmood Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 11, 2011

    Sep 11, 2011
    2
    0
    5
    Solution was to wait!
    I setup the exchange activesync account again from scratch - failed sync due to security settings. Left the phone alone for 15 mins and it came up with a 'manage security' prompt where, which when accepted then let activesync work!

    Strange - the iphone prompts for this immediately, not a long time later.

    However, user's happy, activesync works - all good.

    Osmood
     
  5. Morat

    Morat Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    202
    Joined:
    Apr 9, 2010

    Apr 9, 2010
    202
    22
    38
    I have the same setup, (are you using SBS?) and the Galaxy prompted immediately (both times I've done it). There must be something in the way that handset is set up. We use quite a few Android handsets here and have no issues.
     
  6. +Mie+

    +Mie+ Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Aug 30, 2011

    Aug 30, 2011
    5
    0
    5
    I have to ask you this as this issue have been nagging me since I got my S2 few weeks ago. Any of your users have data in their birthday field on the Exchange? I have quite a few contacts that have values in their birthday field, but the data is not passed to the android phone when synched. I really need the birthdays on the phone so that I can run birthday reminder utility.
     

Share This Page

Loading...