1. Download our Official Android App: Forums for Android!

Support NewBie Wifi Not working

Discussion in 'Android Devices' started by azeemfazal, Oct 9, 2010.

  1. azeemfazal

    azeemfazal Lurker
    Thread Starter
    Oct 8, 2010

    Oct 8, 2010
    The following is my problem:
    When trying to connect any Wi-Fi network, it stuck on obtaining address, any open network, request seems to time out. There is an error. In all cases no problem connecting to same network with laptop and other Wi-Fi enabled phones.

    My ROM is:
    DSTL1 Wifi
    My Hardware Version is:
    Base version 20/05/2009,st32,x2a.m1
    Kernel 2.6.29-senthilvel.prabakrn@si-rd10-ubld01 #1
    Firmware 1.6 (Android Donut)
    Software version: GT540-V10A-MAY-13-2010.

    What I have tried:
    Everything. I have removed battery, rebooted.
    I have reinstalled factory settings, I have configured my home router linksys WRT54G with no security, no mac filtering, created static IP address for phone mac and configured phone with static address but nothing works. Router works fine with other handheld devices and laptop.
    I live outside of UK and cannot claim its warranty. I installed an app Wifi buddy to see if additional settings would help, did not work.
    Phone can see Wi-Fi networks and has excellent signal strength. No problem finding networks. It just can't seem to obtain the IP address. I have also checked on the wireless router that it assigned IP address to my phone.

    Any help would be appreciated. This seems like a good phone/solid hardware but if it can see the Wi-Fi networks and signal strength is good, what could be going wrong? I KNOW, maybe router configuration, but I have tried EVERY POSSIBLE CONFIGURATION for IP address and with no security and no luck.

    It is a very frustrating problem!!! Kindly resolve this issue ASAP.

    Thanks in Advance
    Azeem Fazal


Share This Page