1. Are you ready for the Galaxy S20? Here is everything we know so far!

Newest metropcs / tmobile 6.0 kdz firmware

Discussion in 'Android Devices' started by viperdink, Aug 10, 2016.


    CYCONUMNUM Android Expert

    Win 7 64bit AMD chipset/cpu
    ..android 6 t-mo root script that flashes recovery.img and su in fastboot..
    I can see my phone in adb devices
    But,it chokes at fastboot in download mode..
    It doesn't show in fastboot devices..
    Windows device manager shows android i.d. with no errors..

    #76 CYCONUMNUM, Feb 14, 2017
    Last edited: Feb 14, 2017

    1. Download the Forums for Android™ app!



    CYCONUMNUM Android Expert

  3. bktrk2

    bktrk2 Lurker

    Replying using the app, which I don't care for at the moment, so hope this makes sense.

    Install minimal adb/fastboot here is link from XDA

    Next root manually using only adb and fastboot. This will minimize issues.

    Great guide is available here


    From the guide SKIP STEP 6.

    For step 7 don't install the recovery image but follow guidance at end of paragraph to boot image only.

    This will allow you to boot to recovery and install SU. Once you reboot use flashify app from play store to save recovery image and install twrp recovery.

    Hope this info is helpful.
    CYCONUMNUM and viperdink like this.

    CYCONUMNUM Android Expert

    I can't get it to do anything in fastboot no matter what i try...man i feel stupid...The whatever I'm messing up on..has to be a simple answer....
    Ahhhhhhh....lol...so frustrating.....
    Makes me wanna go back to my previous buggy slow build...
    Once again....can anyone kdz a rooted android6?!?!?
    It's the only way my idiot self will ever see root/recovery!!!!!...
  5. bkttk2

    bkttk2 Android Enthusiast

    @CYCONUMNUM can you get adb to work?
    CYCONUMNUM likes this.
  6. bkttk2

    bkttk2 Android Enthusiast

    @CYCONUMNUM - Let's give this one more try.

    Attention if you try this and end up with a brick or your device spontaneously combusts; it's not my fault you did this not me. Read everything completely and then reread before attempting.



    1) From instruction in OP install latest KDZ (This is optional)

    2) Grab latest Superuser App -

    3) Grab TWRP image, The 3.02 version will work - Download Twrp 3.0.2-0 here: https://www.androidfilehost.com/?fid=529152257862690560

    NOTE - You can name img file whatever you want. I reference it as TWRP.img within this guidance. In the end just remember the name so you know what file you are working with.

    4) For Windows grab the SDK tools from this link -

    5) Place the SU zip file on your external SD card. Also place a copy of your TWRP image on the external SD card.

    6) Extract the Platform Tools package, to a folder you can easily find later (like “C:\Android\platform-tools”).

    7) Place TWRP image in platform-tools folder (this folder contains both adb and fastboot)

    8) On your phone go to Settings/General/About Phone/Software info and tap on the "Build number" until it says"You are now a developer". Then back out until you are in Settings/General and go to "Developer options" and turn "Enable OEM unlock" on and also turn on "USB debugging".

    9) Connect phone to PC via USB. Allow USB debugging and select box on pop-up to always accept the device (PC).

    10) Open command prompt (cmd.exe)

    11) Navigate, within command prompt to platform-tools folder (step 7 above)

    12) In command prompt type "adb devices" [without quotes] to make sure your devices is detected by adb. You may get a toast pop up on your device asking if you to "Allow usb debugging". Except this as this is the RSA key you need to allow your computer to communicate with your device via adb. You should see something like "LGH631dffacad9 device" in your terminal or command line. If you see "unauthorized" instead of "device" you have not excepted the RSA key.

    13) Still in command prompt type "adb reboot bootloader" [without quotes] . This will reboot your device to fastboot mode. Once in fastboot mode type "fastboot devices" [without quotes] to make sure your device is recognized by fastboot. You should see something like "dffacad9 fastboot".

    14) To fully unlock your bootloader you have to type "fastboot oem unlock" [without quotes] . You have to do this or this root method will not work. But be warned that if you do use this command it will factory reset your device. Plus you will get a line of text saying the bootloader is unlocked on the splash screen when you boot your device.

    15) Next type "fastboot boot twrp.img" to boot to the TWRP recovery.

    16) Once you are booted to the TWRP recovery you should first make a full backup to restore to in case things go bad. After you make a backup then select and install SuperSU from your external SD card. Once it is installed reboot your device to system. If TWRP gives you a warning about the su binaries missing and asks if you want to install the su binaries before you reboot select no or it will interfere with the rooting process of the SuperSU.zip. When your device reboots it will boot to the LG splash screen and then reboot again. First boot will take some time. Make sure you let your device reboot completely. You should be fully rooted after this.

    17) Download Flashify from the play store.

    18) Using Flashify backup your stock recovery image and then flash the TWRP image from your SD card. Do this step even if you have TWRP already installed. I have experienced full phone reset when this step is skipped.

    19) You should now be fully rooted with stock recovery.

    This information is a combination of info from multiple users.


    Please let me know if I omitted giving credit to anyone or if information or links need edited.
    #81 bkttk2, Feb 15, 2017
    Last edited: Feb 15, 2017
    whoshotjr2006 and CYCONUMNUM like this.

    CYCONUMNUM Android Expert

    I figured it out.....
    I knew it was something simple and right in front of me...
    Thanx everybody!!!
    The drivers were installing....but, not...
    I finally remembered that even thou they installed...i had to tell windows to use it....
    When i finally remembered...i had 9 drivers to choose from...most being the right one....Windows just needed me to hold its hand....
    I booted recovery...flashed SU...then..since i was feeling lucky i flashed the recovery.img..using twrp...
    Only oddity is..recovery says i don't have SU installed and asks if i want to flash it...
    But, while system is loaded..i have perm root and everything is fine...
    So..now i can stop running around yelling that the sky is falling..
    Sorry..im not stable...thanx for your patience
    viperdink and bkttk2 like this.

    CYCONUMNUM Android Expert

    Well..days later...if feels sluggish
  9. viperdink

    viperdink Android Expert
    Thread Starter

    I jumped up to 20k firmware.
    It all worked great till i tried the 3.02 twrp.
    I had to flash 10j twrp. What is the problem ? I tried a few reboots and it just
    Froze up. The good part was just pulled the battery and retried again.
    I had to use the old twrp 10j . The new 20k Firmware does work and the adb method rooted fine . Be sure to factory reset it 1 more time before you do your final setup. This will clean up junk that is left behind then do a nandroid for safe keeping as usual.
    bkttk2 likes this.
  10. bkttk2

    bkttk2 Android Enthusiast

    Not sure of the issue. I know that I have to use flashify, even with TWRP installed, after each upgrade. I basically just reflash TWRP recovery. I do not remember which firmware version I had the issue with but I did not do this step and the first time I booted to recovery it did a factory reset.

    Not sure if it is related to your issue or not but I do the flashify step everytime and have not had any issues since. Also I am using the most recent TWRP version posted in the forums.
    viperdink likes this.
  11. joethe 1

    joethe 1 Member

    hello tried to return to stock rom to get rid of root to update to newest firmware everything went good until i unpluged it after it was done but now my phone wont turn and not recognized by computer any help
  12. viperdink

    viperdink Android Expert
    Thread Starter

    We Have shared in the O/P with the newest firmware !
    They are coming so fast we haven't had a chance to test.

    Please Share your results with us, We all appreciate all shared information and
    help through out OUR community.
    CYCONUMNUM, GoldenEpic and bkttk2 like this.

    CYCONUMNUM Android Expert

    I'm still on the k i think..without the zip flash...i dled it 3 times n got constant errors trying to flash it in twrp...
    I constantly get apps crashing....YouTube crashes halfway through any vids...
    Instagram crashes....
    Ui crashes..not as often as the rest..
    Maps crashes every other mile...
    But..that's the fone since ..maps have been crashing since i bought it

    Funny thing...my software info says I'm on H63120b...but that's because of the sound mod i flashed ..i need to update it i spose

    CYCONUMNUM Android Expert

    And my device sans anymods other than looks...occasionally turns into a hand warmer...use or no use..it just starts cooking
  15. viperdink

    viperdink Android Expert
    Thread Starter

    Ju gotta go back to da drawin board if sys info shows that in settings info.

    CYCONUMNUM Android Expert


    CYCONUMNUM Android Expert

    Can i jus kdz thingy this new jammy?..
    Since im all pro now...ha
    bkttk2 and viperdink like this.
  18. viperdink

    viperdink Android Expert
    Thread Starter

    CYCONUMNUM and bkttk2 like this.
  19. viperdink

    viperdink Android Expert
    Thread Starter

    O/P updated ;
    Tmobile Firmware added
    Spec2nirvash, bkttk2 and CYCONUMNUM like this.
  20. viperdink

    viperdink Android Expert
    Thread Starter


    #95 viperdink, Jun 1, 2017
    Last edited: Oct 2, 2017
    bkttk2 and tube517 like this.
  21. viperdink

    viperdink Android Expert
    Thread Starter

    Tmobile Firmware update
    BUMP; check post #1 - O/P
    SFVTrigger likes this.
  22. viperdink

    viperdink Android Expert
    Thread Starter

    Attached Files:

  23. viperdink

    viperdink Android Expert
    Thread Starter


LG G Stylo Forum

The LG G Stylo release date was May 2015. Features and Specs include a 5.7" inch screen, 8MP camera, 1/2GB RAM, Snapdragon 410 processor, and 3000mAh battery.

May 2015
Release Date

Share This Page