1. Are you ready for the Galaxy S20? Here is everything we know so far!

Nexus 7 won't charge wirelessly any more

Discussion in 'Android Devices' started by kindakooky, Dec 30, 2015.

  1. kindakooky

    kindakooky Newbie
    Thread Starter

    I use a RAVPower Qi wireless charging pad to charge my Nexus 7 and this has always worked absolutely fine, up until a few days ago when I noticed that it wasn't working properly any more. When I place it on the charging pad the pad beeps to show it is charging and the screen on my Nexus says that it is now "charging wirelessly" and indicates the percentage of battery life. Everything indicates that it is charging as normal but when I go back to it a few hours later it hasn't charged at all or has started losing power. I tried charging it on the Samsung wireless Qi charger i use for my phone and had the same problem.

    Any else had/got similar issues?
     


  2. Madbat

    Madbat Android Expert

    Are you sure you don't have a wakelock draining your battery as fast as it charges?
     
  3. kindakooky

    kindakooky Newbie
    Thread Starter

    What's a wakelock?
     
  4. scary alien

    scary alien not really so scary
    Moderator

    A wake lock is a mechanism for an app to keep the screen / display on (vs. going dark/off) or the CPU running (instead of going into low-power / deep-sleep mode).

    There are system calls (APIs) that an app can use to create a wake lock -- see http://developer.android.com/training/scheduling/wakelock.html#cpu for details.

    Wake locks are indeed often a culprit for a device's battery is being drained, although it kind of sounds like this is not related to the issue you're asking about (i.e., a hardware issue vs. and app/wakelock issue)?

    You could probably rule-out a misbehaving app if you haven't recently changed/installed anything. If you have recently made changes (new apps) or seen that a syncing app has been updated), then that might be the issue as Madbat suggested.
     
    Madbat likes this.
  5. mydian

    mydian Android Expert

    You could try charging wirelessly with the tablet turned off. That would rule out any wakelocks causing the problem.
     
    seVer and scary alien like this.
  6. Madbat

    Madbat Android Expert

    Try charging wired to see if it charges better. Narrow problem from battery issue to wireless issue
     
    mydian and scary alien like this.
  7. kindakooky

    kindakooky Newbie
    Thread Starter

    It charges fine using the wired cable. Does this mean the wireless charging coil thingy inside the tablet is knackered?
     
  8. Madbat

    Madbat Android Expert

    Could be. I know that's a horribly ambiguous answer. I should say, likely.
     
    scary alien likes this.
  9. ssenemosewa

    ssenemosewa Lurker

    Just a thought: Is your Nexus in a case? If so, you might try removing it from the case to see if it charges properly without it.

    You might also want to try putting the Nexus into Airplane mode and reducing the screen brightness to see if that helps.

    Remember, wireless charging is never as efficient/powerful as direct charging. If something is using up the juice faster than the wireless can supply it, then you'll end up with a net drain.
     
    scary alien likes this.
  10. Nate Ocean

    Nate Ocean Lurker

    Mine charges normally with the USB cable directly connected.

    Previously no charging problems with a Qi charging pad. Now the Qi pad doesn't connect. The Qi red "power" light is on, and the green flashes for an instant when power is applied.

    However, the green "charging" light on the Qi pad doesn't connect when the Nexus 7 tablet is placed on top. And the Nexus 7 (2013) does not show a charging "lightning bolt".

    Before I proceed further (replacing the Qi pad), I want to know if any recent Nexus 7 updates might have caused this. This has only been a problem for a day or two. I've wasted time in the past tracking down a problem that turned out was corrected in a following Nexus 7 update.

    (Mine in in a genunine Nexus 7 case, but that has not been a problem in the past as long as it is properly centered on the Qi pad.)
     
    #10 Nate Ocean, Feb 15, 2017
    Last edited: Feb 15, 2017
  11. seVer

    seVer Android Expert

    remove the case and find out. if it works ok, the case is the likely culprit. there hasn't been a software update in a while, and the last security update was last August, so highly unlikely a "recent" update is the problem, unless it's an app.

    1) to eliminate software, try charging while powered off. if still doesn't work...
    2) to eliminate case, try charging with case off. if still doesn't work...
    3) try a different wireless charger OR try a different device on your charger
     
  12. mydian

    mydian Android Expert

    This device hasn't received an update since August 2016 so that's ruled out. I would try a different charging pad.
     
  13. Nate Ocean

    Nate Ocean Lurker

    OK here was the culprit.

    I had notice what I thought was a slight position sensitivity when placing the tablet on the charging coil, but it turns out it was slight *pressure* sensitivity.

    The battery is original, and performs fine, but the tablet had been left on the patio (in Arizona) and so it overheated. There was not a slight bulge to the back cover. Opening the unit revealed the LIon battery envelope was "ballooned".

    The "ballooned" battery pressure was pushing the back cover away sufficiently that the small "S" shaped contacts to the charging coil on the back cover were intermittently making contact to the main circuit board.

    A temporary fix was to slightly "stretch" the "S" contacts. This worked reliably for the week it took to get a replacement battery. Prior to the battery replacement there was a noticeable bow to the back cover, but also a slight bow (about 1mm) to the actual display...which was scary. With the new battery everything is back to normal.

    Thanks, all, for your helpful relies.
     
    psionandy and scary alien like this.
  14. scary alien

    scary alien not really so scary
    Moderator

    Yikes, a "ballooned" battery is not good and should probably be replaced--safety first! :)

    Thank you for replying/posting back here, though--that does shed some light on how all this stuff works :).
     
    seVer and psionandy like this.
  15. Ken Bouchard

    Ken Bouchard Lurker

    I Discovered this. If I have my nexus7 that It charges QI OK as long as NOTHING is plugged into the MICROUSB Charging Port.

    I was trying to watch a Movie on my USB Stick/Adaptor, but when I plug into the USB Stick to the charge port, the QI charging stops. When I unplug it, it resumes Charging. So make sure you are not using a mouse or other USB device, as it fools the charging system into thinking you have WIRED charger hooked up. I see this as a POOR DESIGN limiting your ability to use the tablet via the USB flash drive etc.
     

Nexus 7 (2013) Forum

The Nexus 7 (2013) release date was July 2013. Features and Specs include a 7.0" inch screen, 5MP camera, 2GB RAM, Snapdragon S4 Pro processor, and 3950mAh battery.

July 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...