1. Download our Official Android App: Forums for Android!
  2. We apologize for the disruption in email services! They are sending out now, but there is a backlog, so it may take a little time to catch up.

Support Nexus Completely Lifeless

Discussion in 'Android Devices' started by sheikhnauman, Oct 2, 2012.

  1. sheikhnauman

    sheikhnauman Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 2, 2012

    Oct 2, 2012
    1
    0
    5
    I have Nexus S GT-i9023, not rooted, running Jelly Bean 4.1.1 for more than 1-month now.

    Today I was uninstalling un wanted apps and the phone slowed up. The un-installation was killed due to no response.

    Meanwhile I had an incoming call, I attended and while attending the phone just went dead. Completely dead.

    I have tried charging through computer USB and wall charger, tried taking the battery out, battery in, with charger attached, without charger attached, through computer USB, through wall charger, pressed power button+ volume down button. Nothing seems to work.

    The phone won't even vibrate when power button pressed. It's completely lifeless.

    It has been working perfectly since 8 months, no problems at all.

    Any help please? so in love with my Nexus S :(:(
     

    Advertisement

Tags:

Share This Page

Loading...