1. Download our Official Android App: Forums for Android!

Support Nexus S Can't Mount SD Card [SOLVED]

Discussion in 'Android Devices' started by XeroxCopy, Dec 7, 2012.

  1. XeroxCopy

    XeroxCopy Lurker
    Thread Starter
    Dec 7, 2012

    Dec 7, 2012
    Just thought I would post this here in this forum as maybe it may help someone with a similar problem. To make a long story short I had a Nexus S passed down to me and I found the built in SD card would mount on my OLDER computer but wouldn't mount on my NEWER one. Here's what I did to SOLVE the problem.

    1. Downloaded the SDK Tool Kit to get the Google USB driver.

    2. Downloaded the SDK .exe version (not the .zip) from - Download For Other Platforms Link at the bottom of Android Developer Page page.

    3. Opened SDK and checked both SDK platform Tools & under Extras the Google USB Driver - Install Packages

    4. Open Device Manager find the Google Nexus S Device with exclamation mark. Right Click on it - Properties - Driver - Update Driver - Browse My Computer - C:program Files\ Android\ android-sdk\extras\google\usb-driver - Next and let it install

    5. In the Google Nexus S browse to System Settings - Developer Options - Turn On Switch at top - Check mark USB Debugging

    6. Plug Google Nexus into USB port and tab Turn On USB Storage - wait until the Android goes orange then your connected.

    *Here's the part that had me stumped :mad: :

    When I opened Computer to see the list of available drives I could see the new drive letter for the Google Nexus S but it wouldn't let me access the SD card in the phone. After searching endless forums and doing countless trial and errors this was the solution :)

    7. Goto Device Manager - USB Serial Bus Controllers - Right Click on Standard Enhanced PCI to USB Host Controller (anything that says enhanced) - choose disable (*do not uninstall disable only!*)

    8.Go back to Computer and see if you can access your SD, it worked for me it will for you too.

    When you disable the (Standard Enhanced PCI to USB Host Controller) you are actually disabling USB 2.0 support for your machine. It seems either the Google Nexus Phone or the plug adapter prefers the old USB 1.1.

    The USB 2.0 on my machine works by the running controller setting in the BIOS which switches the USB 1.1 to USB 2.0 So instead of playing in the BIOS you can just disable the Standard Enhanced PCI to USB Host Controller in the Device Manager - that way when you are finished accessing your smartphones SD card just Reboot the PC and you will have your USB 2.0 back and the Standard Enhanced PCI to USB Host Controller will be back in the Device Manager.

    Presto - Happy Days Once More....:star:



Share This Page