1. Download our Official Android App: Forums for Android!

Nexus S voip connection problem

Discussion in 'Android Devices' started by 3D Accuracy, Jul 10, 2011.

  1. 3D Accuracy

    3D Accuracy Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jul 10, 2011

    Jul 10, 2011
    6
    0
    5
    Los Angeles, CA USA
    Here’s my situation:

    I have a new Samsung Google Nexus S Android unlocked phone that I will use primarily as a voip phone with my sip service. I have a new Motorola SBG6580 wireless cable modem/router and a new ATT MiFi 2372 mobile hotspot. I’m using Broadvoice as my voip service.

    I want to be able to use my Nexus S phone with my Motorola SBG6580 wireless cable modem/router to make/receive voip calls when I’m in my home office and use my ATT MiFi 2372 mobile hotspot when I’m traveling out of my home office.

    My Nexus S phone will connect to the ATT mobile hotspot and register just fine with my voip service. I can get on the internet and make/receive phone calls without any problem. Therefore I know all the settings on the phone to communicate with my Broadvoice voip service are ok and functional.

    My Nexus S phone will connect to my Motorola SBG6580 wireless cable modem/router. I can get on the internet just fine and visit any website I want but it will not register with my Broadvoice voip service so I CAN NOT make or receive phone calls through a wifi connection. It keeps telling me that it failed to connect or the connection timed out.

    As an experiment I downloaded Counterpath X-Lite software on my laptop and it works perfectly going through the Motorola cable modem/router, registers with my Broadvoice voip account and I can make and receive phone calls with my laptop with no problems.

    What this experiment tells me is that there must be some difference in the way the Nexus S phone communicates with the wifi on the Motorola cable modem/router versus how my laptop communicates with it. I took the phone to the local library and had the same results as I’m having in my home office. Connects to the open wifi and can get on the internet just fine but CAN NOT connect to my Broadvoice voip sip service.

    I need the phone to work and make/receive voip calls with any open wifi connection as I travel frequently. My old Linksys WIP 330 voip phone worked great anywhere I could get an open wifi connection, I need my new Nexus S phone to do the same.

    Anyone else experience this problem and found a solution?

    Any help would be greatly appreciated as I’ve been trying to make this work for almost two weeks now with no success.

    Have a terrific weekend!
    Robert
     

    Advertisement

  2. quantumrand

    quantumrand Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,237
    Joined:
    Sep 2, 2009

    Sep 2, 2009
    1,237
    198
    143
    Could be your router isn't configured to forward the proper ports to your phone when it's connected.
     
  3. 3D Accuracy

    3D Accuracy Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jul 10, 2011

    Jul 10, 2011
    6
    0
    5
    Los Angeles, CA USA
    Thanks for your reply Jimy,

    Are you connecting to your voip provider via an open wifi connection?

    I can get my Nexus S to work perfectly when I connect through my ATT mobile hotspot so I don't believe it's any of the settings on the phone or my voip service provider.

    I can't get it to work when I connect through my cable modem/router or another open wifi connection so I believe it has something to do with google's software not being able to connect properly via wifi.

    If you're connecting via a wifi connection I'd appreciate it if you could share your setting with me so I can compare them to what I have and see if that will correct my problem.

    Thank you for your reply quantumrand,

    I don't think it's the cable modem/router because I talked with Motorola and we adjusted some setting with no luck. My NExus S wouldn't work at my local library via their open wifi connection either. Gets on the internet just fine but won't register with my voip service so I can make/receive calls.

    What concerns me with making custom settings on my cable modem/router is whether or not the phone will connect to an open wifi connection that I don't have any control over adjusting the settings.

    As an example, I have in the past used my old voip phone to make phone calls while standing in the airport in Chicago, Los Angeles, Denver and Hong Kong. I'd like my Nexus S phone to do the same as I'm sure they're not going to make custom settings for me every place I go just so I can use my Nexus S phone.

    If the Nexus S phone won't work with any open wifi connection to connect with a voip service then I think that Google has dropped the ball some place and they need to correct the problem.

    I appreciate the input from both of you very much. Anything else you can think of will also be appreciated as I'd surely like to find a solution to this problem.

    Have a terrific day!
    Robert
     
  4. quantumrand

    quantumrand Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,237
    Joined:
    Sep 2, 2009

    Sep 2, 2009
    1,237
    198
    143
    The Nexus S uses UDP as the default protocol for VOIP connections. Not all routers are configured to allow UDP connections. When setting up your VOIP account on your Nexus, there's an "Optional Settings" button. You can set it to use TCP instead, which should be compatible with more routers (assuming your SIP provider allows TCP connections).

    I can't say for certain that will fix it, but it's worth a shot.
     
  5. 3D Accuracy

    3D Accuracy Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jul 10, 2011

    Jul 10, 2011
    6
    0
    5
    Los Angeles, CA USA
    Hello quantumrand,

    Thanks for the suggestion. I tried it but it didn't work trying to connect through my cable modem/router or my ATT mobile hotspot.

    I called Broadvoice, my voip service provider, and they informed me that they use UDP only. He said that it should work as UDP is part of the TCP-IP stack. I don't know exactly what this means but I'll take his word for it that it should work. His was of the opinion that it's a problem with Google's software not working properly over an open wifi connection.

    I think I'd have to aggree as everything I've tried so far points to a Google software problem.

    I'm wondering if there is anyone out there who is strictly using the Nexus S as a voip phone with a wifi connection and have it working properly. If so I'd like to hear from you.

    If you can think of anything else please let me know as I'm open to giving anything a try at this point.

    Have a terrific day!
    Robert
     
  6. 3D Accuracy

    3D Accuracy Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jul 10, 2011

    Jul 10, 2011
    6
    0
    5
    Los Angeles, CA USA
    Yesterday I tried using Counterpath's Bria Android Edition software in an attempt to be able to connect with my Broadvoice voip service while connected to my Motorola cable modem/router. I had limited success. It shows that I'm connected to my voip service but if I try to use my contact list to place a phone call it does absolutely nothing and if I manually enter the phone number I want to call I receive an error messages saying "too many calls".

    I was told that this is a known bug that should be fixed in their next release but was not given a date when that would be. I cancelled the software and uninstalled it. By the way it would not work using my ATT mobile hotspot to make/recieve calls either although it does appear to register with my Broadvoice voip service which is one step in the right direction.

    What this tells me is that there is something missing in Googles sip software when trying to connect to a voip service while connected through a wifi connection. Counterpath's Bria Android Edition software showed that it was connected to my Broadvoice voip service via wifi and mobile hotspot while Google's softare will only connect when I use the mobile hotspot.

    I then tried Sipdroid software and had this experience. It will not connect and register with my Broadvoice voip service using my Motorola cable modem/router or my ATT mobile hotspot. I've uninstalled it.

    Again I'd like to ask the members of the forum if anyone has had any luck using their Nexus S phone as a voip phone while connected through a wifi connection using only Google's native sip software?

    If so would you please share what you've done to make it work, I'd really appreciate it.

    Have a terrific day!
    Robert
     
  7. 3D Accuracy

    3D Accuracy Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jul 10, 2011

    Jul 10, 2011
    6
    0
    5
    Los Angeles, CA USA
    Well ... after three weeks of trying to find a way to get my new Nexus S phone to be able to make and receive voip calls through my wireless cable modem/router I finally have a solution that works perfectly.

    While searching the internet again this evening I came across a blog that mentioned a free app on the Google market called CsipSimple. I found the app, installed it and it works great.

    The setup is very straight forward and simple, in fact it has a quick setup feature that allows you to select your voip provider. They had one for Broadvoice, which is who I'm using. I simply selected it and then entered my phone number and password. That was all the information I needed to input for it to setup my account, register with the service and work flawlessly.

    It works with both my wifi connection and my ATT mobile hotspot. The interface is great and it works seemlessly with my Google contact list.

    It appears that there is something missing with Google's native sip software that it won't work correctly with a wifi connection. CsipSimple solves the problem and I'd highly recommend it to anyone else experiencing the same problems with their Nexus S phone that I was having.

    Thanks again to those who took the time to suggest solutions, I appreciate it.

    Have a terrific weekend!
    Robert
     
Tags:

Share This Page

Loading...