1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support No 3G, H or E icons showing, but I have full signal

Discussion in 'Android Devices' started by ReeceasaurusRex, Aug 9, 2013.

  1. ReeceasaurusRex

    Thread Starter

    mods pls
     

    Advertisement

  2. legalkill

    legalkill Android Enthusiast

    Did you reseat your sim card. You may want to have carrier try replacing the sim card if it does not work. Also check settings for network in more settings in my verizon but I see that you are not so somewhere. Just check all options in al the settings under mobile network.
     
  3. tensazan

    tensazan Android Enthusiast

    It sounds similar to what happened to my original s3. The antenna was either faulty or something was messed up really bad, and would do the same thing as yours, the only difference was that mine would at least say 1x.

    Have you tried reflashing your ROM through Odin? You could also take it to a store and see if they can fix it.
     
  4. ReeceasaurusRex

    Thread Starter

    I thought about rooting. I know a fair bit about it. I've rooted and managed two devices in the past.
    Problem is, they were both cheap devices and not on a contract. I don't want to risk rooting. Especially since it voids the possible warranty I have (which I'm not sure about)
     
  5. funkylogik

    funkylogik share the love peeps ;)

    Three is ok for me today mate but its been bad recently. So, without wifi you cant call, text or go online?
    take it u tried giving the sim a clean?
     
Loading...

Share This Page

Loading...