1. Are you ready for the Galaxy S20? Here is everything we know so far!

No in-car charging or Android Auto

Discussion in 'Android Devices' started by IRFU2022, Mar 7, 2022.

  1. IRFU2022

    IRFU2022 Lurker
    Thread Starter

    Previously, both mine and my wife's mobile phones both connected via USB to our cars. Now, the phones still connect via USB for charging and Android Auto in my car but will not connect to my wife's car (Mazda CX-30). When you plug either phone in to the car, it instantly vibrates and the charging icon come up but then within a fraction of a second, it disconnects. This continues every 10 or so seconds, connecting then instantly disconnecting again. You therefore cannot charge the phone or use Android Auto. I replaced the cable and same issue, have reset the cars infotainment to factory settings, uninstalled Android Auto and still no change. I took the car back to the dealer who then connected 3 different mobiles to the car, all of which had no issues and started Android Auto automatically but when I tried to connect my phone to a brand new car there (same model), it replicated the issue I have with our car! So it's not the car and I'm out of ideas! Is there a likely setting on both our phones which may be causing this issue and blocking charging/connection from the car?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    I merged your posts into the device forum since you indicate that is isn't a problem with the head unit. Are both phones the same (Oppo Find X2 Neo)? Have there been any recent updates? It seems unlikely both you and your wife would simultaneously change the same setting.
     
    ocnbrze and GameTheory like this.
  3. IRFU2022

    IRFU2022 Lurker
    Thread Starter

    Hi Unforgiven, no mine is an OPPO Find X2 Neo and my wife has a Samsung Galaxy A41. It is really strange that both phones contune to work fine in my car yet not in hers and other phones work fine in her car!
     
  4. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    Hmmm... ...I don't use AA, but it seems like that is working in the other car. Is the USB prompting to connect?
     
  5. IRFU2022

    IRFU2022 Lurker
    Thread Starter

    When I connect the cable, the phone recognises a connection and vibrates and the usual 'Charge only, Transfer Files/Android Auto etc' options appear for a fraction of a second then it disconnects. It reconnects about 10 seconds later and the same happens and this continues as long as the cable is connected. It never actually charges or connects to AA as the connection drops so quickly but doesn't do this with any other phones (other than my wifes)
     
  6. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    I'm Googling, but a couple things I've found so far that you may try. Check the usb port in the car and make sure there is no dust or debris. Also, try clearing cache for Android Auto, Google Play Services, and Android Assistant.

    The dirty usb port sound the most promising at this point.
     
    ocnbrze and olbriar like this.
  7. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    Also try different cables as well
     
  8. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    He did mention a new cable in the OP. That, and a bad port on the phone were some of my initial thoughts, but the devices work in the other vehicle. I *think* USB does some type of low power listening to determine when a device is connected, then ramps up the power for charging and communication. I think this is what he is seeing with the initial connection / charging notification. When things are firing up something is going wrong so the USB is shutting down (either from the phone or the head unit) to prevent damage to anything connected. That's why, having eliminated the phone ports and the cable, I think it could be debris or other problems with the usb port in the car.
     
    ocnbrze likes this.

Oppo Find X2 Neo Forum

The Oppo Find X2 Neo release date was 21 May. Features and Specs include a 6.5" inch screen, 48MP camera, 12GB RAM, Snapdragon 765G 5G processor, and 4025mAh battery.

21 May
Release Date
0
Reviews
Loading...

Share This Page

Loading...