1. Are you ready for the Galaxy S20? Here is everything we know so far!

No internet on Huawei smartwatch since Androidwear 2

Discussion in 'Wear Os' started by foktop, Jun 27, 2017.

  1. foktop

    foktop Lurker
    Thread Starter

    Hi, I cant find anything with my specific issue. My watch connects and seems to stay connected via Bluetooth but when I try to do anything that needs internet connection I get the error "no internet connection" I have the Lg G6 and was factory reseted and so is the watch...


    1. Download the Forums for Android™ app!


  2. doc1964

    doc1964 Android Enthusiast

    AW2 has totally screwed up the Huawei watch. Mines worked perfectly with my s7 but after the last update, it will not access google accounts so i cant get to install the watch facesi have on watchmaker. Cant get google feed, cant load apps direct on phone from play store. What is so annoying is you see loads of reviews on play store stating it is buggy, yet get the same bland response from google stating, reset watch, wipe caches, reach out to us. Putting me right off android.
  3. The_Chief

    The_Chief Accept no imitations!
    VIP Member

    Maybe I'm doing something wrong, but my Huawei Watch with the Note 5 isn't having any of these issues.

    *Knocks on wood*
  4. James L

    James L Android Expert

    Flash the firmware.
  5. doc1964

    doc1964 Android Enthusiast

    the strange thing is that my watch updated to AW2 and worked perfectly. I then got an update to my S7 and i reset the phone as i usually do after updates and then when i went to reconnect to my watch, it fails at the connect to google accounts stage.
    If you look at the Android wer comments on play store or indeed look at the google support forums you will see hundreds of similar reports. Definitely some major issues with AW2.
    So just dont reset your watch or phone in case you end up in same boat.
  6. doc1964

    doc1964 Android Enthusiast

    I posted this on the Huawei watch site but thought i would post it here as well in case it helps anyone.
    Well, with absolutely no help whatsoever from google i finally managed to get my watch fixed.
    As i mentioned previously i tried every hint and tip i could find on line but could not get the watch to connect to my google account. Found a new post last night that i almost ignored as it seemed to cover everything that i had previously tried. But as i was at a loose end i thought i will give it a go. Well, when i came to step to add account, my account showed up. I nearly fell off my chair but it is finally working. Here is what i did. Thank you to Mats-Ove Fant whoo posted this.
    Mats-Ove Fant said: Finally. After three hours I got AW to add my Google Account. Key actions. 1) First I did all the things to reset watch and phone (as clear all data for both cache and storage for AW, Google Play Service app, Google Play Store app and Google app on phone, resetting watch to factory settings). 2) Remove all Google accounts from your phone. Make sure 2-step verification is turned off for the account you are going to add. 3) Reconnected the watch, configured it and skipped the adding of the account. 4) Turn off WiFi on BOTH phone and watch. Seems to be important. 5) On your watch choose to add an Account. On my watch it opens AW on the phone. 6) AW informs you that you must add at least one Google account to the phone. I added my primary account and after that it was listed as available by AW. I chosed it and AW started to copy settings to the watch. I had to reinstall all my AW apps on the watch but at least it's working.
    Now it looks like a watch.

    Attached Files:

  7. jerrytaff

    jerrytaff Lurker

    I've just bought a Huawei Watch, and spent a very frustrating evening trying to set it up...the play store only installs the latest versions so I had AW2 on the phone but the watch was set up for AW1. It nearly worked, and I did actually get the watch up and running at one point; it took over half an hour updating stuff and starting to sync, but it lost the bluetooth connection before it had synced time and date, and could not re-establish it. So I had a watch with no connectivity, displaying the wrong time and date! I ended up unpairing and starting again...with no joy.
    Finally the penny dropped, and I found the APK for the final version of AW1, and installed that on my phone. I then found that provided my phone was not plugged in to a charger and the watch was, that it could set itself up. I then tried upgrading to AW2 from the watch, and everything was fine. The last thing I did was to sync my google account. That took several attempts, until I ensured that both phone and watch were connected to the wifi with the watch in the charger.

    So now all I need to do is to work out which apps to install,,,,,
  8. doc1964

    doc1964 Android Enthusiast

    I would suggest watchmaker, it give you access to thousands of great watch faces like the Rolex in my earlier post.
  9. lennydude

    lennydude Android Expert

    +1 on the Watchmaker app:)
  10. Julian Eke

    Julian Eke Lurker

    Hi had the same issue with my P10 to Huawei Watch 2. Have just uninstalled Wear OS and reinstalled, followed each of the installation steps, allowing access to everything and now everything is synchronized together and I can use the internet connection of my phone to download watch faces/ apps etc. Good luck
    codesplice likes this.

Share This Page