1. Download our Official Android App: Forums for Android!

Support No Internet

Discussion in 'Android Help' started by Ivan Berger, Aug 9, 2016.

  1. Ivan Berger

    Ivan Berger Member
    Thread Starter
    Rank:
     #567
    Points:
    26
    Posts:
    49
    Joined:
    Oct 21, 2015

    Oct 21, 2015
    49
    2
    26
    Male
    I have a data plan, but when I'm out on the road, services like Google Maps or Shazam often tell me I have no internet service, though I can make and receive phone calls. Sometimes, these services report the same when I'm at home, on my Wi-Fi network, even though my laptop can access the Web via the same router.

    I have an LG G4 with Marshmallow, and access AT&T via Consumer Cellular, but I also had this problem with my prior phone, a BLU running Lollipop. So I wonder if my problem is an incorrect setting somewhere.
     

    Advertisement

  2. Parayilhussain

    Parayilhussain Android Enthusiast
    Rank:
    None
    Points:
    148
    Posts:
    394
    Joined:
    Oct 26, 2015

    Oct 26, 2015
    394
    106
    148
    Male
    Business
    Cochin
    Go to settings> power manager> disable power saving mode.
    Go to settings> data usage> carrier name>scroll down to google map.
    Scroll down to " "restrict app background data" . and
    Disable the switch( unchecked in the box)
     
  3. Ivan Berger

    Ivan Berger Member
    Thread Starter
    Rank:
     #567
    Points:
    26
    Posts:
    49
    Joined:
    Oct 21, 2015

    Oct 21, 2015
    49
    2
    26
    Male
    Where are these settings on Marshmallow?
     
  4. Parayilhussain

    Parayilhussain Android Enthusiast
    Rank:
    None
    Points:
    148
    Posts:
    394
    Joined:
    Oct 26, 2015

    Oct 26, 2015
    394
    106
    148
    Male
    Business
    Cochin
  5. eshieldsvx4

    eshieldsvx4 Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    99
    Joined:
    Feb 16, 2014

    Feb 16, 2014
    99
    41
    53
    Male
    If you're running mainstream Android (non skinned) the quick tile is the same.

    If you haven't already, go to Settings > About device and tap build number seven times. Then go to Performance and select the Balanced or Efficient power setting. Marshmallow has five settings while LP has 3.
     
  6. Ivan Berger

    Ivan Berger Member
    Thread Starter
    Rank:
     #567
    Points:
    26
    Posts:
    49
    Joined:
    Oct 21, 2015

    Oct 21, 2015
    49
    2
    26
    Male
    My problems on the road have disappeared--Consumer cellular support told me how to change APN settings.

    Most of my apps now get online via Wi-Fi when I'm home, but I keep getting messages that "[router #] has no internet connection," or something like that. Just a nuisance, as long as the apps work.

    What submenu is "Performance" under?
     
    eshieldsvx4 likes this.
  7. eshieldsvx4

    eshieldsvx4 Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    99
    Joined:
    Feb 16, 2014

    Feb 16, 2014
    99
    41
    53
    Male
    It's a Dev option. You need to tap build number seven times under Settings > About phone.

    Exercise caution. But once you do, you'll find your device's sweet spot. I've had my m8 for several years now and it usually takes me seven months after a ROM update to find one.
     
  8. Ivan Berger

    Ivan Berger Member
    Thread Starter
    Rank:
     #567
    Points:
    26
    Posts:
    49
    Joined:
    Oct 21, 2015

    Oct 21, 2015
    49
    2
    26
    Male
    Turns out, the problem was in my APN<?> settings, diagnosed by Consumer Cellular, who walked me through it.
     

Share This Page

Loading...