1. Are you ready for the Galaxy S20? Here is everything we know so far!

No OS, Broken Buttons and I'm stuck with "No Command"

Discussion in 'Android Devices' started by YellowYoshi, May 31, 2020.

  1. YellowYoshi

    YellowYoshi Lurker
    Thread Starter

    Hello, I'm YellowYoshi and I have a BIG Problem (I think)..
    I would appreciate it if someone could help me as soon as possible!!!

    I wanted to Root my Xiaomi Mi A1 and followed the steps of Method 1 in this guide: https://www.xiaomigeek.com/root-xiaomi-mi-a1.html

    Right at part 1 from the first method I ran into a Problem, it says: "2) Now, Turn off your device & Boot your device into fastboot mode. Press Power on button with Volume down button to boot into fastboot mode."

    So that didn't work in the first place because my buttons are kind of broken, my volume up/+ key didn´t work at all and when I wanted to start my phone I had to press both the volume down/- and the Power button at the same time in order to start my phone normally. If I only pressed the Power button it got stuck at the "No Command" Screen...

    I followed this: (https://www.xiaomigeek.com/boot-fastboot-mode-xiaomi.html) tutorial to get my phone into fastboot mode using the ADB Command method.

    First Problem solved, the second one came right away:

    I got stuck in part 2 of the first method, the 7th point says: Select “Swipe to allow modification“. From the menu select “Install“. Choose “twrp-installer-tissot.zip” & “Magisk-v14.0.zip” file & Install this files.

    There I encountered myself with the second problem: My phone didn't mount the /data directory, so I couldn´t access the twrp-installer zip file to flash twrp onto my phone. I searched online and found this:

    Second problem solved, i was able to access my internal storage but, the zip file got deleted because of the wipe i did from the tutorial. There i did not think properly...
    I mounted the twrp.img file with the power shell on my computer and because of the wipe i couldn´t flash the twrp zip file onto my phone, I followed the steps in the video and also wiped the system (together with Dalvik/ART Cache, Data, Cache) off my phone, then i wanted to reboot my phone to copy the twrp zip file back to my phone and restart fastboot mode on my phone with the Power Shell. My phone didn't start up normally because of the broken button problem and showed "No Command", when i pressed the Volume Down/- and Power buttons it seemed to start normally but got stuck in a continuous Bootloop, It's then I realized that I couldn't access anything because I deleted the OS...
    I searched online in order to find a tutorial on how to get the phone with Power Shell while in that "No Command" screen to get into fastboot so i could flash the twrp zip file directly onto my phone with the ADB Commands. I didn´t find anything...

    So, here is where I am and what I have:
    1. Unlocked Bootloader
    2. Broken Buttons (means I can't access the stock recovery or bootloader)
    3. My phone hangs in a continuous loop between the "No Command" Screen and the attempt to restart.
    4. My Computer doesn´t recognize my phone in this state so i can´t use Power Shell in order to force restart into recovery or fastboot.

    Can I (or someone else) fix my phone or do I have to consider buying a new one (which I can't afford anytime soon)?

    I would be really thankful if someone could give me a solution!
    Greetings and thanks to anyone who has taken the time and read this far!

    1. Download the Forums for Android™ app!


  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    do you have a sd card? why not just remove it, plug it into your pc and copy twrp onto the card?
    MrJavi likes this.
  3. YellowYoshi

    YellowYoshi Lurker
    Thread Starter

    Maybe I didn´t quite get what you meant... If so I apologize for that, but:

    Yes, I do have an SD Card in the phone and I also have the twrp-instalation ZIP on the card.
    The problem is:
    1. I can't access the phone with the computer to flash it from there because my laptop doesn't recognize the phone
    2. I can't start the phone because there is no OS on the phone
    3. I can't access recovery or bootloader because of the broken buttons...
    What can I do?

  4. mikedt

    mikedt 你好

    From what you described, it sounds like you got a paperweight I think. And really only thing you can do now is buy a new phone, that's it.
    ocnbrze likes this.
  5. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    oops i missed the point of your laptop not seeing your phone.

    sorry but no pc=no deal.....not much you can do at this point.

    just get a cheap burner phone until you can afford a new phone.
  6. YellowYoshi

    YellowYoshi Lurker
    Thread Starter

    Ok then, it's actually what I expected it to be in the end.o_O

    Thanks for the reply's!
    ocnbrze likes this.

Xiaomi Mi A1 Forum

The Xiaomi Mi A1 release date was September 2017. Features and Specs include a 5.5" inch screen, 12MP camera, 4GB RAM, Snapdragon 625 processor, and 3080mAh battery.

September 2017
Release Date

Share This Page