Root No OS


Well i decided to try and follow some tutorials to take my phone back to stock and don't know what i have done but i have managed to delete my OS and now the phone will not boot..
I can get into bootloader but my pc dose not recognise the phone either but when i plug the cable in bootloader changes to FASTBOOT USB...
Can anyone help me please


Android Expert
Ok, re: your other thread the OTA fails because you haven't returned to stock - this means stock recovery, locked boot loader and stock ROM.

With where you are at now, a few questions:

What guides were you following (links would be good)?

Do you know how you managed to wipe the OS? Was it from TWRP and did you only wipe system (the OS)?

Did you take a full nandroid backup using TWRP custom recovery? If yes, did you save otbto internal memory or external SD card? Can you boot in to TWRP? (use vol up/down in hboot to highlight recovery and power button to select). If TWRP loads and you select Restore are there any backups listed? If so you can restore one to at least get a working phone again.

If not, do you have adb/fastboot tools on your PC? If not there is a mini-sdk download on this site (sorry forget where now but a search should help), plus instructions to install. From PC with phone in fastboot does fastboot recognise the phone? In command prompt (assuming a Win PC) type:

fastboot devices

And check you get your phone's serial number returned.

If you do can you type:

fastboot getvar all

And post the results, but scrub out your IMEI and serial number first.

With a working boot loader and fastboot this is fixable, even if we have to load TWRP and download the correct backup files if you don't have one.


Android Expert
Ok, the phone output is useful, a few questions first.
Just to confirm you are in similar situation and have accidentally wiped the OS?
Do you have a TWRP backup you could just restore?

Or are you trying to get back to stock, and is your bootloader Unlocked?


@saltire Yes sir i think ive wiped the OS. It auto updated then i did not check the battery lvl. while updating it turned off then it started in boot loop. then i thought that i had already bricked so ive tried installing roms. then ive manage to atleast fix the boot via ViperOne.


And also i have no backup cause i factory reset wipe everything system Etc. sorry for my ignorance. When i had finished the ViperOne i noticed there was no network/Wifi/Bluetooth.:( Now all i want is to restore my phone atleast stock for as long i can use it. BootLoader Unlocked. Thank you very much sir. :D


  • 20160411_222347.jpg
    254 KB · Views: 88
  • 20160411_222355.jpg
    297.7 KB · Views: 99
  • 20160411_222421.jpg
    317.3 KB · Views: 113
  • 20160411_222505.jpg
    295 KB · Views: 120


Android Expert
Network/Wifi/Bluetooth not working are probably all due to a mis-match between the firmware version currently on the phone, and the ViperOne ROM software base - running newer software with older firmware tends to break stuff, Wifi being most common. Unfortunately it also looks like with the version of TWRP you have - probably - it's the version that removes the firmware version info so the version-main entry in your text output is blank, and line on the bootloader screen for OS is also probably blank as well.

Will have a look for a stock TWRP backup for your CID number and get back to you.

Edit : can you remember what the version of Android you had was eg Kit Kat (4.4.x) or Lollipop (5.x.x)? Don't worry if you can't, it would help pin down whcih stock backup to try.


@saltire To be Honest sir i really didnt realize what to do when i thought my phone was bricked i tried everything. Sorry. Also i cannot Remember the last version i had. Thank you for helping sir. really really thank you. Yes ill just w8 for your instructions.:)

Edit: Anything sir as long as i can fully use my m8 phone. texting/surfing/call etc. love this Phone. Thank you again sir.
Last edited:


Android Expert
No problem, and you don't need to call me sir either ok.

Just having a look at those screenshots, and the thing that concerns me the most is the IMEI showing up as unknown. This might mean we need to run a full RUU to rectify this, but I haven't found one that matches your current radio version - and without S-OFF you won't be able to revert to older firmware. So try the following first.

Ok, here's the steps you need to take to get back to stock working phone.

Reboot phone to bootloader and plug in to PC (so you see FASTBOOT USB on bootloader screen). Open a command prompt window in the adb/fastboot folder on your PC - if in Explorer hold shift + right click, and pick "Open command window here" from context menu.

Then type:

fastboot devices (to check fastboot connects to phone ok, it should also return the phone serial number - write this down carefully as we will need it later)

Next steps to get you up and running:

1) On PC download the TWRP backup files you need from here:

scroll down to CID HTC__044 section and pick the download link for 4.19.707.4 - I think this is the one that matches your current radio version but I would also download the 4.19.707.2 as well just in case.

Plus the stock recovery, which is handy to have if you want to fully return to stock, from here:

in the section headed scroll down and again pick the 4.19.707.4 and the 4.19.707.2 download as well just in case you need the older version.

2) Next, do you have a micro sd card in the phone? So you can copy the TWRP backup files you downloaded to the micro sd card and access them in TWRP. The main point to note is that you need to place the extracted files from the zip or rar file in a folder, on micro sd card, with the following name:

TWRP\BACKUPS\<your phone serial number>\<backup folder name>

The phone's serial number is what you noted down - the <your phone serial number> folder you create needs to match this exactly.

For <backup folder name> give it a name you'll recognise eg Stock_Backup - this can be can be whatever you like, I tend to avoid using spaces just in case.

The key point is to make sure you have placed the extracted backup files in the above folder, so once we get the later version of TWRP flashed (see below), it will pick up the files for the restore. When you extract the zip/.rar file I suspect you'll find a folder extracted with a name that ends in "... release-keys" it is the files in this folder that you need. You can just use this folder if you like, but as this will appear in TWRP as the backup name I think something called "Stock_Backup" is easier to recognise and deal with.

If you do this before the next steps, it'll save a bit of time.

If you don't have a micro sd card reader to hand you can try to copy the backup files across using ADB - see 4a) below.

3) Then download the latest version of TWRP recovery from here, and save to folder on PC where you have the fastboot.exe:

I'd go for the version but latest should be fine if you want to try it. Check the md5sum for your downloaded file matches - the md5sum link is at the top of the website download page, and the mini sdk zip file includes a md5sum checker in it if you haven't got one.

If md5 checks out, reboot phone to bootloader and plug in to PC (so you see FASTBOOT USB on bootloader screen). Open a command prompt window in the adb/fastboot folder on your PC - if in Explorer hold shift + right click, and pick "Open command window here" from context menu.

Then type:

fastboot devices (to check fastboot connects to phone ok, it should return the phone serial number)

If it does, then type:

fastboot flash recovery twrp- (assuming you downloaded this version of TWRP)

4) Then we need to check you can get in to TWRP ok, on phone bootloader screen use vol down to highlight HBOOT from the menu and press power button to select. Wait until HBOOT finishes check (some green text appearing on screen), then select RECOVERY from menu using vol down and pressing power to select.

4a) If you don't have a micro sd card reader to hand you can try to copy the backup files across with the sd card in the phone and after launching TWRP, using ADB commands Hadron set out in his post here : Commands to Copy Backup Files via ADB

This should load TWRP. Then you want to do the restore of the backup you downloaded, so select Restore to get into the restore screen. Now you need to point TWRP to your external SD card, look for the line of text in restore screen that will say something like Internal Storage, press on it and then select External SD Card (or might be Micro sd card, can't recall off the top of my head) - it should be obvious which to select. You should then see the backup listed.

Press on backup name, you should then see a screen with various partitions to restore selected (ticked), there should at least be Boot, System and Data. Then at the bottom swipe the slider left to right to start the restore.

At this point, once restore has completed successfully, I would reboot phone and check it boots ok and complete initial set-up before moving on to the stock recovery step. If it boots ok, you might have to reboot back in to TWRP and do a data only wipe if there are any artifacts hanging around from the backup you have just restored. Let me know if that's the case.

The following is Optional if you don't want to keep TWRP, and get back to stock - I wouldn't until we're sure phone is working ok

5) On PC, copy the stock recovery image you downloaded to your fastboot folder, reboot phone to bootloader and plug in to PC (so you see FASTBOOT USB on bootloader screen). Open a command prompt window in the adb/fastboot folder on your PC - if in Explorer hold shift + right click, and pick "Open command window here" from context menu.

Then type:

fastboot devices (again just to check fastboot connects to phone ok, it should return phone serial number)

If it does, then type:

fastboot flash recovery recovery_4.18.720.10.img (I haven't downloaded this so the "recovery_4.18.720.10.img" filename might be different, just type this with the correct filename if it is)

This should be you back to 100% stock rom/kernel and recovery i.e. unrooted.

Optional if you want to go fully back to stock

6) Then if you want to, the last part is just a case of relocking the bootloader and the phone should be set for OTA updates. At this stage until we are sure everything is ok I wouldn't recommend doing this, in case we need to get TWRP back on. Command for this from PC is:

fastboot oem lock

Let us know how you get on.


Finished downloading the files. uhm there one thing i dont understand:thinking: Do i have to create TWRP/BACKUP/*******/***** folder on my sd card? on my old TWRP its folder is on Internal Storage. sorry for the dumb question just wanna do your instructions solid. Thanks


Finished following your procedure @saltire . :D No Problem installing 4.19.707.4 Zip & Recovery. But it still has no IMEI :( Im going crazy. What step shall we do next? in not loosing this phone. huhuhuhuhuhu..:(


Android Expert
That's what I was afraid of. Having the phone auto turn off due to low battery when running the OTA update is never good, and best case scenario has left you with some firmware components updated but some that are not. Worse case scenario is failure part way through the install of one of the firmware images which probably means it's now corrupted. The fact that the IMEI is now showing as unknown is related to the radio img, however you are not s-off so we need to find a signed RUU. The problem is I can't find a signed RUU that now matches the radio version you got from the getvar all command, the only RUU I could find is here:

You can try and run it, before you do you need to get stock recovery on and relock bootloader. It might work but I don't think it will. If it doesn't I think your best shot is to get in touch with HTC and if the phone is still in warranty see what they say if you tell them the OTA process failed.


Android Expert
Just meant you will need to do steps 5) and 6) in post #9 - if you are s-on to run the RUU (if you are going to try it) the phone needs to be fully stock and bootloader will need to be locked.


Ah ok. Thanks again sir. will try to look for its firmware updates if im right? What do i need for its exact firmware?

Edit: Is there any chance that i can still have s-off even on the status of my Phone.. Thanks
Last edited:


Android Expert
Firmware is included in RUUs and incremental OTA packages, and is the only option if your phone is s-on plus they need to be signed (unmodified) and match the phone CID and modelid numbers (and be later than current firmware).

If you are s-off then the above don't apply and you can for example use unsigned flashable zips to update or indeed downgrade firmware.

Good question, probably not. Sunshine (the s-off tool) typically needs a stock working phone, I have no idea how it would react with no IMEI and needs a data/wifi connection to take payment ($25 if it is successful).

Sorry I can't be of more help :(