1. Are you ready for the Galaxy S20? Here is everything we know so far!

No ROM! Splash screen problem & RUU.exe/ ROM.zip- ERROR 140/Main Version Older

Discussion in 'Android Devices' started by Gerry, Feb 20, 2014.

  1. Gerry

    Gerry Newbie
    Thread Starter

    Hello. I read multiple threads/ sites over the past week on both "Error 140" & "Main version is older", & can not find an answer.
    Started Rooting- A silly mistake & no back-up made- System Format! Now- NO ROM! On normal boot, I get Splash screen- white screen/ green HTC logo
    I posted to another forum several days ago but as yet have not received any replies.
    Can anyone solve this??

    STATS:
    Wildfire S A510E
    ***RELOCKED***
    Marvel PVT SHIP S-ON RL
    MICROP-0451
    Radio 7.57.39.10M

    Android: 2.3.5
    ROM: 2.13.401.2
    Software: 2.26.401.3
    Kernal: 2.6.35.10
    HBoot: 1.09.0099
    HTC Sense Version: 2.1
    Carrier: Unlocked
    ClockworkMod v5.0.2.8. installed

    fastboot getvar all (with serial/ imei #s edited):
    (bootloader) version: 0.5
    (bootloader) version-bootloader: 1.09.0099
    (bootloader) version-baseband: 7.57.39.10M
    (bootloader) version-cpld: None
    (bootloader) version-microp: 0451
    (bootloader) version-main: 19.26.401.3
    (bootloader) serialno: ############
    (bootloader) imei: ###############
    (bootloader) product: marvel
    (bootloader) platform: HBOOT-7227
    (bootloader) modelid: PG7610000
    (bootloader) cidnum: HTC__001
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 4073mV
    (bootloader) partition-layout: HTC
    (bootloader) security: on
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    (bootloader) commitno-bootloader: 510e562c
    (bootloader) hbootpreupdate: 12
    (bootloader) gencheckpt: 0
    all: Done!
    finished. total time: 0.016s
    .
    I can still boot in HBOOT, RE & RE-UN lock BootLoader. One attempt at flashing a fix caused CWM to be wiped but I could re-install.
    The problem I'm having is I can not get an RUU/ ROM.zip flash to complete.
    I get "ERROR 140: Please find the correct RUU to use" (from RUU.exe flash) & "Main version is older!" from ROM.zip flash

    I can not find a 100% match for an RUU. The ROM is 2.13.401.2, the Software is 2.26.401.3

    1) As software is 2.26.401.3 I tried: RUU_Marvel_S_HTC_Europe_2.26.401.3_Radio_47.23e.35 .3038H_7.57.39.10M_release_261695_signed.exe.
    0% ROM match but 100% match of software id & 100% radio match
    With this:
    1) Tried to flash exe direct. Got the: "ERROR [140]: BOOTLOADER VERSION ERROR" message.
    2) Retried to flash RUU after ripping recovery.img from ROM.zip & placed in folder with the adb files. Got: Same result.
    3) I tried microSD card flash with ROM.zip, (BL UNlocked) taken from RUU_Marvel_S_2.26........route. Got "Error: Main Version is older!"

    2) I also tried to flash PG76IMG_Marvel_HTC_Europe_2.13.401.2_Radio_47.23a. 35.3035H_7.53.39.03M_release_225747_signed.zip from shipped-roms
    [100% ROM match & 0% radio] via SD card.
    Got it wrong!! At least all it did was wipe CWM & did not full-brick! So now my Recovery was back to default: Android system recovery <3e> but I could un-unlock/ re-lock BL & put CWM back, no probs.

    3) I've tried to flash (Bootloader RELOCKED, CWM installed) via:
    RUU_Marvel_S_HTC_Europe_2.13.401.3_Radio_47.23c.35 .3037_7.54.39.28M_release_236989_signed.exe
    99.9% ROM match- (I recorded mine in written notes as 401.2); BUT 0% radio match- I have 7.57.39.10.
    It looked as though it would work, BUT, I got:
    HTC Android ROM Update Utility 1.0.3.2011
    ERROR [140]: BOOTLOADER VERSION ERROR
    The ROM Update Utility cannot update your Android phone.
    Please get the correct ROM Update Utility and try again
    Ripped the ROM.zip from %temp% folder, put on SD (BL UNlocked) & tried flash. This gave me the "Installation aborted (bad)"
    Was going to try extracting .imgs- Recovery, System & Boot from ROM.zip, place in sdk folder and rerun RUU but noticed the hboot.nbo was 1.08.0000 NOT 1.09.0099!
    PROPERLY STUMPT!!

    Q; (1) RUU.exe/ ROM.zips: which & version to use??
    Q: (2) Do I need to downgrade/ rip something? If so what & how?

    Surely, this IS self-fixable? (Got some quotes for professional repair but am NOT ready to give-in yet!!) What else can I try?

    Thanks.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Gerry

    Gerry Newbie
    Thread Starter

    I was looking for an exact RUU.exe for my ROM: 2.13.401.2 NOT .3 as offered by shipped-roms & others. After trawling Google I found this: tsar3000.com/Joomla. Clicked downloads tab along the top, chose HTC & scanned down the list. I picked #42 (HTC WildeFire S A510E / A510c / MetroPCS - Marvel / C Stock Roms) HTC WildeFire S A510E / A510c / MetroPCS - Marvel / C Stock Roms. Looking down it I found RUU_Marvel_S_HTC_Europe_2.13.401.2_Radio_47.23a.35.3035H_7.53.39.03M: an EXACT RUU.exe match for my ROM. took me to a file share website: fileom.com. Created account, & after verifying by clicking link & email, downloaded RUU. Then: 1) RELOCKED BootLoader- cmd prompt & typed: fastboot oem lock The tried a straight RUU.exe flash. This returned the ERROR 140: BOOTLOADER VERSION ERROR etc. 2) ***WITH combined ACKNOWLEDGEMENT TO members CafeKampuchia & senthamil on [Guide] Re-flash stock ROM (RUU) after bricking a rooted device*** ["THANKS" hit for both!] Started RUU; went NO FURTHER. Clicked START on PC. Searched for %temp% folder. Found the two created when RUU is run. To do this- call up the temp folder. Kill the RUU. Restart the RUU. Keep doing this and you begin to notice 2 folders will appear when RUU is started & disappear when RUU is stopped.Checked both to find a .zip called "ROM.zip". Took it to a new folder so it did not interfere with anything. Unzipped it. Copied 3 of the revealed files to the \Android folder (my folder containing my ROOTing files- adb/ BootLoader unlock file from HTC/ etc.) The 3 are recovery.img, boot.img & system.img Then: RE-UnLocked BootLoader- opened cmd prompt & typed cd \Android; as my HTCdev Unlock file was still in \Android Then typed fastboot flash unlocktoken Unlock_code.bin. Agreed the pop-up on the handset. It booted itself to the Splash screen. I disconnected USB & pulled/ replaced battery. Booted into HBOOT>Fastboot & connected USB I proceeded to flash the 3 .img files by typing in cmd prompt: fastboot flash recovery recovery.img fastboot flash boot boot.img fastboot flash system system.img Just for good measure I relocked the BootLoader, as I knew it would restart the phone in Normal boot without me having to interfear with the handset. I typed: fastboot oem lock in cmd prompt WHAT HAPPENED NEXT???? Phone reboots Black screen with double arrows in circle, stays for 30 secs, then... White htc screen as before EXCEPT THIS TIME I got "quietly brilliant" written underneath & do-di-do-do-do-do jingle. Phone paused on "quietly brilliant" screen for one-and-a-half minutes......then......the standard phone set-up screens & ON!!!!!!! YESSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Handset is working, has all the apps etc as before. The only change is the "about phone" section of settings. It is a bit more basic with the info it yeilds, as software is older than what I had. I suppose this will change as OTA updates come in. I can live with that for now!! PHONE IS RESTORED!!!!!!!!!!!!!!!!!!!!!
     
  3. Gerry

    Gerry Newbie
    Thread Starter

    Sorry about the above post. It did not hold any of the original layout. When I tried to edit it, it would not save the changes. Thanks
     

HTC Wildfire S Forum

The HTC Wildfire S release date was May 2011. Features and Specs include a 3.2" inch screen, 5MP camera, 512GB RAM, Snapdragon S1 processor, and 1230mAh battery.

May 2011
Release Date
0
Reviews
Loading...
Similar Threads - ROM Splash screen
  1. Yesi Trotamundos
    Replies:
    4
    Views:
    296
  2. Yesi Trotamundos
    Replies:
    5
    Views:
    320
  3. Yesi Trotamundos
    Replies:
    6
    Views:
    513
  4. kumaranil13k
    Replies:
    7
    Views:
    566
  5. kumaranil13k
    Replies:
    11
    Views:
    568
  6. 67defalt
    Replies:
    1
    Views:
    534
  7. RianRusdani
    Replies:
    3
    Views:
    513
  8. 14km
    Replies:
    2
    Views:
    383
  9. einekratzekatze
    Replies:
    12
    Views:
    697
  10. bcrichster
    Replies:
    3
    Views:
    2,260

Share This Page

Loading...