1. Check out our companion app, Forums for Android! Download from Google Play

Support No router(in office or home,all are b/g standard) is detected by my N1!!

Discussion in 'Android Devices' started by tinydroid, Jun 9, 2011.

  1. tinydroid

    tinydroid New Member
    Thread Starter

    May 30, 2011
    Hello there!
    I just recently purchased a second hand N1 and it seems to me that the previous owner was very fond of rooting.Anyways lets get to the point,when I turn on the wi-fi the wifi icon never appears on the top bar and the wifi flashes "scanning.." for a second and goes away. I thought that somehow the wifi chip got busted by the previous owner so to verify it I tried the Portable hotspot thing and almost every device capable of detecting wifi detects my droid as a hotspot so it seems that the wifi is there but something is amiss with the regular wifi as it doesn't my virtual adhoc router which is immediately detected by every device capable of wifi reception and yes my portable adhoc router isn't capable of anything better than b and g so there's no reason why N1 doesn't detect it. I decided to update to 2.2.1 so that all kind dubious works of previous owner would go away but the manual update also fails with an error of
    "assert failed: file_getprop("/system/build.prop", "ro...... Status(7)" and I noticed that the recovery thingy says "clockworkmoderecovery" which means that the device is definitely rooted and its bootloader is unlocked.

    Things to clarify:
    - yep the update(2.2.1 official) file is in the sd card and is correctly named as update.zip(common extension hide option to off so I see all the extensions)
    - My present phone info says
    Model Name : Nexus One
    Android Version: 2.2
    Baseband version:
    Kernel Version: android-build@apa26#1
    Build number: FRF50

    Here are the things I collected that might help:
    Clockworkmod Recovery v3.6.2.0

    So anykind of help as to how I can get rid of this irritating blind wifi or can update to fresh official form without any unlock or root( I don't need anykind of root or unlocked bootloader options!)

    I am a complete noob and most of the forum posts about this kind of issue have so many suggestions and the op never returned to confirm if those methods/suggestions worked or not so I am being cautious here as this N1 is my only cellphone to go on with for the next 1.5 years and no wifi means no internet access for me as our cellphone data plans are far too expensive..but the only one that I have used in my brother's iphone is a micro sim that would be too small for N1's sim slot.

    Thanks for your time and understanding,I appreciate your help.


  2. tinydroid

    tinydroid New Member
    Thread Starter

    May 30, 2011

    I just moved to everything stock
    everything stock,except that my bootloader is still unlocked.
    I even received my OTA today for 2.3.4 which installed fast and fine.
    My radio was updated to 5.0... with the update of stock 2.3.3(I moved directly from stock ere79 to GRI40!)
    I am still having problem with Wi-Fi,it still doesn't pick any router around my house or office but I can switch the portable hotspot and every device detects my droid and can connect and use the 3G over android Wi-Fi.
    I don't know why this is happening,everything seems fine but my Wi-Fi doesn't pick any router or access point,I tried adding manually but that only shows that the accesspoint is "Not within range". Is there anything I can do about it?
    P.S: No warranty and no customer care in our country.

    Okay I was a bit confused,now after trying some free wifi management apps I see that my nexus indeed picks all the access points and most are adhoc,later when trying to connect all the apps keep on trying but fails everytime but one app "WiFi Manager" says that "Android doesn't support Adhoc" so I think thats why my N1 didn't pick or see those access points by default and required third party apps to see them,but I still don't know and will try with a real router t'morrow from my office. I am also seeing that when I turn on Wifi there is no nice wifi icon poping up in the status bar but when I turn on bluetooth a nice bluetooth icon popsup in the status bar,so I am all worried,I need some assurance that this is normal and wifi icon only appear when its connected to a router.

    Thanks and sorry for my n00bish situation.

    Okay after trying to ignore the complaints that android doesn't like adhocs I give in,I think this is going to be the way it should be and I will wait for a future update when adhocs will be supported

Share This Page