1. Check out our companion app, Forums for Android! Download from Google Play

Support No signal after debranding X10

Discussion in 'Android Devices' started by crowman943, Jul 9, 2011.

  1. crowman943

    crowman943 New Member
    Thread Starter

    Jul 9, 2011
    After debranding my wifes Xperia X10 via davinci, I have no signal, and a red x over my signal bars. I tried runnong seus multiple times as well as PC companion, I even tried flashing the firmware again via davinci. I had no problems when debranding my Xperia X10. We are considering rebranding it and sending it back, but would much rather fix this one. Everything else on the phone appears to work, just no signal. Please help. Flashed with NAM1 generic firmaware for both phones.


  2. beau420

    beau420 Well-Known Member

    Nov 10, 2010
    Computer Guy
    Best way get phone working again, is to again use SEUS to reset the phone to factory default.

    Then use the x10 tool

    And reflash the phone with the generic with the appropriate, most recent version -
    Click Flash....point to folder with the unzipped file....then restart phone.

    As for the X....check for any mobile network.

    Open Settings->Wireless->Mobile->Network Operators and see what networks it does see.

    Second....don't use davinci.....use the x10 flash tool to root if you want.

    Once rooted, you can uninstall any apps that were branded on there.

Share This Page