1. Are you ready for the Galaxy S20? Here is everything we know so far!

No Spam Option on messages in some accounts

Discussion in 'Android Devices' started by droidagnostic, Jan 24, 2014.

  1. droidagnostic

    droidagnostic Newbie
    Thread Starter

    I have several different types of email accounts on my phone (exchange, gmail, Google Apps IMAP, POP) and on some of them the "Add to Spam" option is available when you bring up the menu while in the message.

    And on one account the option does not appear (a POP account from my home ISP Comcast).

    Naturally this is the account that gets the mail that I want to block.

    Anyone have any thoughts on why it is only this one account.


  2. lordmage

    lordmage Android Enthusiast

    pop is an older type of connection and it will forward everything from the server end to your phone. block has to be done at the server level ie within your comcast account settings. or you have to forward to a third party account that you can then filter and send to your phone.
    funkylogik likes this.
  3. droidagnostic

    droidagnostic Newbie
    Thread Starter

    Thanks lordmage, that info got me headed towards a solution.

    Switched that Comcast account to IMAP and now have spam filter.

    Comcast apparently has had this option for a while they they just don't make it well known you have to request it https://xcsignup.comcast.net/onboardingapps/imap

    Then set up the account on your phone again but choose manual settings to set up as IMAP.

    PS I just left it set up as a POP account on my outlook email clients
    funkylogik likes this.

Share This Page