Help No USB notification when plugged into computer


Android Enthusiast
Alright. I've done a little research and tried a few things so don't kill me if the answer was right under my nose. I've been looking to root my Fascinate (not new but looks great) but when plugging my phone into the PC using a micro USB cable I get no notification on the phone and no pop-up on the PC.

I've tried this with USB Debugging on and off. I've reseated my SD card. I don't have the stock cable that came with the phone but I've tried a cable that came with my wife's dumb (not smart) phone. It does charge when plugged into the PC or into the wall but apparently there is no data connection from what I can tell.

I guess what I'm asking is:

Is there another setting I'm not checking?
Is there a good chance that it's the cable? (I've got a couple new one's coming tomorrow)

Firmware version

Baseband version
S:i500.04 V.ED05

Kernel version

Build number


Android Enthusiast
Thread starter
Well, can anyone confirm whether or not z4root works for the Fascinate? I'm looking to root so I can get CM7. I'm not a fan of TW and I'm bearing with it as of right now. Thanks!