1. Are you ready for the Galaxy S20? Here is everything we know so far!

No WiFi when sleeping

Discussion in 'Android Devices' started by Colmss, May 26, 2013.

  1. Colmss

    Colmss Well-Known Member
    Thread Starter

    Hi,

    when my phone is in sleep mode it seems to me that WiFi is periodically turned off on my Nexus 4. I have experienced the same issue on my Galaxy Nexus. There is a thread in google's bug tracker.

    I just factory reseted my phone to study the issue some further:

    Sent WhatsApp message from different phone on 22:16.
    Sent email from my PC on 22:25.
    It took until 22:34 for the phone to ring. I pushed the wake button to see if it is the email or the WhatsApp message and as soon as the screen was illuminated I saw that it was the email I sent. One blink of an eye later the WhatsApp message was there.
    Regular text messages arrive instantly.

    It seems to me that I don't have this issue on mobile data.

    I can't believe why only so few people complain about this issue!? Could it be hardware related? I still have the possibility to return my phone but where is the sense in it if it is a software issue :-\

    Does anyone have a fix for this?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. John Bean

    John Bean Happy Wanderer

    Go into wifi settings and tap menu, select "Advanced".

    Is "Wi-fi optimization" checked? If so uncheck it and do your test again.

    I can think of several reasons, like perhaps a few minutes delay doesn't worry them or maybe they just configure their phone to match their preferences ;-)
     
  3. Colmss

    Colmss Well-Known Member
    Thread Starter

  4. John Bean

    John Bean Happy Wanderer

    I didn't say it wasn't a real effect, I simply suggested you try the setting I suggested (which works for me) before being over-critical of the device.

    As for "20 minutes or more" I'm not sure where that time comes from. I used to see delays of maybe 10 minutes - just like the 9 minutes you measured in your first post - and the thread you linked mentions "up to 15 minutes". I've never seen delays longer than that.

    The actual delay depends on both phone settings (that's why I suggested looking at them) and the router you use. You may see no difference at all with your particular router, or you may see a dramatic improvement as I did. It costs nothing to try.
     
  5. Colmss

    Colmss Well-Known Member
    Thread Starter

    Hey, sorry, I forgot to mention that my measurements already used an unchecked optimization option.

    But the 20 minutes came from 22:16-22:34 which was the delay for the WhatsApp message. Yeah, it's 18 minutes but I rounded ;)

    Is the option you mentioned the only one you know of with regard to this?
     
  6. John Bean

    John Bean Happy Wanderer

    I'm not aware of anything else apart from the workaround mentioned in the thread you linked. Needs root access to edit the config file though.

    Later: on re-reading your OP I see I picked up the wrong time (22:25) for receipt, which is why I thought it was 9 minutes rather than 18. My bad, although I have never had a delay anywhere near that length.

    As I was typing (on my PC) an automatic email reminder I had set in Calendar popped up in my Gmail notifier - absolutely simultaneously with the alert chime from my Nexus 4 sitting idle (screen off) on the table. My intention isn't to "rub it in" but illustrate that blame for delays lies in both the router and the Nexus 4, not just in one or the other, otherwise it would always work or always not work with the same settings and any router.

    It's annoying when these things don't work as smoothly as they should for all devices and users, but that's technology... :-(
     
  7. Colmss

    Colmss Well-Known Member
    Thread Starter

    :( I hope they'll fix it sometime soon... I found an App "WiFi Keep Alive" and just tried it twice with just ~3 minutes delay.
    It's just annoying that I miss WhatsApp chats just when I have the time to respond, i.e. when I am at home....
     
  8. DC1022

    DC1022 Well-Known Member

    Have you tried going into the advanced wifi settings and set keep wifi on during sleep to always
     
  9. Colmss

    Colmss Well-Known Member
    Thread Starter

    Yeah, I kept this setting on always.


    ... it seems like that even with the app the delay is kind of random.

    @John Bean:
    Which router do you have?
     
  10. John Bean

    John Bean Happy Wanderer

    I have a BT Homehub 2. It plays havoc with the "Wi-fi optimization" on my Nexus 7 (but not the Nexus 4) to the point I have to turn off wi-fi while sleeping to prevent it from killing the N7 battery.

    But on the Nexus 4 it behaves far better and with "Wi-fi optimization" turned off it performs well, with minimal (often zero) delay and excellent battery life.
     

Nexus 4 Forum

The Nexus 4 release date was November 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 2GB RAM, Snapdragon S4 Pro processor, and 2100mAh battery.

November 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...