1. Are you ready for the Galaxy S20? Here is everything we know so far!

non techy girl needs help :(

Discussion in 'Android Devices' started by mariag461, Oct 22, 2014.

  1. mariag461

    mariag461 Newbie
    Thread Starter

    My friend helped me root my phone and then Google play wouldn't work and long story short he rooted it and left me to my own devices and I have no idea what I'm doing! So I uprooted it and now samsung has a new update but every time it try to update and reboot twrp takes over and goes into a menu that I don't know how to use. Basicly I need help. I would like to uninstal twrp so I can get my new update. I know it has something to do with flashing a new recovery but I don't know how to do that :, ( if somebody could please please help me , mabe send me an email to my inbox and help me step by step on what to do I could totally use the help :( thank you do much in advance boys!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. dynomot

    dynomot Android Expert

    Hello and welcome :)

    Why you wanted to root is a bit of a moot point, but it is what I thought.

    Right, what exactly do you want to achieve? Do you still want your device rooted and want it to work properly or do you want it back to "stock" ie unrooted and as it was? The reason I ask is rooted phones with a custom recovery will not recieve any updates. You have to update manually. Decide exactly what you want and give us some information to go on. We need to know your exact model of Galaxy S4 you have. Go to settings>General > and then to about phone and tell us your model number and "Android version" you have.

    You've come to the right forum to help.

    One last thing don't post your email address on any website, unless your prepared for your inbox to fill with Spam, this is a public forum and can be read by anyone.
     
    Mikestony likes this.
  3. mariag461

    mariag461 Newbie
    Thread Starter

    Thank you for the quick response! I would like to have it re rooted and working properly and fully functional. When u say manual update does that mean that I just have to go into updates check it? If that's the case then yes. Rerooted and working properly.

    My phone is samsung galaxy s4 SGH 1337m
    Version 4.4.2
     
  4. dynomot

    dynomot Android Expert

    Hi sadly no, if you check for updates you'll get this message :

    [​IMG]

    and will not be able to. To install an update with a rooted phone and a custom recovery you need to flash it with a PC and PC software called Odin, we shall be using this to get you a fully working device that is "stock" ie looks the same as any other, to re root and if your going to use your root access you'll also need a custom recovery. All easily done.

    You have a Canadian Galaxy S4 running the latest firmware. OK, now to get the correct stock firmware for you and post a link for it I need the three lines of information you get from typing in *#1234# in your phone dialler. If, because your rooted, you get an app called "SuperUserSU" coming up on doing that, ignore it and tap the back button.

    Right my kids need picking up. I shall be back later, to help and check in this thread.
     
  5. mariag461

    mariag461 Newbie
    Thread Starter

    The info I got is

    Ap:1337mvlufne1
    Cp: 1337mvlufne1
    Csc: 1337moyafne2
     
  6. mariag461

    mariag461 Newbie
    Thread Starter

    I must add that if we need to use my pic that's messed up too. It crashed a few days ago windows Xps420 running on windows vista. Now when u turn it on it the black screen with the windows Microsoft Corp logo shows up and that's it. It just stays the same. :( not a great week for me
     
  7. dynomot

    dynomot Android Expert

    Ah, you need a PC, I'm afraid. I'll post what you need to do, the links to the things you need to download here in this thread, for tomorrow. When you get an hour or so with a PC I'm sure you'll be able to sort your S4. I'm usually around after 8pm (GMT) if not, someone should be able to help. Right, next post links and stuff.
     
  8. dynomot

    dynomot Android Expert

    First you'll need Kies, Samsungs software suite for PC, a dogs breakfast of a piece of software, but we need it for the drivers to connect your PC to your S4. Here is the link for it, download, install and run it. Then connect your S4 using the USB cable. Once Kies has successfully connected to your phone shut it down, disconnect the phone go to windows task manager and end any processes that mention Kies. As I say, we only need it for the drivers it is only on my PC just for that, god awful piece of software. Here's the link :

    Smart Phone - Phone & Tablet | Support | SAMSUNG Canada

    Once you have Kies installed on your PC you'll need your phones firmware. Here is a link. Unzip the .zip folder and place the .tar.md5 file on your PC desktop screen for now, we'll need it later.

    Model: SGH-I337M
    Model name: GALAXY S4
    Country: Canada (Bell Mobile) (Black Edition)
    Version: Android 4.4.2
    Changelist: N/A
    Build date: Thu, 01 Jan 1970 00:00:00 +0000
    Product Code: BMC
    PDA: I337MVLUFNE1
    CSC: I337MOYAFNE2
    MODEM: I337MVLUFNE1


    *WARNING! THE ABOVE FIRMWARE MAY NOT BE THE CORRECT ONE mariag461 PLEASE PM ME BEFORE DOWNLOADING*




    Now to re root you'll need Chain Fire's rooting file, which also comes as a .zip file which, handily, also contains Odin a PC application that flashes phones amongst other things. Download, unzip the file and stick the contents on your desktop. Here again is the download Link :

    CF-Root Download


    Now you have all you need. Any photos, music, videos etc on your phone you want back on later need to be copied to your PC, copy and paste from your phone using windows explorer and once your finished you can cut or copy and paste them back. When you've finished doing all this your phone will be rooted and be like out of the box "new", so once done you'll have to reset it all up again, unavoidable, sorry. At this point I must issue my "Weasel Words" of warning. What you are about to do can render your phone useless, what is know as "brick" it. It won't, if you follow everything to the letter, but can. Don't blame me if it does, or indeed Android Forums, you do everything at your own risk.

    1) Right make sure your phone is fully charged or has at least 80% battery left. If it runs out of power while your using Odin it will brick it.

    2) On your phone go to settings>general>about device and repeatedly tap on "build number" until "you are a developer" appears (it should tell you "no need" if your phones already rooted, if not, no matter.) tap the back key and a new option -"Developer options" has appeared. Tap this and make sure "USB debugging" is ticked, go back to a home screen and turn off the phone.

    Now, on the phone, holding the home button, volume down button then the power button all at the same time in that order go into "download mode" you will get a warning about installing custom firmware

    [​IMG]

    - ignore it and press volume up to continue. A large green Android will appear with the words "downloading do not unplug target !! " written underneath it. This is download mode. [​IMG]

    This also the point of no return. Long press the power button to reboot the phone as normal if you wish.

    3) On the PC desktop locate the Odin V3.07 .exe you put there earlier, right click it and run it as an administrator. It doesn't install anything on the PC it just opens for use. It will look something like this, take a good look:

    [​IMG]

    Make sure only "Auto Reboot" and "F.Reset Time" are the only check boxes ticked, and now connect your phone. It will look like this, the number after COM may well be different, this is quite normal.

    [​IMG]

    Now go to the PDA button and press it and locate the firmware file you downloaded (not the CF rooting file, that's for later) from your desktop, Odin will now look like this :[​IMG]

    as it checks the firmware file for errors, it will after about two to three minutes change and look like this (ignore the codes to the right of the PDA button on this screenshot they will be different for your firmware):

    [​IMG]

    4) Now press start and Odin will flash the firmware. DONOT unplug the phone while it is doing this, let the laptop battery die, touch the laptop etc. Once done Odin will say "PASS" in the top left corner and the phone will reboot. You now have an unrooted stock phone.

    To root is exactly the same procedure from 1) through to 4) only this time use the "CF .tar.md5" file from your desktop at stage 3) close ODIN on the PC and reopen as administrator again to clear it and reset it to start form 1) to root your phone.

    I hope I helped :)
     
    mariag461, Mikestony and johnny_w like this.
  9. mariag461

    mariag461 Newbie
    Thread Starter

    Thank you so much :) when I start this, I will msg u on here so u can kind "be" with me while I do it in case I run into trouble if that's OK with you :)
     
  10. dynomot

    dynomot Android Expert


    Yes, sure. :)
     
  11. johnny_w

    johnny_w Well-Known Member

    Damn Dynomot, you are a knight in shining armor. That's why I like this site. People willing to help!
     
    mariag461 likes this.
  12. ironass

    ironass Extreme Android User

    OK Dynomot... I give up!

    How did you know that mariag461 is on the Bell Mobile (Black Edition) firmware just from her post...

    and not on Rogers, SaskTel, Fido, Koodoo, Telus or Virgin, which all have the same AP, CP and CSC?

    Either it was a lucky guess or you have the Product code as well. ;)
     
    dynomot likes this.
  13. dynomot

    dynomot Android Expert

    Fair question ironass old bean; the answer is, I don't. I presumed based on her post. It was the first firmware that matched SamMobile came up with.

    I shall of course PM mariag461, amend my above post and give her a link to download her correct firmware if it is wrong.

    Your wise counsel (this sounds rather sarcastic, but I am sincere) is always appreciated. :)
     
  14. mariag461

    mariag461 Newbie
    Thread Starter

    were is the thank yu buttons around here that everyone speaks of?

    so i m trying to instal the kies. once connected my phone to kies it says my device is not compatible with kies and needs to upgrade to kies 3. so i did that and it wont open. keps saying theres a problm and has to close ... help :(
     
  15. dynomot

    dynomot Android Expert

    You know I really aught to ban myself looking at Android Forums when coming in at stupid O'clock from being called out for work. :) Let's get this S4 running Rooted Rodgers firmware for you :)


    Kies is regarded, and is, possibly the worse piece of phone related PC software ever. Close it completely as mentioned above and try Odin with your phone booted up as normal. If Odin responds with a blue box top left with the dialog 0:[COM 7] in it and <ID:0/007 >Added in the larger box bottom left (the number "7" at the end may well be different, that's fine) you can forget about Kies, entirely it had installed the drivers we need. If not then completely unistall it using Windows and install Kies 3 direct rather than trying to update Kies 2. I couldn't see a download link in the Samsung Canada site for Kies 3, so here is the link for it in the Samsung US site :

    Kies

    and try again to install it. Don't have your phone plugged into the PC at all until it has installed completely and don't have Odin running at all while Kies 3 is installing either. Once installed follow it's instructions to connect your phone and once connected completely and it recognises your phone, unplug the phone and shut it down entirely. Make sure you end any of it's processes in windows task manager Kies and Odin are known to conflict. Another tip connecting your phone is to use a main USB port on your PC and stick to the same one. Don't use a "USB hub" port to start and use the original Samsung USB cable.

    Right hopefully you got Kies 3 installed, or at least it's drivers and Odin is responding to a phone as it should. You need the correct firmware rather than the one I posted a link for earlier, here you go, Rodgers firmware :

    Firmwares | SamMobile

    I shall be around from 9 pm (GMT) if you want me to be around before trying.
     
    Thatdad_old likes this.
  16. mariag461

    mariag461 Newbie
    Thread Starter

    thanks for helping!! ok so i figured it out.. it gives me a messege saying something about the ddl missing, so i think that means i need to have my windows servic packs installedon my pc.. so my computer is in the process of doing that right now. should i wait until that is finished before proceeding?
     
  17. dynomot

    dynomot Android Expert

    Yep, even Kies needs certain things from Windows to work correctly. A ddl is some sort of "library" I think.
     
  18. jj14x

    jj14x Android Expert

    typo - I think. I suspect the message is about a missing dll (dynamic link library).
    Usually, the software being installed (Kies in this case) should have installed the missing DLL - I suspect the problem might be because of some corrupted upgrade. Worst case scenario, it may be worthwhile trying a clean install of the latest Kies (uninstall existing Kies, and reboot, and then install latest Kies)

    I haven't used Kies, but does it really take the crown of "worse piece of phone related PC software ever" from iTunes? I had to use iTunes once (albeit a couple of years ago) - brought my computer to its knees (and me to my knees hoping to be delivered from that evil POS)
     
    dynomot likes this.
  19. mariag461

    mariag461 Newbie
    Thread Starter

    omg! i finaly fixed it. keis 3 is working perfect. ill connect my phone now and get started.


    ** so i conected my phone to kies, it asks to update the firmware, then it says i need to updte the driver before i can update the firmware. do i ignore all of this and just proceed to shut the program down?
     
  20. dynomot

    dynomot Android Expert



    Yep let it do an update, it can't hurt.
     
    mariag461 likes this.
  21. mariag461

    mariag461 Newbie
    Thread Starter

    the file that i am downloading now for the firmware.. its a rwc.zip file.. thats right?
     
  22. dynomot

    dynomot Android Expert

    How's it going ? When Kies has finished doing it's update, shut it down entirely and close any of it's processes in Windows task manager. The firmware it is offering you is almost certainly the same, latest version, as my link to the Rogers firmware above, and personally I wouldn't trust kies to do anything except let us use it's drivers! I really hope you by now you have a fully working, rooted phone.
     
  23. mariag461

    mariag461 Newbie
    Thread Starter

    i went to the sammobile site and downloaded th firmware you linked me to. kies tried to download firmware but i declined it , but i did get the drivers. now i am waiting for this firmware from the sam site to finish downloading, it says.. 1 hour remaining lol i do have odin saved on desktop already. just waiting for this download to finish i guess
     
  24. dynomot

    dynomot Android Expert

    Yes, when it is finished downloading the .zip, unzip it using WinZip or equivalent , and it will contain a tar.md5 this is the file you need. :)
     
  25. dynomot

    dynomot Android Expert


    Yes it does take a while, being a premuim member there does speed it up, alot ! However me downloading it and sticking it my dropbox and posting a link would be just as slow for you !

    While your waiting read my post again and make sure you understand it. Get into flashing ROMS and modding and using Odin becomes second nature.
     

Samsung Galaxy S4 Forum

The Samsung Galaxy S4 release date was April 2013. Features and Specs include a 5.0" inch screen, 13MP camera, 2GB RAM, Exynos 5410 Octa processor, and 2600mAh battery.

April 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...