1. Are you ready for the Galaxy S20? Here is everything we know so far!

Noob needs help

Discussion in 'Android Help' started by Cavan5250, May 13, 2020.

  1. Cavan5250

    Cavan5250 Lurker
    Thread Starter

    How can I have play services running then have a game tell me 'it needs play services and that my device does not support it' device is a Kindle fire 5 gen os 5.3.6.4 I have play services installed Gmail work's fine
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    what game is it? Maybe try uninstalling the app and reinstalling it.
     
    MrJavi likes this.
  3. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    That's a pretty old Android version, so you're going to run into more and more apps that fail to run, either partially or completely.
    Just because one app works fine doesn't mean others will. :)

    My guess is that the game you're having trouble with recently had an update--and it was the last straw. Up until then, your system was up to its requirements, and now it's not.

    There are a few things you can try, but if my guess is correct they're not going to help. From System Settings, find Google Play Services and clear its cache. Reboot your device. Try playing your game. Any luck?
     
    MrJavi, Deleted User and ocnbrze like this.
  4. Cavan5250

    Cavan5250 Lurker
    Thread Starter

    I've already tried what I could find on Google including clearing the cache thought someone hear might be able to help

    Magnum3.0 modified
     
  5. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    is this happening only on this game? Or other games?

    By the way I alerted the mods to either merge or delete your other threads. Just easier to converse in one thread.
     
    Deleted User likes this.
  6. Cavan5250

    Cavan5250 Lurker
    Thread Starter

    One line to clarify
    Tell's me it needs play services and that my device does not support play services when play services is running
     
  7. Deleted User

    Deleted User Guest

    What game is it? Was it already on the device. The Google Play Store app page description for that game will list the current requirements. If you were to uninstall it, then try to download from the Play Store, it might then say your device is not suitable. This applies to general Android devices of an older generation and spec, I forget what limits a kindle has :oops:
     
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    It could be just like @MoodyBlues suggested in your other thread that the app in question might not work on your device, since it is the only one that's doing it. You may want to try and contact the developer and let them know your issue.
     
  9. Cavan5250

    Cavan5250 Lurker
    Thread Starter

    It says not support when play store is running and thank you to everyone who is trying to help me

    I don't know how I put out multiple threads my apologies for the confusion
     
Loading...

Share This Page

Loading...