1. Are you ready for the Galaxy S20? Here is everything we know so far!

Noob to Android Phones

Discussion in 'Android Devices' started by mikefarr, Sep 15, 2011.

  1. mikefarr

    mikefarr Member
    Thread Starter

    Im very new to the Android phones and am always looking to do more with what I have. I am a computer guy of many years but this is my first go with Androids.

    So its looking like Im gonna want to root my phone.
    Do a ROM upgrade.
    Then upgrade to GB.

    Im sure there are howtos on this but I am not finding them.

    I would like to do a backup so that I dont loose anything and could recover back to where I am at if needed.

    Any directions or recommendations for preferred software would be greatly appreciated.

    I do like the Infuse 4G but I believe it could do a lot more.

    Thanx...
     

    Advertisement

  2. mikefarr

    mikefarr Member
    Thread Starter

    I rooted my phone ok.

    I got Titanium and Rom Manager installed.

    Next thing is to update my ROM
     
  3. Ryanscool

    Ryanscool Android Enthusiast

    There are how-to's, but just head over to the XDA forums on this phone. There is a lot more over there for this phone. You do not have to do a ROM upgrade, if you want you can just skip to Gingerbread. I recommend Infused 2.1 on XDA, even though I have not tried the others. This is because it is the highest rating, and Gtg is just plain cool. Follow the instructions promptly, and you should be fine. Just letting you know though, Canadians do not seem to care much about the Infuse because of them making the 2.3 available on the Infuse, because it has problems. Gtg did a fine job on making it work though. Here it is: [ROM] Infused v2.1.0 - (08/27) - xda-developers
     
    mikefarr likes this.
  4. mikefarr

    mikefarr Member
    Thread Starter

    In the XDA instructions it says that I have to download a Kernel and install it first then do the ROM. What if I want to upgrade to Gingerbread?
     
  5. Ryanscool

    Ryanscool Android Enthusiast

    Go ahead and do the kernel, this needs to be done to install this updated rom. If it is not, then a brick will occur. The kernel is sort of like the software end of it actually running the rom, and controls the CPU speed. This is needed to convert to Gingerbread. Make sure you know your other terms, it may help in the future (I made that mistake). I can not stress this enough though, make sure you follow the directions totally. I forgot to add to also make a Nandroid backup, and learn how to unbrick if it is needed, which I have not had to do (woohoo). If you need any more help, go ahead and ask.
     
    mikefarr likes this.
  6. mikefarr

    mikefarr Member
    Thread Starter

    I have Titanium and did a full backup. Yea havent read too much about recovering froma brick or rolling back if there are any problems. That would be useful to know.

    I have been looking and found some stuff on doing a Nandroid Backup but nothing specific for the Infuse 4G. I have everything to start the process of the ROM upgrade but would like to have that extra comfort in being able to recover from a brick.
     
  7. Mohammad_Adib

    Mohammad_Adib Well-Known Member

    Dont worry about brick too much...just follow the instructions and ull be fine. Delete ur system/bin/recovery and the /sdcard/voodoo folder then load the special community kernel, and install the rom with rom manager. Done ;P
     
    mikefarr likes this.
  8. mikefarr

    mikefarr Member
    Thread Starter

    Will the Astro Explorer work to delete the recovery folder? Thats what I currently have.

    Just tried and it dont.
     
  9. mikefarr

    mikefarr Member
    Thread Starter

    Ok I am in the process of doing the ROM upgrade.

    I have the green screen that has been up for like 10 minutes now.

    It has a few lines on the screen starting with:

    - reboot system now
    -
    -
    -
    -
    -
    -
    - advanced
    - +++++Go Back+++++

    Should I be taking any action or just waiting?
     
  10. Mohammad_Adib

    Mohammad_Adib Well-Known Member

    root explorer is what i used.
    But astro shold work, just find out how to mount it as R/W
     
    mikefarr likes this.
  11. Mohammad_Adib

    Mohammad_Adib Well-Known Member

    LOL no just reboot system. you are sitting in BIOS...you're not really doing anything. relax. Now, list all the options you see! I need to know if you are in ClockWorkMod recovery or normal stock recovery. And if you are installing the ROM you should use red recovery...but for now just reboot system now and give me some more clues as to where you are at so i or others can guide you though installing the ROM correctly. Dont worry about bricking you are almost set. I just wrote a thread here: check to see if you missed any of the steps,
    http://androidforums.com/samsung-infuse-4g/415884-forget-ts-update-get-gingerbread-now.html
     
    mikefarr likes this.
  12. mikefarr

    mikefarr Member
    Thread Starter

    Actually I remember reading somewhere that in some instances it gets stuck.
    I just hit my back button and it continued to boot. Now to verify the update.

    My firmware ver is 2.2.1
    Baseband I997UCKE3
    Kernel 2.6.32.9
    Build FROYO.UCKE3

    Does that look all good for the latest Infused?

    If I have everything done the next thing would be to go to Gingerbread...

    Let me know if I need to check anything else or if Im ready for GB now...

    Thanx for all the help
     
  13. Mohammad_Adib

    Mohammad_Adib Well-Known Member

    So you have infused ROM eh? which version? like 1.5.3 or 1.6.0...etc...
    Sounds like you are talking about the AT&T update...i was talking about the infused ROM
    The AT&T update was just a minor update that had nothing special to bring...but if you are on a 2.2 Infused ROM and you are successfully stable and have clockworkmod recovery, then all you need to do is:

    1) If you have a /Voodoo folder on your internal SD card, delete it and reboot.
    2) Download this kernel: Multiupload.com - upload your files to multiple file hosting sites!
    5) Install SGS Kernel Flasher from the Market.
    6) Open SGS Kernel Flasher, select choose kernel, select the file you downloaded, and select flash kernel. Your phone will reboot and begin to enable Voodoo lagfix. Let it do that and boot all the way up. It will take a while (5-10 minutes) because it's converting all partitions to ext4.
    7) Install a file explorer like Root Explorer from the Market and use it to delete the file /system/bin/recovery. You will need to hit the "Mount R/W" button in Root Explorer before it will let you delete it. You MUST MUST MUST delete that file before continuing or else you will get boot loops!
    8) Now install ROM Manager from the Market and open it.
    9) Select "Flash ClockworkMod Recovery" and choose "Galaxy S i9000".
    10) Now go to "Download ROM", select (gtg465x), select the latest Infused V2 release, and hit the download button.
    11) At the "Installation Type" prompt, select full.
    12) Select the addons you wish to install and then wait for ROM Manager to download the ROM. There is a note at the bottom of this post about which addons are not compatible with each other.
    13) When you get to the "ROM Pre-Installation" prompt, you MUST check "Wipe Data and Cache" unless you're coming from Infused V2 BETA 1.
    14) Press OK. Your phone will reboot and automatically install the ROM. Just sit back and relax.

    From: [ROM] Infused v2.1.0 - (08/27) - xda-developers
    But if you are on stock ROM with no clockworkmod, just refer to my thread on going from stock to gingerbread
     
  14. mikefarr

    mikefarr Member
    Thread Starter

    I downloaded the Infuse 2.1 ROM and followed all the instructions.

    When it stopped at the Go Back and I hit the back it proceeded to boot the phone.

    I just want to verify that the update was successful.

    If I am on the Infuse 2.1 can I upgrade then to GB?
     
  15. Mohammad_Adib

    Mohammad_Adib Well-Known Member

    Well my friend, truth is you are not on infused 2.1, because if you were you would be running gingerbread at this moment! Also, pressing the back button is equivalent to selecting an option with the power button. You were in recovery and to navigate the menus there you have to use the volume for up-down or back and power btton to select.

    Tell me how you got into recovery the first place. And if you have followed all the steps and just need to install the ROM, save the ROM on your sd card, get into recovery again and hit "install zip from sd card" and then navigate to the zip file (ROM) and then just select yes...that should get you installed gingerbread. proceed with caution. im assuming you did all the steps correctly...if not you will brick trying to do this !

    But yea b4 any of that tell me these things:
    -how did u get into recovery? via rom manager?
    -what rom are you running now because you are not running infused 2.1 which if you were you would be running 2.3.3 but you're running 2.2. What i can tell by the settings you posted, is that you are on stock 2.2 ROM.
     
  16. mikefarr

    mikefarr Member
    Thread Starter

    Yea when I started the only thing I had done was to root the phone.

    I did the kernerl update and deleted the recovery folder.

    User Rom manager and followed the steps exactly.

    Downloaded the 180 meg file and went into preinstallation.

    The only other option I selected was the one that said to Wipe Data and Cache
    I turned away and it started up the ClockworkMod and it was a green text screen where the bottom line said +++++Go Back+++++ and thats when i hit the back button at the bottom of the screen.

    It then booted up ok but the update didnt take place as I gather.

    Your advice at this time?

    ***NOTE*** I just checked and the recovery folder is still missing from when I deleted it.
     
  17. Mohammad_Adib

    Mohammad_Adib Well-Known Member

    Good very very good. One last thing that stands between you and gb. go to ROM Manager and select reboot into recovery. Write ALL the options down and let me know. I NEED TO SEE and after that just select reboot system now again by pressing back or power btn. I need to see the list because i need to know what kind of recovery you are in. Dont worry you are this <> close to having gb. Make sure u back up all ur apps with titanium backup or somthin...after installing a ROM all apps and settings go bye bye.
     
  18. mikefarr

    mikefarr Member
    Thread Starter

    Yes I did a full backup with Titanium before starting this process.

    Ok at the very top of the screen it says...

    ClockworkMod Recovery v2.5.1.2

    - reboot system now (appears to be highlighted by looks)
    - apply sdcard:update.zip
    - wipe data/factory reset
    - wipe cache partition
    - install zip from sdcard
    - backup and restore
    - mounts and storage
    - advanced
    - +++++Go Back+++++
    -------------------------------------------------------------------

    Thats it except it says the ver of CWM at the bottom like the top
     
  19. Mohammad_Adib

    Mohammad_Adib Well-Known Member

    SWEET YOU GOT IT MAN!
    ok you are in clockworkmod. select install zip from sdcard
    navigate to where you put the 180mb ROM and select that...let me know how it goes. GOOD LUCK! last step. fingers-crossed
     
  20. mikefarr

    mikefarr Member
    Thread Starter

    What would the file name be?
     
  21. Mohammad_Adib

    Mohammad_Adib Well-Known Member

    file is here: /clockworkmod/downloads/www.prism.gatech.../~gtg465x/update-infused-v2.1...zip
    Navigate with the volume keys and power button through the folders. GOOD LUCK :D
     
  22. mikefarr

    mikefarr Member
    Thread Starter

    Ok everything said it went fine and I rebooted.

    I have been watching a pretty colored X rainbow form on my screen for about 10 minutes.

    Is it still updating? If so how long should it take?
     
  23. Mohammad_Adib

    Mohammad_Adib Well-Known Member


    Holy shh.... oh no.... well the first boot takes some people a looong time. Usually 10mins. But if it does not boot within 20mins then....well let me know what happened....btw the rainbow is the boot animation. By default its the nexus s boot anim. You can change it but as for now I'm hoping ur phone boots
     
  24. mikefarr

    mikefarr Member
    Thread Starter

    I pulled the battery after 25 min and it came back up to the rainbow X

    What should I do...

    ***Every couple of minutes the screen kinda freezes.
     
  25. Ryanscool

    Ryanscool Android Enthusiast

    Ok go into recovery by holding both volume buttons and power button until the samsung screen comes. It should go into recovery, then go to backup+restore then try restoring from a nandroid. If you do not have any, then do the ultimate unbrick then viola! After the restore if you did the ultimate unbrick, download titanium backup and restore from there.
     
Loading...

Share This Page

Loading...