1. Are you ready for the Galaxy S20? Here is everything we know so far!

Nook Color not connecting with my Wi-Fi

Discussion in 'Android Devices' started by meesh23, Dec 28, 2011.

  1. meesh23

    meesh23 Lurker
    Thread Starter

    So I know little to nothing about Wi-Fi and internet connection stuff, but what I can tell you is that I was able to connect my brand new Nook Color to my boyfriend's wifi but when I came home, it is unable to connect with my own wifi. I have a Mac and my wifi is "WPA personal". I know the password and I have entered it but my nook always shows it's 'disconnected.'

    I have even changed my wifi to have no security settings and my nook still won't connect to it. (Don't worry, I changed it back immediately.)

    But what's wrong and what can I do to fix it? I would really like to download some books for my road trip coming up and this is becoming aggravating!

    Thanks in advance!


    1. Download the Forums for Android™ app!


  2. colchiro

    colchiro Extreme Android User

    How old is your wireless router?

    You'll probably need the login/password to access it from a web browser.

    It's possible that you have access control (only certain devices can access it), which would require you to know or recognize it's mac address. (Look for wireless settings with "mac address" on it.)

    Another possibility is to change the encryption type (AES/TPK).
  3. MikeNJ

    MikeNJ Newbie

    I had two similar problems with my new NC.

    It wouldn't connect using stock 1.2.0 or 1.4.1 at my Fiancee's house - I had to change her router's wireless encryption to WPA2 AES.

    It wouldn't connect using CM7 7.1 at my house - I had to change my router's wireless encryption to WPA2 AES.

    Strangely, both our laptops worked interchangably at either house using WEP.
    Coincidentally, my Samsung Galaxy SII/Sprint Epic 4G Touch running 2.3.6 (stock) wouldn't connect at her house before the change, it just worked at mine.
    Nor would my Wii work wirelessly at her house before the change.

    So changing 2 encryption settings fixed three devices :)
  4. chocophile

    chocophile Member

    If you were using WEP, you might as well not bother with encryption at all. WEP is easily cracked. WPA is what you want anyway.
  5. sross512004

    sross512004 Newbie

    Ok, I've had this problem for many months, and could never find any way to connect. I even took my mook to B&N yesterday, where everything worked just fine. I even checked my router's MAC address settings and the router could see the nook just fine, the nook's MAC address was already listed, but still the nook would not even "see" the router when it scanned. Finally, after reading the above posts, I decided to take the security on my router down to WEP (temporarily) to see what that would do. Well, I couldn't connect to the internet with any of my devices following that move. So I pushed the red reset button on my router, which reset the security back to WPA/PSK. And what do you know, after months of no connection, my nookcolor has finally got online at my house. Hurray. Hopefully, people with this problem will see this post and be able to connect.
  6. sross512004

    sross512004 Newbie

    Oop, sorry. Didn't realize I'd already posted about this and don't know how to delete this 2nd post.

    I want to post this update. My Nookcolor has been setting, unused, for the last 6 months, because I broke down and bought a tablet that would connect to wifi. I recently took my Nookcolor into a B&N store. Of course, it connected there just fine so there was nothing they could do. I came home and started playing with trying to connect it again, still no luck. But then, in the course of human events, I messed around so much that I messed up my router. Well, to make a long story short, I had to do a hard reset on the router and what do you know? My Nookcolor connected to it instantly! And I haven't had any connection problems since.
  7. colchiro

    colchiro Extreme Android User

    The NC is an older device and not sure if it supports wireless "N".

    It's possible you changed a setting on it that broke support for older devices that only work with "B" and "G" protocols and the reset fixed it.
  8. Benito_EM

    Benito_EM Lurker

    When I check my router's settings online at Verizon it can't even detect the NC. When I temporarily switch to static IP it "connects" and shows a white wifi logo but there is no internet access. argh.


Share This Page