1. Download our Official Android App: Forums for Android!

Root Nook Simple Touch rooted, running Android

Discussion in 'Android Devices' started by nickdalzell, Jul 29, 2013.

  1. nickdalzell

    nickdalzell Android Expert
    Thread Starter
    Rank:
    None
    Points:
    243
    Posts:
    4,823
    Joined:
    Jun 17, 2011

    Jun 17, 2011
    4,823
    865
    243
    Owensboro, KY
    I've always loved the ideas behind e-ink. Sure, it is black and white, but it is super easy on the eyes, works well in sunlight, and being ultra-low power consumption, means weeks of battery life. For those who's daily tablet use consists of basic web browsing (like these forums), reading their email, and of course, books, the e-ink in the form of a tablet running Android sounds like it'd be an excellent idea. Unfortunately, all we have is e-readers who's functions are limited to their intended purpose, reading books only. Fortunately, with the Nook Simple Touch, the e-ink Android tablet can be a reality. I've already rooted mine, and installed ADW Launcher, side-loaded Dropbox and a file browser, and got online. Now my dream of an e-ink daily use device in my tablet arsenal is reality. Granted it's no Nexus, but for the aforementioned uses, which are 99% of my daily use, it is darned cool. Now, I haven't worked every bug out of the system yet and I'll list what works and what doesn't. In another thread, I said I am buying and rooting one of these and would post some pics.

    [​IMG]

    Behind the Nook interface, resides Android 2.1 Eclair. Archaic, sure but it does run most of the heavily used Android apps. So far, market isn't working and Play doesn't support Eclair, so it is side-loading from an SD card at this point. I cannot get 1Mobile Market to run on the thing yet either as an alternative, and Amazon App Store seems to crash after doing some weird e-ink flashing possibly due to a limitation of the display. However, Dropbox does work and I can use any saved apk files through it. I have most of my often-used apps on it. I also managed to get Gmail working too

    [​IMG]

    It is pretty limited but the idea of being off charge all week and how easy on the eyes e-ink is, well it impresses me. I can certainly see a big market of budget e-ink smartphones for folks who's use is mainly email, texting, playing music, and, of course, phone calls. Imagine the battery life then!

    EDIT: overcame the app market issue, installed Dolphin Browser (stock crashes) and now have access to AF :) seems rather responsive and stable once I ditched the stock web browser

    [​IMG]
     

    Advertisement

  2. Joelgp83

    Joelgp83 Android Enthusiast
    Rank:
     #179
    Points:
    68
    Posts:
    453
    Joined:
    Jul 30, 2012

    Jul 30, 2012
    453
    176
    68
    California
    Now you need to pull this off with those e-ink kindles. :D
     
  3. MoodyBlues

    MoodyBlues Compassion counts.
    VIP Member
    Rank:
     #28
    Points:
    713
    Posts:
    5,994
    Joined:
    Jan 27, 2011

    Jan 27, 2011
    5,994
    4,761
    713
    Formerly Linux sysadmin/programmer
    $HOME/LosAngeles
    Way to go, Nick! Thanks for sharing. :D
     
  4. nickdalzell

    nickdalzell Android Expert
    Thread Starter
    Rank:
    None
    Points:
    243
    Posts:
    4,823
    Joined:
    Jun 17, 2011

    Jun 17, 2011
    4,823
    865
    243
    Owensboro, KY

    The kind with free 3G? (Yeah, how do they do that?!) I wonder if they run Android behind the scenes like a Fire myself. I heard rumors they can be rooted but also read that they're 1/3 as usable afterwards as a Nook Simple Touch. And that is not saying much. Currently I got browsing and market working but there's some bugs left. I cannot reply or post to the forums yet because tapping text boxes in the site doesn't seem to register. There is also a scrolling bug that allows me to scroll down just fine, but it absolutely refuses to scroll back up. Don't worry, I got this far, I will get farther.

    A word of caution, while I can explain the rooting process to anyone interested, don't expect to play Angry Birds or Candy Crush or any games, don't expect music or video (no audio chip set exists and the e-ink screen isn't going to play well with games) so far touch input seems limited to the B&N limitations. Scrolling down is basically the same command as turning pages in a book. I am also not sure if it is resistive or capacitive. You cannot pinch to zoom in or out and multi-touch is a no-go. So far it is OK for web browsing, email, books and minimal forum browsing. Market doesn't have too many compatible apps. One would need apk files for older versions which support Android 2.1

    Currently working :

    1mobile market (play doesn't support the thing and gives a connection error right off when launched)
    Dolphin Browser (not sure if it's mini or full--Dropbox had it named "tunnybrowser”)
    Drop box (fully functional)
    ES File explorer (fully functional)
    Gmail (older version)
    ADW Launcher (seems fully functional)
    ClockworkMod Recovery (boots off SD card like a floppy disk)

    What does NOT work:

    Android Market/Google Play (Android version too old)
    Amazon App Store (crashes possibly due to a display issue. E-ink goes blinky and it silent crashes to desktop)
    Aldiko e-reader, Kindle app, Google Play Books (needs Froyo or above)
    Yahoo! Mail (not compatible with the newer version, gives parse error on sideload, the eclair way of saying it won't work)

    Stock Browser (either too old or just unstable. Crashes like Amazon App Store)
    YouTube (believe me, you don't want to go there!)
     
  5. divinebovine

    divinebovine Android Expert
    Rank:
    None
    Points:
    183
    Posts:
    991
    Joined:
    Aug 30, 2012

    Aug 30, 2012
    991
    273
    183
    I've been waiting to see this thread in
    Simple Touch - All Things Root - Android Forums

    Didn't expect to find it here! :)

    Which firmware version do you have and which root procedure/SD image did you use? I have 1.0.1 and used TouchNooter. I haven't had a chance to really dig in and put some time into perfecting/exploring it yet.
     
  6. MoodyBlues

    MoodyBlues Compassion counts.
    VIP Member
    Rank:
     #28
    Points:
    713
    Posts:
    5,994
    Joined:
    Jan 27, 2011

    Jan 27, 2011
    5,994
    4,761
    713
    Formerly Linux sysadmin/programmer
    $HOME/LosAngeles
    Moved to Simple Touch - All Things Root.
     
  7. nickdalzell

    nickdalzell Android Expert
    Thread Starter
    Rank:
    None
    Points:
    243
    Posts:
    4,823
    Joined:
    Jun 17, 2011

    Jun 17, 2011
    4,823
    865
    243
    Owensboro, KY
    Touchnooter did not work for me. it would stay forever at the 'wait for screen to flash black, remove sd card and reboot'

    thing is, it never flashed black. and then i was soft-bricked (boot loop) when i force-rebooted it. i ended up having to find a clockworkmod recovery *.img file and burning it to an SD Card via WinImager32, then downloading NSTFormatter.zip somewhere, inserting the card into my device and boot off of it like a Floppy Disk (yea, go ahead and laugh, i'm THAT old). then i was at clockworkmod, i installed that *.zip and it did a proper factory reset, updated firmware to 1.1.0, and rebooted. then was back to B&N default setup. i re-registered it, tried TouchNooter again hoping the newer firmware would work (originally was 1.0) and it got stuck again. then the boot loop. apparently i got one of the oddballs that does not support TouchNooter (i tried all of them).

    i am not sure which root tool i ended up using as i was frantically trying so many and eventually landed on one that did work, it installed through the same ClockworkMod recovery, and i was rooted but without market access, some important tools missing (namely, a file manager), and the stock Android 2.1 browser was extremely crash prone (crashed when loading google.com, refused to login anywhere, crashed loading any link, etc). i then discovered a wiki article somewhere that told me how to use the 'file:///' prefix in the stock browser to install or side-load APKs from the sd card manually (about the one time it didn't crash). then i side-loaded ES File explorer, dropbox, 1Mobile Market and then installed Dolphin.

    so far it will read and send Gmail messages (only through the older app, the pastel one doesn't support it which i'm not fond of anyway so i will stay with the older one) and will browse the web. it will login and browse AF, but won't post anything (the text box doesn't invoke the keyboard or cursor for some odd reason, but i can edit the subject and title!) this could just be a Dolphin glitch, it's a rather old version. it also throws a lot of security certificate errors as well. it goes to other sites fine, can search, displays rather well given the limits of the display, but it does have a bug with the screen refresh. sometimes i click a link and it loads, but never shows on the screen, just showing the previous screen (say i was at Google, and i clicked a search result, it shows it loading up top but it still has the display at Google instead of updating the screen with the new page) for that i have to work around by opening most new links in a new tab. it also refuses to scroll up, but will scroll down.

    the ROM i used that had the working root, did not include tools to reprogram the side buttons along the screen, but if it had, i may be able to use them to scroll up/down but until i find an APK for it somewhere, this bug is not a high priority. right now when i leave work i plan to remove any pre-installed stuff that either does not work or i won't use (an IM client, the default email.apk, and the unstable stock browser), reboot, back up the ROM in its current state, and see if another browser can post to this site.
     
  8. divinebovine

    divinebovine Android Expert
    Rank:
    None
    Points:
    183
    Posts:
    991
    Joined:
    Aug 30, 2012

    Aug 30, 2012
    991
    273
    183
    Do you have a link for the CWM recovery?

    Yeah, I understand the thing about getting frantic and frustrated and losing track of how you've done what you did. Sometimes I operate the same way.

    I started by doing complete backups of mine with approximately these instructions:
    How to Backup and Restore Nook Glow and Nook Simple Touch | The eBook Reader Blog
    also referencing the linked XDA-Developers threads and a little bit of applying my own knowledge, since I am working with a variety of hardware and software setups that aren't entirely congruent with what's described there.

    You'll want to try Opera Mobile (not Opera Mini). It is reported to work very well with the Nook Simple Touch, and on my Venture I've found it very functional for difficult web sites.
     
  9. nickdalzell

    nickdalzell Android Expert
    Thread Starter
    Rank:
    None
    Points:
    243
    Posts:
    4,823
    Joined:
    Jun 17, 2011

    Jun 17, 2011
    4,823
    865
    243
    Owensboro, KY
    Opera mobile won't install. It says "installing" then says "application not installed" indicating not compatible. However, UC Browser is fully functional and I'm typing this with my Simple Touch right now.
     
  10. OverByter

    OverByter Resident Slide Rule Guru
    Rank:
    None
    Points:
    213
    Posts:
    4,000
    Joined:
    Dec 12, 2010

    Dec 12, 2010
    4,000
    922
    213
    Male
    Disabled
    CT, USA
    I used NookManager to root, very painless also has a link to a gapps package. Like Nick said, it's a bit of trial and error to find app versions compatible with Eclair. Have TiBu up and running to freeze a lot of included system apps, like the dialer and camera, lol. :D
    http://forum.xda-developers.com/sho...nager - graphical rooter for 1.2.x and beyond
    OB
     
  11. divinebovine

    divinebovine Android Expert
    Rank:
    None
    Points:
    183
    Posts:
    991
    Joined:
    Aug 30, 2012

    Aug 30, 2012
    991
    273
    183
    I was wrong about opera mobile, now it is called opera classic. Using it on my nst to post this now.

    Don't forget that AF has their own app. however, I don't like it...it doesn't give me the nice list of subscribed threads and forums that usercp in a web browser gives me.
     
  12. nickdalzell

    nickdalzell Android Expert
    Thread Starter
    Rank:
    None
    Points:
    243
    Posts:
    4,823
    Joined:
    Jun 17, 2011

    Jun 17, 2011
    4,823
    865
    243
    Owensboro, KY
    AF has a limited app but the link goes straight to the Play Store/Android Market which doesn't work for me. I get instant connection error.
     
  13. divinebovine

    divinebovine Android Expert
    Rank:
    None
    Points:
    183
    Posts:
    991
    Joined:
    Aug 30, 2012

    Aug 30, 2012
    991
    273
    183
    OIC. It works for me and I could get you the APK if you want but I agree about "limited". Along those lines there's also forum apps like Tapatalk and Convo.

    I tried Opera Mini earlier and, contrary to reports about what works and doesn't work on the NST, I found that it works fine. Its interface isn't quite optimum for the NST though.

    Have you found your NST to be horribly slow? Mine is infuriatingly slow...it really makes me appreciate my Virgin Mobile Venture that I almost never stop insulting which is smooth and fast by comparison.
     
  14. OverByter

    OverByter Resident Slide Rule Guru
    Rank:
    None
    Points:
    213
    Posts:
    4,000
    Joined:
    Dec 12, 2010

    Dec 12, 2010
    4,000
    922
    213
    Male
    Disabled
    CT, USA
    It is only an 800 mhz single core, which compared to the 533 on the Kindle is pretty quick for an ebook. There's a kernel that's oc to 1100 on xda. Also the market works for me, you need to install the search app for that to work properly, link is in the Nook manager thread.
    OB
     
  15. divinebovine

    divinebovine Android Expert
    Rank:
    None
    Points:
    183
    Posts:
    991
    Joined:
    Aug 30, 2012

    Aug 30, 2012
    991
    273
    183
  16. nickdalzell

    nickdalzell Android Expert
    Thread Starter
    Rank:
    None
    Points:
    243
    Posts:
    4,823
    Joined:
    Jun 17, 2011

    Jun 17, 2011
    4,823
    865
    243
    Owensboro, KY
    My NST is actually quite responsive, and takes to rapid typing rather well. Since the e-ink redraws instead of showing actual transitions, I'd be hard pressed to notice lag. Apps themselves seem quite snappy to launch. My preferred browser is UC Browser, which is a darned good alternative to Google Chrome, as far as function goes (Chrome only supports 4.0 or higher)

    A week of my normal browsing and checking email, reading blogs (the latter category is an excellent use for the device) and the battery came down to 25%, even with leaving WiFi on. Impressive, to say the least. My Nexus 10 burned out in six hours, not even enough for one day unless I recharge it and wait. I'm quite disappointed in the 10's rather depressing battery life, since my iPad beats it despite being a generation behind.
     
    divinebovine likes this.
  17. syzmic

    syzmic Well-Known Member
    Rank:
    None
    Points:
    88
    Posts:
    108
    Joined:
    Jul 28, 2013

    Jul 28, 2013
    108
    272
    88
    Male
    What works seems to vary by user. For me, Opera Mini works great. I really like being able to zoom in or out. Most other browsers don't allow that. I have the Amazon app store working fine, and Yahoo mail functions also. This thing might be useful yet.
     

Share This Page

Loading...