1. Are you ready for the Galaxy S20? Here is everything we know so far!

NOOK WiFi concerns addressed!

Discussion in 'Android Devices' started by jayjay1122, Feb 22, 2011.

  1. jayjay1122

    jayjay1122 Android Expert
    Thread Starter

    ****To the other Guides and Mods: I am placing this in the main NOOK Forum for the moment. I plan to leave it here for a couple of days and then I will move it to the Tips and Tricks section. I want to ensure that anyone coming here for WiFi issues, sees this!

    What you need to know about the NOOK Color and WiFi

    There is quite an aggravating issue with the NOOK Color and WiFi connectivity. For those that do not know, this device does not like/support WPA2 security. To that end, I have put together a couple of options for those that are having issues!

    First, I am sorry to say that every wireless router is different and some of these options may not work for everyone!!

    • Multiple SSID

    Some routers support the feature of Multiple SSID. In other words, if your router is able, you can setup a second SSID in your router and set the security on that SSID to WPA or WEP or have it open. This will allow your WPA2 capable devices to connect to the WPA2 SSID and your NOOK to connect to the other SSID

    • Dual Mode Security

    Some routers support WPA + WPA2 security. Unfortunately, not all “home grade” routers implement this dual mode correctly and you may see intermittent to no connectivity. If you implement this method, you should set the WPA and WPA2 passwords to be different!!

    • Secondary Router

    If you have recently upgraded to an N router and you still have your old device, you can connect one of the ports on your new router to the WAN port on the old unit, give it a static IP Address and setup the old unit to WPA or WEP security and have your NOOK connect to it. Your NOOK will now get its IP address (different range than the N router) from the secondary WiFi AP and achieve internet connectivity through it.

    ***Important to have a little Networking acumen to set this up correctly so if anyone wants to attempt this and needs help just PM me!

    • WPA only

    Fairly self explanatory! Just set all your other nodes to WPA! Of course, your security level is now diminished but not too bad!

    • WEP

    Fairly self explanatory! Just set all your other nodes to WEP! Of course, your security level is now diminished to a “crackable” level!

    • Open AP

    Fairly self explanatory! All nodes can connect including any node within range of your AP!

    **Remember, ANYONE in range of your AP can connect to your network!!!


  2. cabbie

    cabbie Android Expert

    My NC connects to a WPA/WPA2 dual fine.

    My current issue is tethering from an HTC Evo running MikFroyo. The hacked up Sprint Hotspot works but just on 3g. Wireless tether 2.0.6 was recommended to me and while NC sees the network, it hangs on obtaining IP address.
  3. A.Nonymous

    A.Nonymous Extreme Android User

    I connect mine to WPA2 as well with no issues. I'm just using stock rooted.
  4. jayjay1122

    jayjay1122 Android Expert
    Thread Starter

    Interesting, what firmware are you running?
  5. A.Nonymous

    A.Nonymous Extreme Android User

    I had updated it to whatever version was right before 1.1.0 and then BN downgraded it automatically to 1.0.0. I never bothered to install the latest, greatest firmware on it. I just didn't see the point. What I had worked and I didn't see any amazing new features in the new FW. I don't have it in front of me right now as I'm at work so I can't confirm. I'm reasonably sure it's 1.0.0.
  6. jayjay1122

    jayjay1122 Android Expert
    Thread Starter

    Thanks for the info A.Nonymous, when you have time to check, post back with the info. Once you know, I will load that firmware and run some tests.

    It might make sense then for me to update the OP to reflect the info based on firmware!!

  7. jayjay1122

    jayjay1122 Android Expert
    Thread Starter


    Are you running a mix of WPA and WPA2 clients connected to the router and if so, are you using different passkeys for the two levels of encryption?
  8. A.Nonymous

    A.Nonymous Extreme Android User

    No, no mixed mode. Just running WPA2 personal. Only one encryption key.
  9. jayjay1122

    jayjay1122 Android Expert
    Thread Starter

    That question was to Cabbie! ;)
  10. A.Nonymous

    A.Nonymous Extreme Android User

    Tells me my firmware is 1.1.0, but that's because I did the build.prop edit/fix. I'm fairly certain that in reality I'm running 1.0.0.
  11. DenverCZBob

    DenverCZBob Member

    My experience with my Wife's NC is making me think it has an issue with 'N' routers. I could get it to connect (and have internet) to mine as long as I limited the speed to 54mps. That was using wpa2(AES). I finally just left my old 'G' router plugged in and connected to my network so I could get my 'N' router back up to normal 'N' speeds for my other devices.
    Wish there was a way to tell the Nook itself to slow down so I could still have it connect to my 'N' router without slowing the router down itself...oh well, maybe in a future update from B&N.

  12. A.Nonymous

    A.Nonymous Extreme Android User

    I have set my router to N only before and had no problems with the Nook. My Kindle couldn't connect, but the NC had no problems.
  13. DenverCZBob

    DenverCZBob Member

    Cool, what router do you have?

  14. jayjay1122

    jayjay1122 Android Expert
    Thread Starter

    Bob, the NOOK should have no problem connecting to an N router. I have had mine connect to my Netgear when it was set to both 145mbps and up to 300mbps as long as security was set to WPA or lower...It was more likely the WPA2 security that was the issue.

    Let me guess, you connected to WiFi and it said "Connected to Internet" then immediately switched to "Testing"?
  15. DenverCZBob

    DenverCZBob Member

    My original setup was full speed 'N' and zero security but using a mac address filter to limit what devices connected, and with that setup, yes, it connected but no internet. :(

  16. BiggHoss

    BiggHoss Lurker

    So I unrooted my nook color n now I have no wifi. Cwm is still there n not sure how to get rid of it. I used manual n n it work but b&n still came up n tried a diff manual n n now I can't factory reset or hard reset n still no wifi. Please help me.
  17. Benito_EM

    Benito_EM Lurker

    Let me start by saying I'm running
    kernel version " erik@myhost #151"
    On my Nook Color.
    I had never had any problems connecting to my wireless router at home until I recently had major crash issues with 7.1.0 and re-installed it exactly as before.
    Now, I cannot connect to the internet through my wifi router at home. I went to check WiFi at a public place and was able to connect, so it's not total inability to use WiFi, only with my home network.
    I have a Westell model 7500 gateway.
    So, since I've encountered this problem yesterday I've tried:
    Running "fix permissions" in ROM Manager as per another suggestion I'd read. It had no effect.
    After that:
    switching to a static IP
    IP addresses ( and and now
    Gateway (
    DNS 1
    DNS 2

    This finally enabled me to connect to the router, but I was still not able to connect to the internet. I know there was an internet connection to the router because my desktop PC was working).
    I even desperately tried something way out of my league as a final, desperate measure. I found instructions to enter some commands in termainal emulator as a superuser to eliminate some lines of code about wifi. I cannot remember what they are. No effect.
    Let me also add I checked the router settings through my provider and wireless was active. I've also turned off the router a few times using the on/off switch and even did a full reset.
    So, now, I've re-reinstalled 7.1.0 yet again to start clean (in case I messed anything up with my attempts) but am out of ideas.
    Thanks in advance for your help.
  18. stef7

    stef7 Android Expert

    Is your router broadcasting the SSID?

Share This Page