1. Are you ready for the Galaxy S20? Here is everything we know so far!

Not detecting SD card. Tried formatting as well!

Discussion in 'Android Devices' started by taylormah, Sep 19, 2011.

  1. taylormah

    taylormah Well-Known Member
    Thread Starter

    I inserted my 2 year old class 4 8GB sandisk card which I used to use with win-mobile treo, but it did not detect the card. So I inserted the card in PC and did a quick format in FAT32, but still same results. In settings->storage, under sd card it says unavailable under total space, but its still clickable, while the mount card is disabled/unclickable. Any help would be highly appreciated. Thanks!!

  2. RazzleFnDazzle

    RazzleFnDazzle Well-Known Member

    What do you mean by it is still clickable? I switched my card in and had no problem. Does your phone recognize the card? The phone itself can do a format of the sd card from the settings -> storage option. Also make sure the card is in well. I don't think it is completely easy to tell that the sd card is in all the way.
  3. taylormah

    taylormah Well-Known Member
    Thread Starter

    This is what I meant:

    Total Space and Available Space are enabled, but upon click they dont do anything. Whereas Mount SD and Format SD are disabled. This is a screen shot with sd card inserted. I noticed that even if I remove the sd card, these button's state's dont change - meaning that phone is not even realizing that I inserted the sd card, but then I noticed that whenever I remove the sd card, in the status bar, "SD card removed" or something similar message flashes for a half a second. Any ideas?
  4. Exit24

    Exit24 Member

    Do you happen to have any extra microSD cards? If so, try putting one in to see if it recognizes it. If you don't have one, try and borrow a friends... It might just be a bad SD card.
  5. RazzleFnDazzle

    RazzleFnDazzle Well-Known Member

    I'm going to have to agree with Exit on here. It is best to try a different micro sd card first. If the format SD card is available it is working. However, I'm more shocked at the fact you get a message saying it was removed. I don't have any direct experience with the phone and sd card doing that, but in general I've had issues with bad micro sd cards being recognized as plugged in but cannot be recognized by the computer.
  6. taylormah

    taylormah Well-Known Member
    Thread Starter

    Ok guys, I found a solution. I downloaded a utility called SDFormatter from sdcard.org website, and then formatted my card using that utility. And even if the first run it worked. So somehow window's inbuilt formatting program was not doing a good job of formatting on my sd card.
  7. unplugged1

    unplugged1 Android Enthusiast

    This reminds me of the advice given on my HD video camera: When placing a new card or formatting an old card, always format the card in the camera. Do not format the card in your PC.

    I guess this applies to phones also.
  8. Exit24

    Exit24 Member

    Glad to hear you got it to work :)

Samsung Epic 4G Touch Forum

The Samsung Epic 4G Touch release date was September 2011. Features and Specs include a 4.52" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1800mAh battery.

September 2011
Release Date

Share This Page