1. Download our Official Android App: Forums for Android!

General Not receiving notifications of received email from Yahoo, Gmail

Discussion in 'Android Devices' started by SSemel, Aug 3, 2016.

  1. SSemel

    SSemel Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Aug 3, 2016

    Aug 3, 2016
    8
    4
    26
    Male
    I just bought a new J7 running 6.0.1 on Boost Mobile's network, last week. It is not displaying visual notifications of received emails at the top of the notification area on the home screen. I used Samsung.com's live chat to troubleshoot this with the online tech support, and the tech remotely accessed my phone to investigate. Sending myself test emails showed that the tech's efforts did not work. The tech's only solution is to delete both the Samsung app and Google app, and then to do a factory reset. As I just bought the phone last week and spent days setting it up the way I want it, I don't want to factory reset it and have to go through all that work again. Does anyone have a better solution?

     

    Advertisement

    imranmansoor likes this.
  2. wardnkathy

    wardnkathy Member
    Rank:
    None
    Points:
    28
    Posts:
    64
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    64
    20
    28
    Which email so are you using? Are you trying to use both the Gmail and Email apps at the same time for the same email accounts?
     
  3. SSemel

    SSemel Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Aug 3, 2016

    Aug 3, 2016
    8
    4
    26
    Male
    I'm using the Yahoo Mail app and the Gmail App. I don't use the stock email app that came with the phone. On my previous S3 phone, I used both Yahoo and Gmail apps and had no problem: each one would display a notification in the status bar whenever each one received a new email. But on my new J7, only Gmail is displaying a notification. Yahoo is not.
     
  4. wardnkathy

    wardnkathy Member
    Rank:
    None
    Points:
    28
    Posts:
    64
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    64
    20
    28
    I assume you have notifications turned on in the Yahoo app. If you go to Android's application manager by pulling down the top menu, picking the gear to go to settings, then selecting applications and finally application manager then looking at the Yahoo app settings that notifications are turned on.
     
  5. SSemel

    SSemel Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Aug 3, 2016

    Aug 3, 2016
    8
    4
    26
    Male
    Yes, all the notifications setting are on in the Application Manager for Yahoo Mail, and the notifications are on in the Yahoo app itself. Still, no notifications are displayed for new emails.
     
  6. wardnkathy

    wardnkathy Member
    Rank:
    None
    Points:
    28
    Posts:
    64
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    64
    20
    28
    I am out of ideas but I would just try uninstalling and reinstalling the Yahoo app before I did a factory reset.
     
  7. storageman

    storageman Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    88
    Joined:
    Jan 12, 2012

    Jan 12, 2012
    88
    20
    38
    Male
    My Yahoo & Gmail apps do not show message notifications even though they are set to do so. I have and outlook app and it does show notifications along with a private email app. I actually think its good. On my old GIII, the gmail app would constantly be buzzing and shaking for every email received.
     
  8. Hayat52

    Hayat52 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Nov 30, 2016

    Nov 30, 2016
    4
    0
    15
    Male
     
  9. Hayat52

    Hayat52 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Nov 30, 2016

    Nov 30, 2016
    4
    0
    15
    Male
    Make sure you have power saving turned off to get notifications
     
  10. SSemel

    SSemel Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Aug 3, 2016

    Aug 3, 2016
    8
    4
    26
    Male
    Thanks! That worked.
     
  11. Joker420

    Joker420 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Aug 22, 2017

    Aug 22, 2017
    3
    1
    16
    I had the same problem with my s8 and here is what I found worked for me..
    Go to Apps in your phone settings, next select App manager. After that select the three dots on the top right corner, then select special access. after that go to Optimize battery usage. Then select all Apps. find Yahoo Mail and it should show that it is on (bar slid to the right). Turn this off. Samsung wants to save as much battery usage to make you use less battery. So if your like me you don't care that your saving battery, I just want to see notifications for my mail as soon as I get them. So you just turn off battery saver for that App. After that go to yahoo App in Apps. force stop or close it. Then go to your Yahoo mail settings (in the actual mail settings in yahoo). And scroll down to clear cache, select it and that should do it for you. I tested this today and this worked for me. If your having the same problems with other Apps. you should just be able to follow these steps and it should work. Let me know if this worked or helped you out.
     
    lilmama112290 likes this.
  12. manumzo

    manumzo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 8, 2017

    Sep 8, 2017
    1
    0
    5
    Thank you so much Joker420 for your solution. It worked perfectly for me on my galaxy S7. I was beginning to desperate ! I searched everywhere.
    You had a good idea to post your tip on this old subject.
    Thanks again !!!
     
  13. Joker420

    Joker420 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Aug 22, 2017

    Aug 22, 2017
    3
    1
    16
    Glad I could help.
     
  14. Fezmaster

    Fezmaster Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 1, 2017

    Dec 1, 2017
    1
    0
    5
    Thanks Joker worked a treat
     
  15. josianesaiure

    josianesaiure Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 25, 2018

    Jan 25, 2018
    1
    1
    5
     
    RohaWaRohaMenther likes this.
  16. Retired Engineer

    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Feb 18, 2018

    Feb 18, 2018
    3
    1
    16
     
  17. Retired Engineer

    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Feb 18, 2018

    Feb 18, 2018
    3
    1
    16
    I am a Samsung Galaxy S7 user on Verizon. I struggled for the better part of two years to get my Gmail working to my satisfaction. Namely, when someone sends me an email, I expect to get it in a very short time. I experienced the same problems that everyone posts about. The emails don't appear until you open the Gmail app. All of the comments about turning off power saver, deleting the app and reinstalling it, manually synching Gmail app did nothing. Many, many, many feedback responses to Google went unanswered. I tried all of the other apps like Blue Mail, Aqua Mail, K9 Mail, etc. And none worked any better. I then read about Microsoft Outlook and its good reputation for instantly pushing emails for their clients. I went to my Windows 10 laptop and opened Outlook. I installed my Gmail as an IMAP/SMTP account. I then downloaded the Outlook app on my S7. I added my Gmail account as an IMAP/SMTP account. Problem solved. I now get my Gmail as soon as the sender presses Send.

    I hope this helps somebody else. My daughter did the same as me and she is thrilled to finally have a Gmail account with instant push.
     

Share This Page

Loading...