1. Download our Official Android App: Forums for Android!

Note 2 possible APN issue

Discussion in 'Straight Talk' started by 83HatchGTI, Jan 5, 2014.

  1. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    So today I changed over from AT&T to Straight Talk on the bring your own phone feature.

    I used my Galaxy Note 2 (not a clone). I am able to place and receive phone calls as well as access the internet so far. My MMS is functioning to send pictures, however will not receive them. Also, my SMS does not function for sending or receiving text at all.

    I followed the instructions on Straight Talk for setting the APN. When I did that I had no internet or sending of MMS. I found on google some other APN settings which made my internet and sending MMS work.

    My current settings are as follows.

    Name: straight talk
    APN: tfdata
    Proxy: not set
    Port: 80
    MMSC: h t t p : / / mms-tf . net (without spaces)
    MMS Proxy: mms3 . tracfone . com (without spaces)
    MMS Port: 80

    It's only been 4 hours since I switched but I've spent basically that entire time trying different APN's I found online.

    Answered
     

    Advertisement

  2. Rukbat

    Rukbat Android Expert
    Rank:
    None
    Points:
    843
    Posts:
    10,392
    Joined:
    Jan 16, 2012

    Jan 16, 2012
    10,392
    2,894
    843
    Male
    Being retired and writing Tasker tasks.
    Fayetteville, NC, USA
    SMS is the same as voice - 2G. MMS - if you can access the internet you can send and receive MMS. IF the account is set up right.

    Go to ST's Facebook page - that's where all their better tech support people are. (Make an account if you don't have one.) They probably have to reprovision your account (it takes a few minutes, but just post, tell them that you can access the internet and make and receive calls, but you can't do SMS and can't receive [but can send] MMS).
     
  3. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    Okay I made a Facebook account and went to the support tab on their facebook. I chatted with a person from tech support, however they were unable to resolve my issue. It was the exact same thing as talking to a tech support member at their 800 number. It was a whole lot of

    "send yourself a text and see if you get it"
    Didn't work

    "okay turn your phone off and back on again"
    okay

    "try sending yourself a text and see if you get it"
    nope didn't work still

    "okay trying deleting your text messages, it's probably full"
    okay

    "restart the phone and try to send yourself a message"
    didn't work again

    "Okay make sure your APN settings are exactly as they are on our website"
    yep they are

    "Okay now try to reboot your phone again and send yourself a message"
    Wait a minute...you had me LOOK at my APN settings and since they're okay, we are just going to reboot again? Really?

    "Okay we are going to walk you through a factory reset of your phone. You will probably lose any pictures, video or music you had saved on the phone. Let me know when you are ready to go ahead with the process"
    Ummmm...CLICK...I hung up...

    Except the chat support operator hung up on me when I tried their facebook support. They simply disconnected leaving behind a message saying "to assist you further, we will need to speak to you directly, please call our 800 number blah blah blah". They basically had me do the same thing as the phone operator except they once even had me remove my sim card and put it back in then reboot.

    So...I still have no SMS or MMS.

    I don't feel like it's going to be an APN setting issue because I tried every APN I could find on google today. They all seem to allow me to do the same things and they all seem to restrict SMS. I find this odd because most people with APN problems, the main complaint seems to just be not being able to send/receive MMS only.

    What else could I do?
     
  4. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    I tried to upload photos of my APN settings but my pictures fail to upload even after resize. So I'll manually type them out. Let me know if you see any problems with my APN settings. I typed them exact to what I see in my phone right now.

    Name: Straight Talk
    APN: tfdata
    Proxy: not set
    Port: 80
    User Name: not set
    Password: not set
    Server: not set
    MMSC: http://mms-tf.net
    MMS Proxy: mms3.tracfone.com
    MMS Port: 80
    MCC: 310
    MNC: 410
    Authentication Type: not set
    APN type: default,mms,supl (<---added that myself and seems to not add to or fix my problem. Tried them in different orders and variations that included the * sign)
    APN Protocol: IPv4
    APN: enable box is ticked with a green check
    Bearer: Unspecified
     
  5. new optimus

    new optimus Android Expert
    Rank:
    None
    Points:
    413
    Posts:
    4,205
    Joined:
    Mar 10, 2011

    Mar 10, 2011
    4,205
    1,456
    413
    Jax Fl
    it appears you have it set up just like
    http://androidforums.com/straight-talk/768940-helping-you-setup-your-account-lte.html
    but double check, read all the info there. :D
     
  6. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    Yeah I'm set up just like that and my screen most of the time is showing LTE just like it did when I was with AT&T, except when I'm at work. AT&T didn't even give me LTE at work but that's okay.

    As of right now, straight talk is sending me a new sim card to try. It took my wife calling straight talk and using some serious attitude before they were willing to do anything else besides having me pull my battery and sim card out over and over.

    I'll update this thread when the sim card is here and I've had time to check it out. If this doesn't work I'm going back to AT&T and maybe a GOphone plan. I'll let everyone know.
     
  7. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    So my new SIM card arrived today. I installed it immediately and placed a call to Straight Talk via a different phone (wifes iPhone) to activate it. I am well finished activating my new SIM and am able to place calls as well as send MMS, yet still cannot receive them nor send/receive SMS yet. It's been a few hours now and nothing. This sucks. I don't want to wipe the phone but I guess I'm going to have to back every thing up to my PC and considering doing it anyway.
     
  8. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    I didn't want to wipe my phone completely but I tried it. Back to factory settings and still nothing. In the process of downloading all my apps and putting all my pictures back on my phone now. Blah.
     
  9. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    For anyone interested in hearing how this turned out, I sort of have an answer. My SMS and MMS both work now as well as internet.

    After putting my new SIM card in and having Straight Talk re-provision my account, then hard resetting my phone, it ended up working after about 5 hours. I kept trying to send SMS off and on during that time and suddenly a message made it to my wifes phone and she was able to reply. So far everyone in my contacts can get messages and reply. It was Straight Talks problem all along.
     
  10. new optimus

    new optimus Android Expert
    Rank:
    None
    Points:
    413
    Posts:
    4,205
    Joined:
    Mar 10, 2011

    Mar 10, 2011
    4,205
    1,456
    413
    Jax Fl
    ouch well at least its resolved.
    Ya I find straight talk can have problems, but fresh new account seems to fix it, they do not do well with re provisioning in my experience.
     
  11. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    UPDATE: So I crushed my Note 2 in a machine at work while using the flash light app on it. The sim card and memory card survived. I ordered a new Note 2 unlocked from Amazon. The only difference between the new phone and my old one aside from color, is that mine was not unlocked and this one is.

    I put my same sim card from the old phone into the new one. Everything worked again except mms. After going back and forth with ST trying to get a new sim card again, they had me set my apn mms proxy to "mms3 . tracfone . com" without the spaces. After a restart, I was able to send pictures to my wife and get pictures from her. I sent pictures to various contacts all morning and suddenly have a new problem. Now my pictures say they failed and have an exclamation point next to them in my inbox, but my contacts were still getting pictures after that occurred. I did a restart again and now they don't get pictures and I still get the exclamation point. Also I get a pop up that says Error: Network Error Occurred. Any ideas?
     
  12. 83HatchGTI

    83HatchGTI Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    9
    0
    5
    fixed this by deleting the APN type and now it says "Not set"
     

Share This Page

Loading...